Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: ATI 9000 RV250

  1. #1

    Default ATI 9000 RV250

    I wasn't sure where to post this or what to use as the title.

    Therefore, I tried to have everything as specific as possible.

    The machine that I have the issue with is a laptop. To be even more specific, a Thinkpad T41 with the following graphics card:

    IBM ThinkPad T41 , model 2373THD
    VGA compatible controller: ATI Technologies Inc Radeon RV250 [Mobility FireGL 9000] (rev 02)

    Issue: Cannot enable 3D effects or 3D effects results in lockup
    OpenSUSE 11.2 - KDE - cannot enable XRender - receive a message that it can't be enabled and to check my configuration file; enabling OpenGL results in the screen going black and a white cursor showing - laptop is totally locked up and requires a hard restart i.e. power off/on

    Is this a bug or a familiar state? I'm just curious what the situation is. Does it require an edit of xorg.conf and if so, what should be there?

    I've only used live media to test so far so if I can solve it via live media for now, that would be great.

    I guess my machine is quite old for using 3D but it would still be interesting to learn whether this issue could be solved.

    Thanks for reading!

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    10,616

    Default Re: ATI 9000 RV250

    Numerous threads on this topic within these forums. Sadly, I think your hardware is consigned to using the (limited) radeon driver now (as is my X300) should I choose to 'upgrade' to openSUSE 11.2 version.

  3. #3
    Join Date
    Aug 2008
    Location
    Temporarily, planet Earth
    Posts
    102

    Default Re: ATI 9000 RV250

    I've had success on one machine using the ATI proprietary driver. This thread has patches. I've followed directions for the patches and built an RPM. It worked on one machine, not another.

  4. #4

    Default Re: ATI 9000 RV250

    Quote Originally Posted by deano_ferrari View Post
    Numerous threads on this topic within these forums. Sadly, I think your hardware is consigned to using the (limited) radeon driver now (as is my X300) should I choose to 'upgrade' to openSUSE 11.2 version.
    What was the general consensus then of what to do? Was there any?

    I understand that the open source radeon driver is the main (only?) choice. However, as I previous stated, it works but only in 2D mode. That is, the default setting works since no 3D effects are enabled. When I enable 3D, I have issues presented that corrupt X. The last time I tried, one of the settings (OpenGL or XRender) makes the screen go 'black' with a frozen/locked white cursor displaying.

    I recently tried a few things using an Ubuntu Live CD. I edited xorg.conf and had some success at getting 3D to work. I chose Ubuntu since it gave the worst experience OTB. Would this edit apply to OpenSUSE, too? I suppose so, huh? I should try it.

    Anyway, I can post what I tried. Can anyone give me any feedback on what it is doing and why it 'helps?':

    Code:
    Section "Device"
         Identifier      "Radeon 9000"
         Driver          "ati"
         BusID           "PCI:1:0:0"
         Option        "BusType" "PCI"
         Option         "AGPMode" "1"
         Option          "AccelMethod"   "EXA"
    EndSection
    
    
    Section "Monitor"
         Identifier      "InternalLCD"
         Option          "DPMS"
    EndSection
    
    
    Section "Screen"
         Identifier      "Default Screen"
         Device          "Radeon 9000"
         Monitor         "InternalLCD"
         DefaultDepth    24
         SubSection "Display"
                 Depth           24
                 Modes           "1440x900" "1024x768"
         EndSubSection
    EndSection

  5. #5

    Default Re: ATI 9000 RV250

    Nevermind. It didn't work anyway.

  6. #6
    Join Date
    Jun 2009
    Location
    Pune city, India
    Posts
    135

    Default Re: ATI 9000 RV250

    Quote Originally Posted by kpenguin View Post
    Nevermind. It didn't work anyway.
    Hi,

    Refer this > Radeon - openSUSE

    I have IBM ThinkPad T60 with Ati Radeon x1300 graphics & encountered similar problem. I beleive above link will be definitely useful to you.

    I just followed tutorial and it worked!
    - ran Sax2
    -It created xorg.conf file under /etc/X11
    -Did vi to xorg.conf
    -renamed radeonhd to radeon as my chip set is not hd
    -saved the file
    -logged off and logged in back
    - ran rendering test and got output as YES.

    Regards,
    AmeY.

  7. #7

    Default Re: ATI 9000 RV250

    Quote Originally Posted by kpenguin View Post
    Anyway, I can post what I tried. Can anyone give me any feedback on what it is doing and why it 'helps?':
    The open source driver has a lot of features off by default, because not all of them are stable on all configurations. By explicitly providing an xorg.conf, you override those default settings and can get better performance. Also, in my case, HAL didn't seem to properly detect my card bus type; by explicitly setting it things became a lot more stable.

    I wouldn't just copy that config from wherever though, since a lot of the settings are very specific to your machine (i.e. "BusID" has to be whatever the BusID of your actual card is). Also, the driver name is wrong in that config; it's supposed to be "radeon". I'd follow the instructions in the wiki page that sco1984 posted a link to, because I wrote it.

  8. #8

    Default Re: ATI 9000 RV250

    One problem is that this program, Sax2, is unreliable.

    I was able to start it initially but when I wanted to modify a setting, the icon just bounces and then disappears. Nothing starts.

    When I was able to run it the first time, I could enable XRender but not OpenGL. It's an improvement but not useful if you can't run the utility. The xorg.conf generated is quite extensive, though. That part in interesting.

    Other than that, it's disappointing.

  9. #9

    Default Re: ATI 9000 RV250

    Is there no update with this issue yet?!?

    I was just curious: what bus type should be set for my card, RV250? I tried both but there was no real difference in result.

  10. #10

    Default Re: ATI 9000 RV250

    Quote Originally Posted by kpenguin View Post
    Is there no update with this issue yet?!
    You have a few issues here, which ones are still bothering you?

    Quote Originally Posted by kpenguin View Post
    I was just curious: what bus type should be set for my card, RV250? I tried both but there was no real difference in result.
    RV250 is your chipset, not your card. You need to find out what your card is, and find out what bus type it has.

    Using Google, I found this:
    ATI Mobility FireGL 9000 - ThinkWiki

    Assuming the same card is inside your Thinkpad, you should probably set BusType to "AGP", and if you want a little more performance, set AGPMode to "4".

    Quote Originally Posted by kpenguin View Post
    One problem is that this program, Sax2, is unreliable.
    I wouldn't use SaX2 for anything other than generating an initial xorg.conf. It will not let you configure many of the driver settings.

    Quote Originally Posted by kpenguin View Post
    I was able to start it initially but when I wanted to modify a setting, the icon just bounces and then disappears. Nothing starts.
    Are you using KDE? I'm pretty sure that's a bug with kdesu not starting, and not directly related to SaX2. I'm not sure what causes it or how to fix it (there are probably other threads about this that I have not read), but you can start SaX2 by running it in a terminal window as root.

    Quote Originally Posted by kpenguin View Post
    When I was able to run it the first time, I could enable XRender but not OpenGL.
    Let's make sure OpenGL is working... type "glxgears" in a terminal window. A new window should pop up with spinning gears if it's working. If that doesn't happen, tell us what you see.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •