Page 1 of 8 123 ... LastLast
Results 1 to 10 of 77

Thread: VNC is not working

  1. #1
    maier-tech NNTP User

    Default VNC is not working

    Hallo,
    after installing OpenSuse 11.2 (32Bit) I have two problems. One is, that the VNC in not working. The behavior is quite simple explained: After accessing from another machine with VNC-Viewer, the window is coming in the right size, but it remains black. There is no login-dialog opening. When looking in the messages it's clear, the VNC is correctly working, but it's not starting a KDE. This bug is well known in lots of forums but the solution is missing. Does anybody really know a solution, or better a programmer can change this ?
    Kind Greeeez, Klaus

  2. #2
    Join Date
    May 2009
    Location
    EU
    Posts
    1,009

    Default Re: VNC is not working

    Are you trying to access another openSUSE / Linux PC or Windows PC? I had no trouble with KRDC (KDE's VNC viewer) accessing a XP desktop. I just set XP to allow remote desktop access then used KRDC through RDP to access the PC. It worked well. Check out this link.

    However if you're trying to get remote access to another openSUSE box using the Krfb server (KDE's VNC server) then yes there is a bug. I tried all sorts of things to get it working but it just failed at the authentication every time. It's a known bug and has been around for a while.
    IBM Thinkpad X60s | Intel L2400 | Intel 945GM | 3GB | openSUSE 12.3 | KDE4.10.1
    ASUS M3N78 | AMD 64x2 5400+ | nvidia 8200+ | 2GB | openSUSE 12.3 | KDE4.10.1
    Acer Aspire Revo R3610 | Atom 330 | nvidia ION | 2GB | openSUSE 12.3 | KDE4.10.1

  3. #3
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    10,844
    Blog Entries
    2

    Default Re: VNC is not working

    VNC as a server, serving up a KDE window to a client, has been problematic for all of the openSUZSE 11.x versions because VNC from KDE4 is problematic. The workarounds to get it going nicely with TightVNC in openSUSE 11.0 and 11.1 are detailed here:
    TightVNC (VNC Xvnc) on openSUSE as Client or Server (Remote Desktop Connections)
    I haven't tried that in openSUSE 11.2, see if it still works.

  4. #4
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    25,626
    Blog Entries
    29

    Default Re: VNC is not working

    At the risk of sounding like a broken record, vnc from openSUSE-11.2 PC to another openSUSE-11.2 PC works fine for me.

    For vnc, all I do is copy and paste the following where computer-a (ip 192.168.2.110) is going to take over the desktop of computer-b (ip 192.168.2.111):

    computer-a >
    ssh -t -L 5900:localhost:5900 oldercpu@192.168.2.111 'x11vnc -localhost -nolookup -nopw -display :0'

    and in a second console , also on computer-a

    computer-a > vncviewer -encodings "tightvnc copyrect hextile" localhost:0

    ...
    where "oldercpu" is an account on computer-b that is running, and thats it. The typing can be reduced by using a script, or a copy and paste from a text file on one's desktop (where the text file contains commonly used long command expressions)

    I did NOT spend one second configuring anything else, other than to open up my firewall for ssh and for vnc. And I also installed tightvnc and x11vnc for the above. No other config files to configure.

    I've been using this technique for over 2 years to remotely maintain my mother's PC a continent away. (I've lost count - maybe for over 3 years). It worked in openSUSE-10.2 and it worked in openSUSE-10.3, and in 11.0, and in 11.1 and it now "just" works now in 11.2.

    Note there is NOT a lot of typing to do. Rather one can either:
    a. copy this to a text file kept on one's desktop and copy and paste it into a terminal when needed,
    b. put it in a script that is linked to an icon on one's desktop, or mapped to a specific key,
    c. use the history command to recall the last time one ran the command, and then simply copy and paste it again.

  5. #5
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    10,844
    Blog Entries
    2

    Default Re: VNC is not working

    What's the D.E. on the server at your mother's place oldcpu?

  6. #6
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    25,626
    Blog Entries
    29

    Default Re: VNC is not working

    Quote Originally Posted by swerdna View Post
    What's the D.E. on the server at your mother's place oldcpu?
    My mother is currently running openSUSE-11.1 with KDE-3.5.10.

    Before under openSUSE-10.2 she was running KDE-3.5.5.

  7. #7
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    10,844
    Blog Entries
    2

    Default Re: VNC is not working

    Quote Originally Posted by oldcpu View Post
    My mother is currently running openSUSE-11.1 with KDE-3.5.10.

    Before under openSUSE-10.2 she was running KDE-3.5.5.
    And there's the rub oldcpu. VNC is pretty good whatever the flavour if using KDE 3 or Gnome. It's only bad for serving a KDE4 desktop.

  8. #8
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    25,626
    Blog Entries
    29

    Default Re: VNC is not working

    Quote Originally Posted by swerdna View Post
    And there's the rub oldcpu. VNC is pretty good whatever the flavour if using KDE 3 or Gnome. It's only bad for serving a KDE4 desktop.
    Hmmm ... perhaps true for many cases. ... although with those commands I can go from a KDE4 PC to a KDE4 PC. I've done this to/from the PCs on my home LAN.

  9. #9
    Join Date
    May 2009
    Location
    EU
    Posts
    1,009

    Default Re: VNC is not working

    Quote Originally Posted by swerdna View Post
    VNC as a server, serving up a KDE window to a client, has been problematic for all of the openSUZSE 11.x versions because VNC from KDE4 is problematic. The workarounds to get it going nicely with TightVNC in openSUSE 11.0 and 11.1 are detailed here:
    TightVNC (VNC Xvnc) on openSUSE as Client or Server (Remote Desktop Connections)
    I haven't tried that in openSUSE 11.2, see if it still works.
    I could not get this working with 11.2 KDE server to 11.1 KDE client. I have no idea why. I even disabled the firewalls to make sure it wasn't them but that made no difference. When I try connecting to the server nothing would happen. No password prompt or anything.

    However oldcpu's method does work.
    IBM Thinkpad X60s | Intel L2400 | Intel 945GM | 3GB | openSUSE 12.3 | KDE4.10.1
    ASUS M3N78 | AMD 64x2 5400+ | nvidia 8200+ | 2GB | openSUSE 12.3 | KDE4.10.1
    Acer Aspire Revo R3610 | Atom 330 | nvidia ION | 2GB | openSUSE 12.3 | KDE4.10.1

  10. #10
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    10,844
    Blog Entries
    2

    Default Re: VNC is not working

    Quote Originally Posted by suse_tpx60s View Post
    I could not get this working with 11.2 KDE server to 11.1 KDE client. I have no idea why. I even disabled the firewalls to make sure it wasn't them but that made no difference. When I try connecting to the server nothing would happen. No password prompt or anything
    I've just check out TightVNC for an openSUSE 11.2 server, serving a KDE4 desktop. It works fine using standard RPMs and standard setup. So if it's not working for you, can I see some of your setup: please post here the results of these three diagnostic console commands:
    1. cat /home/your_username/.vnc/xstartup
    2. cat /etc/sysconfig/SuSEfirewall2 | egrep "CONFIGURATIONS_EXT=|DEV_EXT="
    3. rpm -qa | egrep "vnc|VNC"
    4. and fifth, please show the exact command you use to start a vnc server
    5. sixth and finally, what do you get from this command after you've set the server running:
      Code:
      ps -aux | egrep "Xvnc|xstartup"

Page 1 of 8 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •