Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Installing Novell Client on 11.2

  1. #1
    Join Date
    Jan 2009
    Location
    Szkesfehrvr, Hungary
    Posts
    15

    Question Installing Novell Client on 11.2

    When trying to install Novell client (novell-client-2.0-sp2-sle11-i586.iso) on my 11.2 box, I get the following error: "Problem: nothing provides libbfd-2.19.so needed by novell-xtier-base-3.1.6-12.i586".

    The libbfd library is provided by binutils. I have binutils-2.19.51-10.26.4.i586 installed, and it provides /usr/lib/libbfd-2.19.51.20090527-10.26.4.so. I made symlinks (/lib/libbfd-2.19.so and /usr/lib/libbfd-2.19.so) but it didn't help.

    Do you guys know any solution? Thanks in advance.
    Last edited by adosztal; 14-Nov-2009 at 01:42. Reason: typo

  2. #2
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,562

    Default Re: Installing Novell Client on 11.2

    * adosztal,

    locate the novell-xtier-base-3.1.6-12.i586.rpm and install it with
    rpm -Uvh novell-xtier-base-3.1.6-12.i586.rpm --nodeps

    Now run the nlc_install script.

    No idea if this will result in a working Novell client, but it is unsupported on openSUSE 11.2 anyways ;-)

    Please note that the Novell client specialists hang out over on forums.novell.com. Please post there if this didn't help you.

    Uwe

  3. #3
    Join Date
    Jan 2009
    Location
    Szkesfehrvr, Hungary
    Posts
    15

    Default Re: Installing Novell Client on 11.2

    Install was successful but I got the same error when trying to start it.

    I know it's for SLE11, I just gave it a try.

  4. #4

    Default Re: Installing Novell Client on 11.2

    I've got it working on an 11.2 system (granted it was an upgrade from 11.1, but it did reinstall novclient when I did a zypper dup to upgrade). I made a symlink for the version of libbfd that it wanted against the version of libbfd that comes with 11.2 (which is a minor update to the 11.1 version) and after running client configuration through Yast it has been fine.

  5. #5
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,562

    Default Re: Installing Novell Client on 11.2

    * ryuu7988 wrote, On 11/14/2009 08:26 PM:
    > I've got it working on an 11.2 system (granted it was an upgrade from
    > 11.1, but it did reinstall novclient when I did a zypper dup to
    > upgrade). I made a symlink for the version of libbfd that it wanted
    > against the version of libbfd that comes with 11.2 (which is a minor
    > update to the 11.1 version) and after running client configuration
    > through Yast it has been fine.


    Can you give me the exact versions you see, please?
    This is interesting: While I got the Novell client up and running with the 11.2RC, I got a KDM error upon login with the released version.

    Uwe

  6. #6
    Join Date
    Jan 2009
    Location
    Szkesfehrvr, Hungary
    Posts
    15

    Default Re: Installing Novell Client on 11.2

    Quote Originally Posted by ryuu7988 View Post
    [...] I made a symlink for the version of libbfd that it wanted against the version of libbfd that comes with 11.2 [...]
    What was this symlink? I tried /lib/libbfd-2.19.so and /usr/lib/libbfd-2.19.so but it didn't help.

  7. #7

    Lightbulb Re: Installing Novell Client on 11.2

    I just got this working on my laptop (64bit OpenSuSE 11.2 - fresh install).

    Steps to Make It Work:
    1) Grab the binutils-2.19-9.3.x86_64.rpm from whatever mirror is handy. Make sure it matches what novell client you're trying to install in terms of arch.
    2) Grab the latest and greatest novell client ISO from novell.
    3) rpm2cpio binutils-2.19-9.3.x86_64.rpm | cpio -idv
    4) You now have ./usr in your directory. Copy all the library files to the right places. If you're 64bit, you'll see ./usr/lib64 and the .so files need to be copied to /usr/lib64. If you don't have a fresh install, check to make sure there's no symlinks or whatever in the way.
    5) Mount the novell ISO as loopback. Unlike previous releases, you MUST use ncl_install for the installation. Adding it to yast and using package groups is a recipe for delicious fail.
    6) Choose to ignore any grousing about libbfd. Break dependencies! (This is "option 2").
    7) ldconfig and reboot.

    Tada.

  8. #8
    deryk NNTP User

    Default Re: Installing Novell Client on 11.2

    Hi folks,

    Thanks to jknarr for explaining how to do this. Works a charm.

    I couldn't get auto-login to work - for some reason the entry it creates in Startup Applications doesn't work. The command it uses is '/opt/novell/ncl/bin/gnome-login.bsh'. I suspect that it might not like the quotation marks.

    I did a combination of 2 things to get it working:
    Added the following line to the end of /etc/bash.bashrc...
    PATH=$PATH:/opt/novell/ncl/bin
    Created a new item under Startup Applications (Control Centre)
    Name: Novell Login Command: gnome-login.bsh

    Now it logs in and maps the drives automatically

    I suspect a tidier way to fix this might be to edit /opt/novell/ncl/bin/ncl_autologin.desktop and remove the quotation marks (as well as giving it a better name than "No name") as it probably just copies this file to your Gnome profile. Haven't tested this yet.

  9. #9
    deryk NNTP User

    Default Re: Installing Novell Client on 11.2

    Sorry to double post. Thought I'd be able to pop back and edit my original comment, but was mistaken.

    Rather than what I suggested above for auto-login, I've poked around a little more and found a better way that should fix it for all users. There's no need to add the path to bash.bashrc as it's already being added to the path somewhere else.

    Just open /opt/novell/ncl/bin/ncl_autologin.desktop and replace the contents with the following:

    Code:
    [Desktop Entry]
    Type=Application
    Exec=gnome-login.bsh
    Hidden=false
    X-GNOME-Autostart-enabled=true
    Name=Novell Login
    Comment=Automatically login to the Novell network
    After logging out and in a few times, and possibly running ncl_autologin to establish the startup item, it starts working. I can only assume that the format of the .desktop file has changed, or perhaps the Type field is required nowadays.

    Seems to me a good idea is to also edit /etc/gdm/PostSession/Default and add:
    nwlogout -t NAME_OF_TREE
    before the 'exit 0'. This should logout the user if they log out of GNOME, rather than just leaving their connection hanging there like it does by default.
    Edit: Nnnngh that doesn't seem to work either!

  10. #10
    deryk NNTP User

    Default Re: Installing Novell Client on 11.2

    BINGO

    The logout script runs as root, so you have to run it as $USER instead. Also you have to put the nwlogout line BEFORE the Xreset lines, as the Xreset script... does what it says on the tin, and kills the $USER variable.

    So, just after #!/bin/sh in /etc/gdm/PostSession/Default :

    su $USER -c '/opt/novell/ncl/bin/nwlogout -t TREE_NAME_HERE'

    Does the trick here.

    Feel free to merge these 3 posts.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •