Results 1 to 9 of 9

Thread: sound on dell Inspiron 1545

  1. #1

    Cool sound on dell Inspiron 1545

    i recently changed from fedora 9 to OpenSuse 11.1 on
    a dell Inspiron 1545, sound card
    828011 (ICH9 Family) HD Audio controller according to yast.
    configured as sound card nr 0, driver= snd-hda-intel.
    I played around with settings, but have no sound.
    I have no clue where to look, i'm lost.
    thanks for any advise this
    johan

  2. #2
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    25,839
    Blog Entries
    30

    Default Re: sound on dell Inspiron 1545

    Now the general advice I give for sound problems is to start trying to work your way through the openSUSE audio troubleshooting guide: SDB:AudioTroubleshooting - openSUSE .

    Do NOT use the startup system sound as your criteria for stating sound does not work. Also be certain to check your mixer. Its not uncommon for a mixer setting (master, pcm or speaker) to be muted upon boot. In KDE your mixer is "kmix" (the small speaker in right hand corner). In Gnome your mixer is "alsamixer".

    Note, when testing if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole:

    speaker-test -Dplug:front -c2 -l5 -twav

    Note Linux is case sensitive, and D is not the same as d. To stop the above test, while the konsole/xterm has the mouse focus, press <CTRL><C> on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 95%. Once you have basic sound established you can back off to lower volume levels. Note the test for surround sound is different.

    If that test yields errors (and its not uncommon to get errors there), try instead this more simple test:
    speaker-test -c2 -l5 -twav
    You should hear a female voice saying 'FRONT LEFT', 'FRONT RIGHT' five times. Its quite common that one of those speaker tests will work and one will NOT work, so don't be distressed if that is the case. IF that test gives sound, stop now, post that the sound test gives sound, and we will look at other possible causes for your applications not giving you the sound you want (such as missing codecs, using the wrong packaged version ... etc ... ).

    Or alternatively, for testing the simple playback, use aplay program. Prepare a WAV file and simply run like:
    Code:
    aplay -vv somefile.wav
    With the option -vv, aplay shows the verbose information of the PCM device, and a VU-peak meter during playing the file.

    Try those speaker-tests as both a regular user, and also with root permissions. If you have a headset, try with your headset plugged in, and also with your headset not plugged in (for speakers).

    Assuming no sound, can you provide more very detailed information so a good recommendation can be given? For openSUSE-11.1, you can do that, with your laptop connected to the internet, by opening a gnome-terminal or a kde konsole and twice copy and paste the following into that terminal/konsole
    Code:
    /usr/sbin/alsa-info.sh
    Run it the 1st time with root permissions. It will ask if you wish to do an update of the script. Select YES.

    Then run it again (as either a regular user or as root). This time it will diagnose your PC's hardware and software configuration for audio, and it will post its output on the Internet/web. It will give you the URL of the web site. Please post that URL here. JUST the URL.

    If you are not using openSUSE-11.1, please advise.

    Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output:
    rpm -qa | grep alsa
    rpm -qa | grep pulse
    rpm -q libasound2
    uname -a
    cat /etc/modprobe.d/sound
    ... with that information I may be able to make a recommendation.

    Also, do NOT waste too much time on this. Simply post on our forum if you get stumped, and continue to look for help that way.

  3. #3

    Cool Re: sound on dell Inspiron 1545

    hey,
    thanks for helping me out.
    i AM running OpenSuse 11.1

    kmix is at 100 %

    i ran all the tests, output 1st one is same for user as root.

    On the 2nd one i hear nothing, not from speaker of headset.

    here's the output:

    linux-g1qz:~ # speaker-test -Dplug:front -c2 -l5 -twav

    speaker-test 1.0.18

    Playback device is plug:front
    Stream parameters are 48000Hz, S16_LE, 2 channels
    WAV file(s)
    Rate set to 48000Hz (requested 48000Hz)
    Buffer size range from 64 to 262144
    Period size range from 32 to 131072
    Using max buffer size 262144
    Periods = 4
    Unable to set hw params for playback: Invalid argument
    Setting of hwparams failed: Invalid argument

    jvermeulen@linux-g1qz:~> speaker-test -c2 -l5 -twav

    speaker-test 1.0.18

    Playback device is default
    Stream parameters are 48000Hz, S16_LE, 2 channels
    WAV file(s)
    Rate set to 48000Hz (requested 48000Hz)
    Buffer size range from 2048 to 16384
    Period size range from 1024 to 1024
    Using max buffer size 16384
    Periods = 4
    was set period_size = 1024
    was set buffer_size = 16384
    0 - Front Left
    1 - Front Right
    Time per period = 2.673493
    0 - Front Left
    1 - Front Right
    Time per period = 3.050160
    0 - Front Left
    1 - Front Right
    Time per period = 2.986735
    0 - Front Left
    1 - Front Right
    Time per period = 3.007959
    0 - Front Left
    1 - Front Right
    Time per period = 3.008100

    linux-g1qz:~ # speaker-test -c2 -l5 -twav

    speaker-test 1.0.18

    Playback device is default
    Stream parameters are 48000Hz, S16_LE, 2 channels
    WAV file(s)
    Rate set to 48000Hz (requested 48000Hz)
    Buffer size range from 2048 to 16384
    Period size range from 1024 to 1024
    Using max buffer size 16384
    Periods = 4
    was set period_size = 1024
    was set buffer_size = 16384
    0 - Front Left
    1 - Front Right
    Time per period = 2.685850
    0 - Front Left
    1 - Front Right
    Time per period = 3.008087
    0 - Front Left
    1 - Front Right
    Time per period = 3.007941
    0 - Front Left
    1 - Front Right
    Time per period = 3.008248
    0 - Front Left
    1 - Front Right
    Time per period = 3.029036ne

    Your ALSA information is located at http://www.alsa-project.org/db/?f=70...0eb0f2a835d8d8

    jvermeulen@linux-g1qz:~> rpm -qa | grep alsa
    alsa-1.0.18-8.12.1
    alsa-firmware-1.0.17-1.42
    alsa-oss-1.0.17-1.37
    alsa-plugins-pulse-1.0.18-6.12
    alsa-utils-1.0.18-6.4
    alsa-plugins-1.0.18-6.12
    alsa-tools-1.0.18-1.13
    alsa-devel-1.0.18-8.12.1

    jvermeulen@linux-g1qz:~> rpm -qa | grep pulse
    pulseaudio-lang-0.9.14-2.2.1
    libpulse-browse0-0.9.14-2.2.1
    pulseaudio-module-lirc-0.9.14-2.2.1
    libpulse0-0.9.14-2.2.1
    libxine1-pulse-1.1.15-23.3.3
    pulseaudio-module-jack-0.9.14-2.2.1
    alsa-plugins-pulse-1.0.18-6.12
    pulseaudio-0.9.14-2.2.1
    pulseaudio-module-x11-0.9.14-2.2.1
    pulseaudio-utils-0.9.14-2.2.1
    pulseaudio-module-zeroconf-0.9.14-2.2.1
    pulseaudio-module-bluetooth-0.9.14-2.2.1
    libpulse-mainloop-glib0-0.9.14-2.2.1
    pulseaudio-esound-compat-0.9.14-2.2.1

    jvermeulen@linux-g1qz:~> rpm -q libasound2
    libasound2-1.0.18-8.12.1

    jvermeulen@linux-g1qz:~> uname -a
    Linux linux-g1qz 2.6.27.37-0.1-pae #1 SMP 2009-10-15 14:56:58 +0200 i686 i686 i386 GNU/Linux

    jvermeulen@linux-g1qz:~> cat /etc/modprobe.d/sound

    options snd slots=snd-hda-intel
    # u1Nb.NSQVSWdGjjE:82801I (ICH9 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel

    hope this is suficient
    j

  4. #4
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    25,839
    Blog Entries
    30

    Default Re: sound on dell Inspiron 1545

    Quote Originally Posted by linuxjohan View Post
    i ran all the tests, output 1st one is same for user as root.

    On the 2nd one i hear nothing, not from speaker of headset.
    I do not understand your english.
    Does this mean you heard sound with the 3rd "aplay" ?

  5. #5
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    25,839
    Blog Entries
    30

    Default Re: sound on dell Inspiron 1545

    Quote Originally Posted by linuxjohan View Post
    Your ALSA information is located at http://www.alsa-project.org/db/?f=70...0eb0f2a835d8d8
    Thankyou. For this I note a 32-bit openSUSE-11.1 with the 2.6.27.37 kernel and 1.0.17/1.0.18 of alsa (which was built for an earlier kernel).

    I suspect your alsa needs to be updated, and I can explain how to do that. But I also note your mixer is setup to completely BLOCK all sound. I assume that is an oversight on your part. Specifically

    !!Amixer output
    !!-------------

    !!-------Mixer controls for card 0 [Intel]
    Card hw:0 'Intel'/'HDA Intel at 0xf6afc000 irq 21'
    Mixer name : 'IDT 92HD71B7X'
    Simple mixer control 'Master',0
    Mono: Playback 64 [100%] [0.00dB] [on]
    Simple mixer control 'Headphone',0
    Front Left: Playback 25 [39%] [-29.25dB] [on]
    Front Right: Playback 25 [39%] [-29.25dB] [on]
    Simple mixer control 'PCM',0
    Front Left: Playback 0 [0%] [-51.00dB]
    Front Right: Playback 0 [0%] [-51.00dB]
    Simple mixer control 'Speaker',0
    Front Left: Playback 0 [0%] [-48.00dB] [on]
    Front Right: Playback 0 [0%] [-48.00dB] [on]
    Your PC has speaker volume control at 0% GUARANTEEING no sound. Your PC also has PCM volume at 0% GUARANTEEING no sound. Your PC also has headphone volume at 39%, which is so low it is HIGHLY unlikely you can hear any sound even IF it was present.

    As an NNTP user, you may not be able to read how I marked up your mixer settings. If so, then you need to go here to view them:
    sound on dell Inspiron 1545 - openSUSE Forums

    Now its likey turning up those levels will not help, as I suspect your PC needs to have alsa updated (and as noted, I can help there) but first, before we update you alsa, please test with good mixer settings.

  6. #6

    Default Re: sound on dell Inspiron 1545

    Same computer, same problem, same actions, and same results

    finally after the indications from oldcpu, about the output

    "Your PC has speaker volume control at 0% GUARANTEEING no sound. Your PC also has PCM volume at 0% GUARANTEEING no sound. Your PC also has headphone volume at 39%, which is so low it is HIGHLY unlikely you can hear any sound even IF it was present."

    I realize that whem you display the kmixer it has a "mezclador" button (spanish)

    in preferences, select "configurar canales" (or the equivalent in english) the select the IECXXX (I select all) and there it is the IECXXX'silence is select, all you need to do is unselected and is ready.


    Thanks for show us the direction oldcpu

  7. #7

    Cool Re: sound on dell Inspiron 1545

    hejimar, oldcpu,
    i also found the "mezclador" button - like that word, hejimar.
    i have a lot to learn, oldcpu.

    but where exactly did you find the mentioned settings -....hejimar?
    i now have sound when running the left-right test.

    maybe for good mesurement, you can tell me how the update the alsa,
    oldcpu?

    thank you very much
    johan

  8. #8
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    25,839
    Blog Entries
    30

    Default Re: sound on dell Inspiron 1545

    Quote Originally Posted by linuxjohan View Post
    maybe for good mesurement, you can tell me how the update the alsa, oldcpu?
    The guide for updating is here: Alsa-update - openSUSE

    Note in your case you would need to install alsa-driver-kmp-pae (but NOT the unstable nor default drivers) and also update alsa, alsa-firmware, alsa-oss, alsa-plugins-pulse, alsa-utils, alsa-plugins, alsa-tools, and alsa-devel.

  9. #9
    anters NNTP User

    Default Re: sound on dell Inspiron 1545

    I had the same problem on a new inspiron. The fix was just to reset the mute on Kmix (icon on bottom right of task panel). Thanks for the help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •