Results 1 to 4 of 4

Thread: 11.2 RC and network problems (yast repos fetching, etc)

  1. #1
    mityokUA NNTP User

    Lightbulb 11.2 RC and network problems (yast repos fetching, etc)

    After testing 11.2 for few days I've encounted problems with network:

    1) yast was unable to fetch repo's data, saying something about AbstractCommand.cc:139 (don't remember line number for sure)

    2) FTP client (in KDE - konqueror, krusader and midnight commander too) was not working with error messages saying about "temporary problems with name resolution" or "timeout exceed"

    After some digging around this forum and over the net, I've found following solutions:

    1) Disabling aria for zypper to work:
    export ZYPP_ARIA2C=0

    then try
    yast2 --install

    it should work. If not, and sayng about hostname resoultion problems - go to step 2.


    2) KDE 4.3 and others problems with FTP
    Reason was very simple - IPv6. it was used in name resolution by KDE libraries.
    To disable IPv6 for KDE place following:

    export KDE_NO_IPV6=true

    in your "/etc/bash.bashrc.local" and restart KDE (+ may be kdm, so if you dont know how to do that - just reboot)
    If that does not help - we have to disable IPv6 completely (in my case IPv6 is useless, so I can disable it with no doubt)
    Forget all stories about disabling IPv6 in /etc/modprobe.d
    IPv6 now compiled into a kernel and no longer a module, so /etc/modprobe.d configuration wouldn't help.

    Just try to do following (as root) (and don't forget to replace "eth0" with name of your network interface) :

    sysctl -w net.ipv6.conf.all.disable_ipv6=1
    ifdown eth0
    ifup eth0
    ifconfig | grep inet6

    If output of grep is empty - you've successfully disabled IPv6. It will be disabled until you reboot. To disable IPv6 permanently add a line to /etc/sysctl.conf:

    net.ipv6.conf.all.disable_ipv6 = 1

    reboot and enjoy an OpenSuse 11.2 without mysterious network problems.

    Hope someone will find that useful.

  2. #2

    Post Re: 11.2 RC and network problems (yast repos fetching, etc)

    IPv6 is enabled in KDE (and in Linux going forward) for a reason - IPv4 exhaustion will happen. (That's not merely a possibility, but a certainty.) NAT is a kludge (an elegant one, but still a kludge), and merely staves off the inevitable (like King Canute and his broom vs. the tide). I have Brits in the heritage; however, I have no wish to find myself being another Canute. Besides, I find that Linux distributions in general support IPv6 (and the just-as-elegant kludge of ipv6-in-ipv4 tunnelling, which is the default IPv6 deployment today) better than Windows (even Windows 7). Most free tunnelbrokers (including the three best-known ones - Freenet6, Hurricane Electric's tunnelbroker.net and SixxS) have RPMs for Linux distributions that require them (SixxS, which I use, has a package set for development distributions, which I use for 11.2 RC2 x64). Heck, Debian has gone one better and included AICCU (which supports most 6to4 tunnel types and most brokers, both free and fee) in their repos (and Ubuntu/Kubuntu actually has IPv6-accessible repositories in the US).

    So, I wouldn't be so quick to dispense with IPv6. Temporarily, but definitely not permanently.

  3. #3

    Post Re: 11.2 RC and network problems (yast repos fetching, etc)

    Quote Originally Posted by PGHammer View Post
    IPv6 is enabled in KDE (and in Linux going forward) for a reason - IPv4 exhaustion will happen. (That's not merely a possibility, but a certainty.) NAT is a kludge (an elegant one, but still a kludge), and merely staves off the inevitable (like King Canute and his broom vs. the tide). I have Brits in the heritage; however, I have no wish to find myself being another Canute. Besides, I find that Linux distributions in general support IPv6 (and the just-as-elegant kludge of ipv6-in-ipv4 tunnelling, which is the default IPv6 deployment today) better than Windows (even Windows 7). Most free tunnelbrokers (including the three best-known ones - Freenet6, Hurricane Electric's tunnelbroker.net and SixxS) have RPMs for Linux distributions that require them (SixxS, which I use, has a package set for development distributions, which I use for 11.2 RC2 x64). Heck, Debian has gone one better and included AICCU (which supports most 6to4 tunnel types and most brokers, both free and fee) in their repos (and Ubuntu/Kubuntu actually has IPv6-accessible repositories in the US).

    So, I wouldn't be so quick to dispense with IPv6. Temporarily, but definitely not permanently.

    Addendum and followup:

    I have since done a test reinstall (blanking the original RC2 install from a live CD, using a DVD version of RC2 x64), and I've had no issues with repository updates before or since adding back my tunnel from SixxS. In fact, I have added the Linux Catalyst drivers and configured the kopete IM software since re-adding the tunnel (I have no issues with them, either; however, I may go back to pidgin for IM because of personal-preference reasons concerning pidgin).

  4. #4
    mityokUA NNTP User

    Default Re: 11.2 RC and network problems (yast repos fetching, etc)

    Yes, of course, IPv6 is next generation based on IPv4, and it will replace its parent once. But for now lots of ISPs still not ready for that changes. And even more, software (especially userspace software) is only partially ready for that change. Mainly because IPv6 is relatively young. And software contains bugs, that must be addressed before it will be really usable. Until then - stable work is a much more important that the new features in a fresh version of software.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •