Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Firefox broken after stupid update

  1. #1
    Join Date
    Sep 2009
    Location
    Barcelona
    Posts
    15

    Unhappy Firefox broken after stupid update

    Hi!

    After updating my system firefox doesn't works and puts the next error in terminal: "Could not find compatible GRE between version 1.9.1.3 and 1.9.1.3."

    I've been searching/reading in forums and no solution found. Any ideas?

    (removing .mozilla directory doesn't solve my problem)

    Also Kaffeine change the look it has, and it is not yet my default videoplayer.... is there a way to know what have i changed (log or something similar??)


    My System:
    Opensuse 11.1 64 bits
    Kde 4.3.1 release 165

  2. #2

    Default Re: Firefox broken after stupid update

    You haven't been looking too well

    When you update firefox you also need to update xulrunner to appropriate version. Make sure that xulrunner was also updated.
    How does a linux geek make love??

    - rtfm; unzip; strip; touch; finger; mount; fsck; more; yes; umount; zip; sleep;

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    37,051
    Blog Entries
    16

    Default Re: Firefox broken after stupid update

    Also you fetched a kaffeine update from kde4 factory, you need to switch back to Packman, the kde4 version will not work.
    My openSUSE 13.1 KDE Box
    My Articles
    Was I any help? If yes: Click the star below

  4. #4
    Join Date
    Sep 2009
    Location
    Barcelona
    Posts
    15

    Default Re: Firefox broken after stupid update

    To BenderBendingRodriguez: xulrunner is updated too. I have the mozilla repo on. I think it's time to buy a new hdd and do some cleaning and upgrading.....

    ps. do you speak spanish? i'm spanish and i think i can explain better in that language....

    to caf 4926: i've just upgraded down kaffeine and it works ok again, thanks a lot....

  5. #5

    Default Re: Firefox broken after stupid update

    Hmmm, not really though i plan to learn it

    So you have firefox and xulrunner installed? I propose to UNinstall both firefox and any xulrunner version 1.9.x

    Then install firefox again, which should pull appropriate xulrunner version and save it somewhere on the working part of the disk
    How does a linux geek make love??

    - rtfm; unzip; strip; touch; finger; mount; fsck; more; yes; umount; zip; sleep;

  6. #6
    Join Date
    Jun 2008
    Location
    Kln, Deutschland
    Posts
    1,204

    Default Re: Firefox broken after stupid update

    Maybe disabling the mozilla repo, and "downgrading" to the current stable version would also help?

    I had that same error message when I tried the newer Firefox version, and decided to downgrade it again.
    HP dv6645, Nvidia 8400m-gs, KDE 4.

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    37,051
    Blog Entries
    16

    Default Re: Firefox broken after stupid update

    If you actually have the Mozilla repo and have priority 99 on it and the same on Updates. If Updates provides a new package then it will use it, if you let it. This should not be a problem.
    See my screen
    My openSUSE 13.1 KDE Box
    My Articles
    Was I any help? If yes: Click the star below

  8. #8
    Join Date
    Sep 2009
    Location
    Barcelona
    Posts
    15

    Default Re: Firefox broken after stupid update

    I can't uninstall firefox and xulrunner because yast gives me a lot of error of dependencies. (or downgrade KDE 4.3 to 4.1). Is it possible to uninstall and then reinstall in command line forgetting the dependencies? is it too risky?

    I'm gonna try that growbag says, it's simple and nice. i like this solution. hope it works

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    37,051
    Blog Entries
    16

    Default Re: Firefox broken after stupid update

    @Ivanjn
    Please give us the result of this:

    Code:
    zypper lr -d
    My openSUSE 13.1 KDE Box
    My Articles
    Was I any help? If yes: Click the star below

  10. #10
    Join Date
    Sep 2009
    Location
    Barcelona
    Posts
    15

    Default Re: Firefox broken after stupid update

    Quote Originally Posted by caf4926 View Post
    @Ivanjn
    Please give us the result of this:

    Code:
    zypper lr -d
    # | Alias | Nombre | Activado | Actualizar | Prioridad | Tipo | URI | Servicio
    ---+---------------------+---------------------------------------------------------+----------+------------+-----------+--------+----------------------------------------------------------------------------------------------------+---------
    1 | Compiz_&_XGL | Compiz & XGL | Si | Si | 99 | rpm-md | Index of /repositories/X11:/XGL/openSUSE_11.1 |
    2 | Contrib | Contrib | Si | Si | 99 | rpm-md | Index of /repositories/openSUSE:/Factory:/Contrib/openSUSE_11.1 |
    3 | Emulators | Emulators | Si | Si | 99 | rpm-md | Index of /repositories/Emulators/openSUSE_11.1 |
    4 | JAVA | JAVA | Si | Si | 99 | rpm-md | Index of /repositories/Java:/packages/openSUSE_11.1 |
    5 | KDE_4_Community | KDE 4 Community | Si | Si | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.1_KDE4_Factory_Desktop |
    6 | KDE_4_Core_Packages | KDE 4 Core Packages | Si | Si | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.1 |
    7 | mozilla | mozilla | Si | Si | 99 | rpm-md | Index of /repositories/mozilla/openSUSE_11.1 |
    8 | repo | NVIDIA Repository | Si | Si | 99 | rpm-md | http://download.nvidia.com/opensuse/11.1 |
    9 | repo_1 | Repositorio principal (NON-OSS) | Si | Si | 99 | yast2 | Index of /distribution/11.1/repo/non-oss |
    10 | repo_10 | BuildService de openSUSE - Juegos | Si | Si | 99 | rpm-md | Index of /repositories/games/openSUSE_11.1 |
    11 | repo_11 | BuildService de openSUSE - Mozilla | Si | Si | 99 | rpm-md | Index of /repositories/mozilla/openSUSE_11.1 |
    12 | repo_12 | Repositorio Principal de Actualizaciones | Si | Si | 99 | rpm-md | Index of /update/11.1 |
    13 | repo_13 | VideoLan Repository | Si | Si | 99 | rpm-md | Index of /pub/videolan/vlc/SuSE/11.1/ |
    14 | repo_14 | Packman Repository | No | Si | 99 | rpm-md | Index of /pub/packman/suse/11.1 |
    15 | repo_2 | Repositorio principal (OSS) | Si | Si | 99 | yast2 | Index of /distribution/11.1/repo/oss |
    16 | repo_3 | BuildService de openSUSE - GNOME:Comunidad | Si | Si | 99 | rpm-md | Index of /repositories/GNOME:/Community/openSUSE_11.1 |
    17 | repo_4 | BuildService de openSUSE - GNOME:ESTABLE | Si | Si | 99 | rpm-md | Index of /repositories/GNOME:/STABLE/openSUSE_11.1 |
    18 | repo_5 | BuildService de openSUSE - KDE:Adaptaciones (backports) | Si | Si | 99 | rpm-md | Index of /repositories/KDE:/Backports/openSUSE_11.1 |
    19 | repo_6 | BuildService de openSUSE - KDE:Comunidad | Si | Si | 99 | rpm-md | Index of /repositories/KDE:/Community/openSUSE_11.1 |
    20 | repo_7 | BuildService de openSUSE - Mono:Comunidad | Si | Si | 99 | rpm-md | Index of /repositories/Mono:/Community/openSUSE_11.1 |
    21 | repo_8 | BuildService de openSUSE - OpenOffice.org | Si | Si | 99 | rpm-md | Index of /repositories/OpenOffice.org:/STABLE/openSUSE_11.1 |
    22 | repo_9 | BuildService de openSUSE - X11:Compiz | Si | Si | 99 | rpm-md | Index of /repositories/X11:/Compiz/openSUSE_11.1

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •