Results 1 to 10 of 10

Thread: Need help with GRUB video modes!

  1. #1
    Join Date
    Oct 2008
    Location
    The Netherlands
    Posts
    121

    Default Need help with GRUB video modes!

    Since my screen resolution is 1024x768, I would like that GRUB starts in that resolution as well.

    This is how my menu.lst looks like:
    Code:
    # Modified by YaST2. Last modification on Sat Jul 11 20:25:14 CEST 2009
    default 0
    timeout 9
    gfxmenu (hd0,2)/boot/message
    
    title openSUSE 11.0 - 2.6.25.20-0.4
        root (hd0,2)
        kernel /boot/vmlinuz-2.6.25.20-0.4-pae root=/dev/disk/by-id/scsi-SATA_HDS728080PLA380_PFDB32S6R2DKHN-part3 splash=silent showopts vga=0x314
        initrd /boot/initrd-2.6.25.20-0.4-pae
    
    title openSUSE 11.0 - 2.6.25.20-0.4 (Failsafe)
        root (hd0,2)
        kernel /boot/vmlinuz-2.6.25.20-0.4-pae root=/dev/disk/by-id/scsi-SATA_HDS728080PLA380_PFDB32S6R2DKHN-part3 showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off x11failsafe vga=0x314
        initrd /boot/initrd-2.6.25.20-0.4-pae
    
    title  openSUSE 11.1 - 2.6.27.23-0.1 (/dev/sdd4)
        rootnoverify (hd0,3)
        chainloader +1
    
    title Windows XP
        rootnoverify (hd0,2)
        chainloader (hd0,0)+1
    
    title Floppy
        rootnoverify (hd0,2)
        chainloader (hd0)+1
    According to table below (found somewhere on the Internet) vga=0x314 stands for 800x600 video resolution.
    Code:
    +--------------------------------------------------+
         | 640x480    800x600    1024x768   1280x1024
    -----+----------------------------------------------
     256 | 0x301=769  0x303=771  0x305=773   0x307=775
     32K | 0x310=784  0x313=787  0x316=790   0x319=793
     64K | 0x311=785  0x314=788  0x317=791   0x31A=794
     16M | 0x312=786  0x315=789  0x318=792   0x31B=795
    +--------------------------------------------------+
    To change the GRUB video resolution, I have tried different possibilities
    vga=0x31A
    vga=0x319
    also 1024x768 resolution
    vga=0x317

    Any of these settings results in text screen during boot.

    What am I doing wrong?
    openSUSE 11.0, GNOME
    HP Compaq NC6000, Intel Pentium M Processor 725, ATI Mobility Radeon 9600, Intel PRO 2200BG
    HP Compaq DC7100, Intel Pentium 4 Processor 521, Intel 915G Express, D-Link DWL-510 AirPlus G

  2. #2
    Join Date
    Jul 2009
    Location
    Cyberspace
    Posts
    352

    Default Re: Need help with GRUB video modes!

    This link might help: VideoSubsystem - GRUB Wiki
    Last edited by malcolmlewis; 03-Aug-2011 at 15:35. Reason: Fix link
    Once you install a modem, the government can look into your computer and watch everything you do! That's why every night before I go to bed, I turn the monitor to the wall.

  3. #3
    Join Date
    Oct 2008
    Location
    North Wales, UK
    Posts
    1,136

    Default Re: Need help with GRUB video modes!

    If you have an installed system, go to yast2>system>boot loader then edit and add the screen resolution 317.

  4. #4
    Join Date
    Oct 2008
    Location
    The Netherlands
    Posts
    121

    Default Re: Need help with GRUB video modes!

    Quote Originally Posted by suse_amd64x2 View Post
    This link might help: VideoSubsystem - GRUB Wiki
    This is very complex, I would not know what to do with it.
    Could you give me a hint?
    openSUSE 11.0, GNOME
    HP Compaq NC6000, Intel Pentium M Processor 725, ATI Mobility Radeon 9600, Intel PRO 2200BG
    HP Compaq DC7100, Intel Pentium 4 Processor 521, Intel 915G Express, D-Link DWL-510 AirPlus G

  5. #5
    Join Date
    Jul 2009
    Location
    Cyberspace
    Posts
    352

    Default Re: Need help with GRUB video modes!

    Actually whych came up with a better solution above. Easier. I have a habit of referring people to other links where a lot of reading is involved, lol.
    Once you install a modem, the government can look into your computer and watch everything you do! That's why every night before I go to bed, I turn the monitor to the wall.

  6. #6
    Join Date
    Oct 2008
    Location
    North Wales, UK
    Posts
    1,136

    Default Re: Need help with GRUB video modes!

    When the boot loader settings screen comes up, highlight the relevant entry and click edit.
    At the bottom of the next screen is an entry box for VGA mode. Enter 0x317 in it for your resolution. Save it and you should see the mode at the bottom of the grub boot screen next time you boot.

    suse_amd64x2:
    Lots of reading is probably not a bad thing when you run linux - we linux users are probably the biggest self-help group around.

  7. #7
    Join Date
    Oct 2008
    Location
    The Netherlands
    Posts
    121

    Default Re: Need help with GRUB video modes!

    Quote Originally Posted by whych View Post
    If you have an installed system, go to yast2>system>boot loader then edit and add the screen resolution 317.
    I did that as well, but it does not help.

    In fact, what I see is following:
    Boot menu is displayed in green graphical mode, resolution 800x600. It shows "Boot Options = vga=0x317"

    When I press enter, green screen disappears and bunch of text is being scrolled over the screen.
    I would like to see the standard green screen with the progress bar.
    By the way, such screen is displayed only with vga=0x314.
    openSUSE 11.0, GNOME
    HP Compaq NC6000, Intel Pentium M Processor 725, ATI Mobility Radeon 9600, Intel PRO 2200BG
    HP Compaq DC7100, Intel Pentium 4 Processor 521, Intel 915G Express, D-Link DWL-510 AirPlus G

  8. #8
    Join Date
    Oct 2008
    Location
    North Wales, UK
    Posts
    1,136

    Default Re: Need help with GRUB video modes!

    Try adding splash=silent showopts to the end of the 'optional kernel command line parameter' box in yast2>system>boot loader settings.
    This should give the splash screen.
    Sometimes it's not a bad idea to see what is being loaded at boot (the txt you are seeing).

  9. #9
    Join Date
    Oct 2008
    Location
    The Netherlands
    Posts
    121

    Default Re: Need help with GRUB video modes!

    Yes I agree with you. It can be useful to see what is being loaded, but only when I want to see it.

    However, "splash=silent showopts" is always there (please see the menu.lst at the beginning of the thread).

    So this works properly:
    kernel /boot/vmlinuz-2.6.25.20-0.4-pae root=/dev/disk/by-id/scsi-SATA_HDS728080PLA380_PFDB32S6R2DKHN-part3 splash=silent showopts vga=0x314

    while this shows only text:
    kernel /boot/vmlinuz-2.6.25.20-0.4-pae root=/dev/disk/by-id/scsi-SATA_HDS728080PLA380_PFDB32S6R2DKHN-part3 splash=silent showopts vga=0x317
    openSUSE 11.0, GNOME
    HP Compaq NC6000, Intel Pentium M Processor 725, ATI Mobility Radeon 9600, Intel PRO 2200BG
    HP Compaq DC7100, Intel Pentium 4 Processor 521, Intel 915G Express, D-Link DWL-510 AirPlus G

  10. #10
    Join Date
    Oct 2008
    Location
    The Netherlands
    Posts
    121

    Default Re: Need help with GRUB video modes!

    I have enabled 1024x768 splash screen as follows:
    Code:
    linux:/ # mkinitrd -s 1024x768
    
    Kernel image:   /boot/vmlinuz-2.6.25.20-0.4-pae
    Initrd image:   /boot/initrd-2.6.25.20-0.4-pae
    Root device:	/dev/disk/by-id/scsi-SATA_HDS728080PLA380_PFDB32S6R2DKHN-part3 (/dev/sdd3) (mounted on / as ext3)
    Kernel Modules:	processor thermal dock scsi_mod libata pata_sil680 ata_piix fan jbd mbcache ext3 edd sd_mod usbcore ohci-hcd uhci-hcd ehci-hcd ff-memless hid usbhid 
    Features:       block usb resume.userspace resume.kernel
    Bootsplash:	openSUSE (1024x768)
    21512 blocks
    linux:/ #
    There is still one other issue that needs to be solved.
    The splash screen is completely distorted because the monitor frequency is not set properly.
    Vertical frequency is 60Hz, it should be 85Hz.
    How to fix this?
    openSUSE 11.0, GNOME
    HP Compaq NC6000, Intel Pentium M Processor 725, ATI Mobility Radeon 9600, Intel PRO 2200BG
    HP Compaq DC7100, Intel Pentium 4 Processor 521, Intel 915G Express, D-Link DWL-510 AirPlus G

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •