Page 1 of 4 123 ... LastLast
Results 1 to 10 of 39

Thread: LCd screen resolution

  1. #1

    Default LCd screen resolution

    hi
    yesterday i installed suse 10.3 every thing went fine the configuration detected Ati Radeon graphics i set the resolution to monitor defautl 1440X900 suring hardware setup and completed the installation now when i start the comp i can see the welcome page but when after that the display is gone from the screen but the computer booots normally and i can hear the login sound .... the PC is in running condition but no display. please tell me how to set the refresh rate or whatever i m very new to linux i dont knw much commands please guide me

  2. #2
    Join Date
    Sep 2008
    Location
    Dubai
    Posts
    1,903

    Default Re: LCd screen resolution

    When the booting starts (you will see the grub screen), type 3 and press enter. This will bring you to text mode and you will see a login prompt. Login as root and run sax to configure the display again. Select a lower resolution (like 1024x780) and see if works first.
    Code:
    sax2
    openSUSE 12.3 (x86_64) with Kernel 3.7.10-1.16-desktop and KDE 4.11.2 on MacBook Pro
    Latest MS Windows version used: Win95

  3. #3

    Default Re: LCd screen resolution

    how do u run sax after login to root i mean what should i type juts "sax" ?

  4. #4
    Join Date
    Sep 2008
    Location
    Dubai
    Posts
    1,903

    Default Re: LCd screen resolution

    Type the following
    Code:
    sax2
    openSUSE 12.3 (x86_64) with Kernel 3.7.10-1.16-desktop and KDE 4.11.2 on MacBook Pro
    Latest MS Windows version used: Win95

  5. #5

    Unhappy Re: LCd screen resolution

    brother i tried doin what u said after doing sax it says starting then says cannot connect to X-server and some lines scroll after that the screen goes off..and the pc remains on

  6. #6

    Unhappy Re: LCd screen resolution

    plzz plzz help me no body is helping me sax2 dosen work it says x sever not connected type blah and scree goes off in yast2 also i try hardware>>scree and monitor and type the resolution 1024X768@60 hz it goes blank ....please some one tell me what to do to change the resolution i tried re installing also but the same problem......i have samsun 19" wide screen lcd

  7. #7
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    25,619
    Blog Entries
    29

    Default Re: LCd screen resolution

    Quote Originally Posted by ishfanatic View Post
    the configuration detected Ati Radeon graphics
    There is a reasonable chance that "sax2" will work for you, but you need to run it with the appropriate input arguments.

    First, boot to run level 3 (ie type "3" in the options line of the grub menu) and login as a regular user, and enter the regular user password.

    Then type "su" (no quotes and enter root password) to get root permissions.

    Then backup your /etc/X11/xorg.conf file, which is the file with your graphics, display, keyboard and mouse configuration by typing:
    cp /etc/X11/xorg.conf /etc/X11/xorg.conf.newbackup
    Then confirm your graphics by typing:
    sax2 -p
    post here the output.

    (1) If you are confident this is ATI/Radeon graphics on chip0 , then type:
    sax2 -r -m 0=radeon
    and see if that appears to work. If that appears to work, then exit YaST, and then type "exit" to get rid of root permissions. Type "whoami" to confirm you are now a regular user. And then type:
    startx
    and see if you have X windows (ie a gui). If you do, open a terminal or a konsole, and type "su" (enter root password) followed by "shutdown -r now" to reboot.

    (2) If "sax2 -r -m 0=radeon" did not work, then try with root permissions:
    sax2 -r -m 0=radeonhd
    and again see if that appears to work. If that appears to work, then exit YaST, and then type "exit" to get rid of root permissions. Type "whoami" to confirm you are now a regular user. And then type:
    startx
    and see if you have X windows (ie a gui). If you do, open a terminal or a konsole, and type "su" (enter root password) followed by "shutdown -r now" to reboot.

    (3) If "sax2 -r -m 0=radeonhd" did not work, then try with root permissions:
    sax2 -r -m 0=vesa
    and again see if that appears to work. If that appears to work, then exit YaST, and then type "exit" to get rid of root permissions. Type "whoami" to confirm you are now a regular user. And then type:
    startx
    and see if you have X windows (ie a gui). If you do, open a terminal or a konsole, and type "su" (enter root password) followed by "shutdown -r now" to reboot.

    (4) If that does not work, there are other possibilities, such as
    • using the installation xorg.conf.install file
    • using the framebuffer
    • installing the proprietary driver
    Good luck.

  8. #8

    Unhappy Re: LCd screen resolution

    dear moderator atleast somebody reply me i m all stuck since last nite

  9. #9
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    25,619
    Blog Entries
    29

    Default Re: LCd screen resolution

    Quote Originally Posted by ishfanatic View Post
    dear moderator atleast somebody reply me i m all stuck since last nite
    Please read my above post. ... Good luck!

  10. #10

    Default Re: LCd screen resolution

    brother u did not mention after doing restart how do i exactly change the resolution

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •