Results 1 to 5 of 5

Thread: Suse LDAP authentication in Active Directory Problem

  1. #1

    Exclamation Suse LDAP authentication in Active Directory Problem

    Hello,

    I am trying to set up a network with a Windows 2008 Server, using AD, I'm trying to authenticate in Suse with a Windows username, and I get this error,

    Apr 1 17:05:12 Susy sshd[6329]: nss_ldap: failed to bind to LDAP server ldap://10.154.59.51: Invalid credentials
    Apr 1 17:05:12 Susy sshd[6329]: nss_ldap: failed to bind to LDAP server ldap://windowsad-dc.windows-ad.testes.loc/: Invalid credentials

    But, according to Windows Security Events Viewer,the Suse box doesn't even try to login, there is record of nothing.

    Can you help me?

    Thankyou.

  2. #2

    Default Re: Suse LDAP authentication in Active Directory Problem

    I should add that I'm reading the error from the log files and it appears as soon as I insert the username, it doesn't get to ask for the password.


    Thanks.

  3. #3
    Join Date
    Oct 2008
    Location
    Manchester
    Posts
    130

    Default Re: Suse LDAP authentication in Active Directory Problem

    Hi,

    Are the ldap ports available to a telnet session ?

    ie: telnet "windows2008serverip" 389

    Is the Win 2k8 firewall configured to allow the ldap traffic ? (command above should prove this)

    Are physical network comms ok ?

    From the win2k8 box can you issue the command:

    telnet localhost 389 ? does it respond with a connection ?

    hth
    J
    Linux# makes_a_network_feel_good.sh

    Linux and BSD solutions

  4. #4

    Default Re: Suse LDAP authentication in Active Directory Problem

    Hy,

    I can connect by telnet in both systems..

    Any idea what is the problem?


    Tiago

  5. #5

    Default Re: Suse LDAP authentication in Active Directory Problem

    Hello,

    figured how to solve it, for it to work I have to have the user created both in the Windows AD and in Linux, I gave each a different password and I'm logging in with the Windows password, so I know it is getting information from the AD, but it takes forever to log in, maybe 5 minutes, and this error keeps popping up,

    Apr 2 18:33:15 Susy sshd[3839]: nss_ldap: failed to bind to LDAP server ldap:// 10.154.59.51: Invalid credentials
    Apr 2 18:33:15 Susy sshd[3839]: nss_ldap: failed to bind to LDAP server ldap:// windowsad-dc.windows-ad.testes.loc/: Invalid credentials
    Apr 2 18:33:15 Susy sshd[3839]: nss_ldap: reconnecting to LDAP server (sleeping 64 seconds)...


    Any idea what is going on???

    Thankyou!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •