Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Very weird poor sound quality

  1. #1

    Default Very weird poor sound quality

    Hi,

    I have a HP Compaq 8510p 32Bit Machine running opensuse 11.1 which I upgraded from opensuse 11. The sound card is Radeon HD 2600 Series. Anyway, the sound was fine when I got the laptop originally bundled with Vista. It was also fine when I installed opensuse 11. Problems came when I upgraded to opensuse 11.1. The sound quality is bad. The volume is ok when its low, but its low, to a point where I cannot here anything. I thought the problem was a hardware issue, so I had it sent back and they told me hardware was ok. I installed Windows in a partition and the volume is fine. If the volume is high it gets distorted.If the volume is too low, it also gets distorted. Better example is when u listen to an MP3, the beginning is distorted, middle is fine, end is distorted. When I watch a DVD, sound is distorted. I use banshee for audio, Mplayer, VLC and Smplayer for Video and its all the same result.

    How do I get the sound to be normal, allowing me to raise without compromising the quality i.e. dropping the bass etc, and on the same levels when I run Windows? I have attached all sorts of output for info. Any help appreciated.

    Thanks.

    Kahenya


    To Alsa-info output http://www.alsa-project.org/db/?f=7b...b9e94b3451e100


    Yast Soundcard Currently Configured
    Code:
    RV630/M76 audio device []
    Configured as sound card number 0
    Driver snd-hda-intel
    rpm -qa | grep alsa
    Code:
    alsamixergui-0.9.0rc1-705.1
    alsa-1.0.19.git20090122-1.1
    alsa-tools-gui-1.0.18-1.13
    alsa-utils-1.0.19.git20090120-1.3
    alsa-driver-kmp-pae-1.0.19.20090122_2.6.27.7_9.1-2.1
    alsa-oss-1.0.17.git20080715-2.13
    alsa-plugins-pulse-1.0.19.git20090122-2.1
    alsa-devel-1.0.19.git20090122-1.1
    alsa-plugins-1.0.19.git20090122-2.1
    alsa-tools-devel-1.0.19.git20090120-1.3
    alsa-firmware-1.0.19.git20090120-1.1
    alsa-tools-1.0.19.git20090120-1.3
    rpm -qa | grep pulse
    Code:
    libpulse-browse0-0.9.12-9.6
    pulseaudio-utils-0.9.12-9.6
    libpulse0-0.9.12-9.6
    libpulsecore5-0.9.10-0.pm.2
    pulseaudio-0.9.12-9.6
    gstreamer-0_10-pulse-0.9.7-42.pm.1
    libpulse-mainloop-glib0-0.9.12-9.6
    libpulsecore4-0.9.12-9.6
    alsa-plugins-pulse-1.0.19.git20090122-2.1
    libxine1-pulse-1.1.15-20.8
    rpm -q libasound2
    Code:
    libasound2-1.0.19.git20090122-1.1
    cat /etc/modprobe.d/sound
    Code:
    options snd slots=snd-hda-intel
    # NXNs.WYUlP8TbU_B:RV630/M76 audio device [Radeon HD 2600 Series]
    alias snd-card-0 snd-hda-intel

  2. #2
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    25,619
    Blog Entries
    29

    Default Re: Very weird poor sound quality

    Quote Originally Posted by kahenya View Post
    How do I get the sound to be normal, allowing me to raise without compromising the quality i.e. dropping the bass etc, and on the same levels when I run Windows?
    My not being an MS-Windows user, I can't help re: Windows comparisons.

    But could you try going to: YAST > HARDWARE > SOUND > OTHER > VOLUME and move both Master and PCM volume UP there. Then close YaST. Then go to your Mixer and adjust both the Master and PCM volume there to obtain optimum sound quality. Note that when you start a new multimedia application, the PCM volume may dynamically change, and you may need to readjust it.

    There is also the possibility that the auto probe did not configure the AD1981 hardware audio codec in your Compaq properly. If the above YaST/mixer tuning does not work, we could try applying a custom model setting in your /etc/modprobe.d/sound file to test if that is an improvement.

  3. #3

    Default Re: Very weird poor sound quality

    I have done YAST > HARDWARE > SOUND > OTHER > VOLUME and it did not make a difference. The windows thing was just to check if my hearing was ok, and that I wasn't screwing up somewhere. How do I do the auto probe thingy? That may be the problem right there. Please let me know how to do sort out the /etc/modprobe.d/sound file. The AD1981 hardware audio codec thing is new to me. I don't think I have seen that one coming.

    Thanks.

    Kahenya

  4. #4
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    25,619
    Blog Entries
    29

    Default Re: Very weird poor sound quality

    Quote Originally Posted by kahenya View Post
    I have done YAST > HARDWARE > SOUND > OTHER > VOLUME and it did not make a difference. The windows thing was just to check if my hearing was ok, and that I wasn't screwing up somewhere. How do I do the auto probe thingy? That may be the problem right there. Please let me know how to do sort out the /etc/modprobe.d/sound file. The AD1981 hardware audio codec thing is new to me. I don't think I have seen that one coming.
    If you look at the output of the diagnostic script you ran, you will see this entry:
    Code:
    !!HDA-Intel Codec information
    !!---------------------------
    --startcollapse--
    
    Codec: Analog Devices AD1981
    Address: 0
    Vendor Id: 0x11d41981
    So alsa has identified your PC audio hardware as using an AD1981.

    I believe when a PC boots openSUSE Linux, alsa probes one's hardware, and tries to determine what hardware codec is in use, and tries to apply the setting specific for your PC's hardware implementation of the codec. For the AD1981, the following list of options is contained in the 1.0.19 alsa HD-Audio-Models.txt file:
    Code:
    AD1981
    ======
      basic		3-jack (default)
      hp		HP nx6320
      thinkpad	Lenovo Thinkpad T60/X60/Z60
      toshiba	Toshiba U205
    If we work under the assumption that the autoprobe did not succeed (and that may not be a valid assumption, ... but we need to start from somewhere) then, for example, to try the "hp" option from that list, you need to change your PCs /etc/modprobe.d/sound file to
    Code:
    options snd slots=snd-hda-intel
    options snd-hda-intel model=hp
    # NXNs.WYUlP8TbU_B:RV630/M76 audio device [Radeon HD 2600 Series]
    alias snd-card-0 snd-hda-intel
    and then restart your alsa sound drive by typing the following in a gnome terminal or kde konsole: su -c 'rcalsasound restart' and enter root password when prompted. Then restart your mixer, and test your sound. Again, move up both PCM and Master volume to 95% to test sound. Once you have basic sound, back off to a lower level to avoid distortion.

    If "hp" does not work, then try each of the other items in the list, one at a time. ie replace "hp" with "basic", save change, restart alsa and mixer, test ... if that does not work, try each of "thinkpad" and "toshiba".

    Could you also paste to a web site the contents of your dmesg, immediately after booting your PC and post the URL here. Just the URL. You can do that by copying and pasting into a gnome terminal or a kde konsole (with pc connected to internet):
    dmesg > dmesg.txt && curl -F file=@dmesg.txt nopaste.com/a
    Perhaps that dmesg may give a hint as to the problem.

  5. #5

    Default Re: Very weird poor sound quality

    Hi,
    Sorry was away on business. I tried all the choices possible, and toshiba and thinkpad came without sound. Basic was almost muted.

    Code:
    options snd slots=snd-hda-intel
    options snd-hda-intel model=hp
    # NXNs.WYUlP8TbU_B:RV630/M76 audio device [Radeon HD 2600 Series]
    alias snd-card-0 snd-hda-intel
    Currently using HP and the quality is still the same

    This is the DMESG/Nopaste Link

    dmesg.txt - nopaste.com (beta)

    Thanks.

    Kahenya

  6. #6
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    25,619
    Blog Entries
    29

    Default Re: Very weird poor sound quality

    Quote Originally Posted by kahenya View Post
    This is the DMESG/Nopaste Link

    dmesg.txt - nopaste.com (beta)
    Looks like you have many devices using IRQ 17 which is your sound interrupt?

    What is the output of:
    cat /proc/interrupts

  7. #7

    Default Re: Very weird poor sound quality

    Hi,

    This is the output.

    Code:
               CPU0       CPU1
      0:    5919953    5937985   IO-APIC-edge      timer
      1:       1672       1629   IO-APIC-edge      i8042
      3:          0          0   IO-APIC-edge      pata_pcmcia
      7:          0          0   IO-APIC-edge      parport0
      8:          0          1   IO-APIC-edge      rtc0
      9:       5030       4815   IO-APIC-fasteoi   acpi
     12:        895        904   IO-APIC-edge      i8042
     14:      56043      53045   IO-APIC-edge      ata_piix
     15:          0          0   IO-APIC-edge      ata_piix
     16:     490303     485170   IO-APIC-fasteoi   uhci_hcd:usb1, yenta, fglrx[0]@PCI:1:0:0
     17:      26848      25637   IO-APIC-fasteoi   uhci_hcd:usb2, yenta, HDA Intel, HDA Intel
     18:      56107      54427   IO-APIC-fasteoi   ehci_hcd:usb5, uhci_hcd:usb6, ohci1394
     19:        106         92   IO-APIC-fasteoi   mmc0
     20:         28         21   IO-APIC-fasteoi   uhci_hcd:usb3, ehci_hcd:usb7
     22:          0          0   IO-APIC-fasteoi   uhci_hcd:usb4
    217:     172290     165726   PCI-MSI-edge      iwlagn
    218:       2517       2718   PCI-MSI-edge      eth0
    219:      62717      62104   PCI-MSI-edge      ahci
    NMI:          0          0   Non-maskable interrupts
    LOC:    3920276    4965024   Local timer interrupts
    RES:     642819     602417   Rescheduling interrupts
    CAL:       1557      25912   function call interrupts
    TLB:       6349       5881   TLB shootdowns
    TRM:          0          0   Thermal event interrupts
    SPU:          0          0   Spurious interrupts
    ERR:          0
    MIS:          0

  8. #8
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    25,619
    Blog Entries
    29

    Default Re: Very weird poor sound quality

    With the "model=hp" applied, make certain you again try going to: YAST > HARDWARE > SOUND > OTHER > VOLUME and move both Master and PCM volume UP there. Then close YaST. Don't forget you MUST then go to your Mixer and adjust both the Master and PCM volume there to obtain optimum sound quality. And finally, don't forget that when you start a new multimedia application, the PCM volume may dynamically change, and you may need to readjust it.

  9. #9
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    25,619
    Blog Entries
    29

    Default Re: Very weird poor sound quality

    Quote Originally Posted by kahenya View Post
    The sound quality is bad. The volume is ok when its low, but its low, to a point where I cannot here anything. .... If the volume is high it gets distorted.If the volume is too low, it also gets distorted. Better example is when u listen to an MP3, the beginning is distorted, middle is fine, end is distorted. When I watch a DVD, sound is distorted. I use banshee for audio, Mplayer, VLC and Smplayer for Video and its all the same result.
    Can you explain what you mean by "distorted" ? ...

    Especially follow my recommendation re: YaST and re: your mixer.

  10. #10

    Default Re: Very weird poor sound quality

    I have done the YAST bit of adjusting the volume and as well on the mixer.

    By distorted, I mean that the sound becomes choppy when the volume is too low or high. It also gets a white snow effect noise effect.
    (sorry, only example on google).

    On DVDs without earphones, there is basically nothing to hear because if you adjust the volume, the sound is choppy, so have to watch with earphones to have a chance of actually hearing something.

    Thanks. Appreciate this.

    Kahenya

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •