Results 1 to 6 of 6

Thread: firefox : no display specified

  1. #1

    Default firefox : no display specified

    I am running OpenSUSE 11.1 with KDE4 on a Thinkpad T61 with an nVidia Quadro NVS 140M.

    When I am logged in as root and try to invoke firefox from the terminal, I get an error saying "No display specified".

    Anyone have any ideas?

  2. #2
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,941
    Blog Entries
    4

    Default Re: firefox : no display specified

    By terminal you mean the command line login? You don't have a display running then. You have to login at the GUI login to have a display.

  3. #3
    Join Date
    Mar 2008
    Location
    Vsters, Sweden ex. Highbury London UK
    Posts
    1,282

    Default Re: firefox : no display specified

    And remember NOT to do this as root
    Quote Originally Posted by ken_yap View Post
    By terminal you mean the command line login? You don't have a display running then. You have to login at the GUI login to have a display.
    Core 2 Duo 3.16GHz, 8GB DDR2, 3.5TB, GeForce 9600 GT, Amilo LCD 26", OS 11.1 x86_64, KDE4.2.4 (2)
    My wine tips & tricks

  4. #4
    hanae NNTP User

    Default Re: firefox : no display specified

    Hi, i have the same problem. but i didn't undrstand the soltion proposed...maybe because of my bad english :s

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    14,023
    Blog Entries
    12

    Default Re: firefox : no display specified

    Quote Originally Posted by darthshak View Post
    I am running OpenSUSE 11.1 with KDE4 on a Thinkpad T61 with an nVidia Quadro NVS 140M.

    When I am logged in as root and try to invoke firefox from the terminal, I get an error saying "No display specified".

    Anyone have any ideas?
    Yes. NEVER,NEVER use firefox as root !!! They should put a fix in Firefox so that it would simply not start when invoked by root. That's the single idea I have, simply because it's the only idea that matters.

    So, there is no solution, because there is no problem. You're trying something you shouldn't do.
    - Athlon X6 3.6 GHz, 16 GB DDR3, 30 GB SSD, 3 TB of disks, GT540, openSUSE 12.2 x86_64 + KDE 4.10 + GNOME 3
    - ASUS A73SD, Intel + GT610M Optimus, 6 GB, 120 GB SSD, openSUSE Tumbleweed

    Anything that can go wrong.... will teach us

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6
    elle_famous NNTP User

    Default Re: firefox : no display specified

    If you find where to download or detail about Firefox ,Download Firefox Free,anti spam,server detail.

    You should go to my blog and download free.

    serverservice.blogspot.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •