Results 1 to 4 of 4

Thread: !!!~.......urgent help required....... ~!!!

  1. #1

    Exclamation !!!~.......urgent help required....... ~!!!

    i've got my suse box thats connected directly to the internet running as a server i've got two nic one allows my ps3 to connect to the internet and the other connects to another machine also running suse 11.0 the configuration i've used is as follows
    ip address for nic eth1 on my machine that is connected to the other suse box is 192.168.5.100 then on that other suse box i've assigned a static ip address 192.168.5.8 subnet mask 255.255.255.0 and then on the routing tab the default gateway is 192.168.5.100 ??? now as far as i know i've done evrytin ryt but its still not able to access the internet from the other suse machine ? can sumwun plz help me with that i know itz probly jux a stupid mistake i've made though i read a tutotial for ip masquerading and thats how i've set everything up and masquerading is allowed and nic that connects to internet directly via cable modem is assigned to external and other nic assigned to internal zone ......... ?
    what could i possibly be doing wrong ?? lol im sure as hell outta ideas haha

  2. #2
    ab@novell.com NNTP User

    Default Re: !!!~.......urgent help required....... ~!!!

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    What document did you follow to pull this off?

    Please post the output of the following on each box:

    ip addr sh
    ip route sh
    cat /etc/resolv.conf
    cat /proc/sys/net/ipv4/ip_forward
    sudo /usr/sbin/iptables-save

    Good luck.





    lDeVillish wrote:
    > i've got my suse box thats connected directly to the internet running as
    > a server i've got two nic one allows my ps3 to connect to the internet
    > and the other connects to another machine also running suse 11.0 the
    > configuration i've used is as follows
    > ip address for nic eth1 on my machine that is connected to the other
    > suse box is 192.168.5.100 then on that other suse box i've assigned a
    > static ip address 192.168.5.8 subnet mask 255.255.255.0 and then on the
    > routing tab the default gateway is 192.168.5.100 ??? now as far as i
    > know i've done evrytin ryt but its still not able to access the internet
    > from the other suse machine ? can sumwun plz help me with that i know
    > itz probly jux a stupid mistake i've made though i read a tutotial for
    > ip masquerading and thats how i've set everything up and masquerading is
    > allowed and nic that connects to internet directly via cable modem is
    > assigned to external and other nic assigned to internal zone ......... ?
    >
    > what could i possibly be doing wrong ?? lol im sure as hell outta ideas
    > haha
    >
    >

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.2 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

    iD8DBQFJRw+G3s42bA80+9kRAmNJAJ9gRL9nZ4yMFkaHAasJkJtMXnmK/wCfUysg
    QHcV1h9gPvH2SLVkJ7qsR1g=
    =zvGE
    -----END PGP SIGNATURE-----

  3. Cool Re: !!!~.......urgent help required....... ~!!!

    Well, of course the simple smart ass answer is buy a $10 switch.

    But to get it to work I believe you will also need to enable IP forwarding in the one acting as gateway

    #cat /proc/sys/net/ipv4/ip_forward
    If 0 then IP forwarding is disable.

    To use IP forwarding there are many good tutorials:

    How to enable IP Forwarding in Linux | MDLog:/sysadmin

    Like the last guy said: Good luck!

    Pete

  4. #4

    Exclamation Re: !!!~.......urgent help required....... ~!!!

    i've got a broadband router a d-link di-704up can i jus use that instead i want to but i dont know how lol ....
    heres the output on my suse 11.0 box that is connected directly to the internet
    ip addr sh
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 brd 127.255.255.255 scope host lo
    inet 127.0.0.2/8 brd 127.255.255.255 scope host secondary lo
    inet6 ::1/128 scope host
    valid_lft forever preferred_lft forever
    2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether 00:0a:cd:12:41:c1 brd ff:ff:ff:ff:ff:ff
    inet 192.168.5.200/24 brd 192.168.5.255 scope global eth0
    inet6 fe80::20a:cdff:fe12:41c1/64 scope link
    valid_lft forever preferred_lft forever
    3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether 00:0a:cd:12:42:19 brd ff:ff:ff:ff:ff:ff
    inet 192.168.5.100/24 brd 192.168.5.255 scope global eth1
    inet6 fe80::20a:cdff:fe12:4219/64 scope link
    valid_lft forever preferred_lft forever
    4: eth2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether 00:0d:61:e1:40:7b brd ff:ff:ff:ff:ff:ff
    inet 122.106.115.233/20 brd 122.106.127.255 scope global eth2
    inet6 fe80::20d:61ff:fee1:407b/64 scope link
    valid_lft forever preferred_lft forever

    ip route sh

    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 brd 127.255.255.255 scope host lo
    inet 127.0.0.2/8 brd 127.255.255.255 scope host secondary lo
    inet6 ::1/128 scope host
    valid_lft forever preferred_lft forever
    2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether 00:0a:cd:12:41:c1 brd ff:ff:ff:ff:ff:ff
    inet 192.168.5.200/24 brd 192.168.5.255 scope global eth0
    inet6 fe80::20a:cdff:fe12:41c1/64 scope link
    valid_lft forever preferred_lft forever
    3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether 00:0a:cd:12:42:19 brd ff:ff:ff:ff:ff:ff
    inet 192.168.5.100/24 brd 192.168.5.255 scope global eth1
    inet6 fe80::20a:cdff:fe12:4219/64 scope link
    valid_lft forever preferred_lft forever
    4: eth2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether 00:0d:61:e1:40:7b brd ff:ff:ff:ff:ff:ff
    inet 122.106.115.233/20 brd 122.106.127.255 scope global eth2
    inet6 fe80::20d:61ff:fee1:407b/64 scope link
    valid_lft forever preferred_lft forever

    cat /etc/resolv.conf

    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 brd 127.255.255.255 scope host lo
    inet 127.0.0.2/8 brd 127.255.255.255 scope host secondary lo
    inet6 ::1/128 scope host
    valid_lft forever preferred_lft forever
    2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether 00:0a:cd:12:41:c1 brd ff:ff:ff:ff:ff:ff
    inet 192.168.5.200/24 brd 192.168.5.255 scope global eth0
    inet6 fe80::20a:cdff:fe12:41c1/64 scope link
    valid_lft forever preferred_lft forever
    3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether 00:0a:cd:12:42:19 brd ff:ff:ff:ff:ff:ff
    inet 192.168.5.100/24 brd 192.168.5.255 scope global eth1
    inet6 fe80::20a:cdff:fe12:4219/64 scope link
    valid_lft forever preferred_lft forever
    4: eth2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether 00:0d:61:e1:40:7b brd ff:ff:ff:ff:ff:ff
    inet 122.106.115.233/20 brd 122.106.127.255 scope global eth2
    inet6 fe80::20d:61ff:fee1:407b/64 scope link
    valid_lft forever preferred_lft forever

    cat /proc/sys/net/ipv4/ip_forward
    1

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •