Page 1 of 3 123 LastLast
Results 1 to 10 of 30

Thread: suse unable to recognise hard drive

  1. #1

    Default suse unable to recognise hard drive

    I have been having a terrible time getting suse or any distro of linux to be able to see my hard drives. Vista is on a partition, but even if I disconnect that hard drive, it still doesn't see the other.

    I have an
    xfx 750a motherboard;AMD Athlon 64 X2 5000+BE OC to 2.9ghz;2g of 1066 ram not OC actually at 800; HITACHI Deskstar 320GB SATA Hard Drive;WD Caviar 250GB SATA;LG DVD Burner GH22NS30;Lite-on IDE SOHC-5236V DVD-ROM/CD Burner;EVGA 8800gt.
    order on easus partition manager
    Disk 1 250g WD
    1.Vista Apps,Drive F=126.95g
    2.Vista ,Drive C=51.76
    2.Restore ,Drive G=9.77
    4.Bootsak ,Drive D=44.41

    Disk2 320g Hitachi
    1. ,Drive H=68.36
    2. ,Drive I=68.36
    3.Backup ,Drive J=68.36
    4.unsure ,Drive E=93.01

    This has always been done in sata mode, I have tried it in ACHI mode, but got the BSOD when I booted windows. I ran across another poster on the nvforums that has been have having trouble with this exact motherboard and is much more knowledgeable than me. I am going to try what he wrote, but I wanted to see if anyone had any ideas before I switched into raid mode.
    Oh in his post he said something about having to reverse the order of the drives. I was thinking that maybe this might have something to do with suse not seeing the drives.
    Any thoughts or help would be appreciated.
    this is the link to the other forum
    nforce 750a sata_nv problem - nV News Forums

    I am going to try a boot manager called GAG this weekend and then if that doesn't work I'll try fdisk. I kind of have a feeling it is vista's partition manager messing everything up.

  2. #2
    Join Date
    Jun 2008
    Location
    Levin, New Zealand
    Posts
    233

    Default Re: suse unable to recognise hard drive

    When you say 'see' what do you mean? Looking at the forum you point to it seems you are trying to use a live CD is that right? Is it KDE or GNOME. When you say it can't 'see' the hard drive what exactly happens

  3. #3

    Default Re: suse unable to recognise hard drive

    Sorry about that. I changed what I wrote several times and I guess I got blind to what I was typing. Although, I do remember that I never included the part about gnome.

    Yes that is correct. I tried using gnome and the dvd version's,the 64bit versions. On the dvd version, I think I used gnome on it to.

    Is it possible that since I used the vista partition manager to format and and partition that this is causing the issue?

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    317

    Default Re: suse unable to recognise hard drive

    So you have two HDD drive do the BIOS recognize both drives ?
    Where did you like to install linux on second HDD ?
    CAn you change the boot order of the disk ore mimic a IDE drive ?
    Partitioning can also be done by Partition maqic a utility for Windos user but it is not free ware or gparted is free ware
    both can make a lot of different file systems.
    Both utilities are power full , and can do anything you found
    dobby9

  5. #5

    Default Re: suse unable to recognise hard drive

    Yea, I have two hard drives. I have vista on one and was trying to put Suse on the other hard drive.

    I have tried changing the boot order, but I am not sure about mimicking an ide drive. This motherboard has all sorts of features, so it probably can, I just don't know how.
    I just tried again last night after using EasyBCD to mess with the boot file, but it didnt matter. When I have both hard drives in, I get the initramfs error with Ubuntu and Suse doesn't see the hard drives no matter if I have one or both hard drives plugged in. Suse doesn't ever give that an error.

    I had a flash drive this time and Suse saw it. The FD is formatted in ntfs format.
    Delete partitions /dev/sda/ 4.9gb Resize impossible due to inconsistant fs. Try checking fs under windows.
    delete /dev/sda2
    delete /dev/sda5
    create swap partition /dev/sda/ 2.0gb
    create root partiton /dev/sda2 5.0gb
    create partition /dev/sda3/ 533.4mb for home with ext3

    I was using the flash drive for readyboost,so that might be the error it was seeing.

    I just downloaded gpart. I going to take a look at it, tonight. As for Partiton Magic,I used to wonder why anyone pay that much and now that I'm moving on to Dual OS, I understand perfectly. Unfortunately, christmas and everything has me strapped for cash, but I will probably end up getting it after the new year.Maybe,I'll run across some coupons by then.
    Thankyou for the pointers

  6. #6
    Join Date
    Jun 2008
    Location
    Atlanta, Georgia, USA
    Posts
    2,422

    Default Re: suse unable to recognise hard drive

    Whoa! If the kernel does not "see" (as in, "detect") the drives, then partitions and boot loaders and DE's have nothing to do with anything. So . . . are you saying that you managed to actually complete an installation (you said you used the DVD)? Please just describe exactly what you did with openSUSE and what exactly is happening now.

  7. #7

    Default Re: suse unable to recognise hard drive

    When I put in the dvd, I get all the through the process till the hard drive stage.It doesn't matter if I choose gnome or kde,it doesn't detect either of my hard drives and I have to abort every time I try.

    The listing (dev/sda/ is just for the flash drive, that I happen to leave in this time.
    I guess suse could have been installed on my flash drive if I would have continued.

    I see where I made it confusing, the boot order I was referring to was for the hard drives and then I referred to EasyBCD, dobby9 asked
    So you have two HDD drive do the BIOS recognize both drives ?Where did you like to install linux on second HDD ?
    CAn you change the boot order of the disk ore mimic a IDE drive
    The easybcd was point less, I thought maybe something was going on with the boot files. I am just doing different things trying to learn.

    I hopped into my bios just now looking to see if I could make the hard drives mimic ide. I think they are already recognized as ide. The sata port 1 hard drive is listed as Third Ide Master and the second hard drive under sata port 2 is listed as fourth ide master. I don't know what that means, other than the master part. I would think the second hard drive should be a slave drive.

    This could be the reason why I have to disconnect one drive when using Ubuntu before I can get to the GUI part of the install. I am starting to think there is an issue with the controller.

    I am going to try in just a little while to disconnect just my ide cd burner and run the livecd(gnome), this will leave only sata devices (2 sata hard drives and a sata dvd burner).

  8. #8
    Join Date
    Jun 2008
    Location
    Atlanta, Georgia, USA
    Posts
    2,422

    Default Re: suse unable to recognise hard drive

    OK, thanks for the clarification.

    Try this: Boot the installation DVD and then do Ctrl-Alt-F2 (or F9); you will be at a root prompt. Then do:

    Code:
    cd /var/log
    more boot.msg
    lspci
    That will scroll the kernel log, and the lspci will list the primary hardware; look for the chipset and disk controller, especially whether a SATA controller is shown or just an IDE controller. In the kernel log look for loading of the kernel's disk controller drivers. Probably you will see scsi and libata, and another that is specific to the chipset on your motherboard (for example, if the chipset is nvidia you'll see "sata_nv", etc.). Then you should see the disk controller initialized and detection attempted, e.g., a scsi0 and sata1. It's possible you will see the drivers loaded but nothing detected, or that you won't see this at all because there is a problem in communicating with the disk controller. Some controllers are dual IDE/PATA-SATA; from your bios description, could be the case. If in the bios it's set to IDE emulation (also called "legacy") but the drives are SATA, that could be the problem. Or it may be that the bios needs to be set to AHCI, which is the for the newer SATA specification.

    I would change the bios setting to AHCI and try installing. If the disks are recognized and you install, you may be able to switch it back to SATA or whatever Windows requires and Linux may still boot once installed (don't ask). Otherwise, do some googling on the chipset (specifically, the Southbridge if it lists it) and linux installation; you probably will find the key.

  9. #9

    Default Re: suse unable to recognise hard drive

    Either I did something wrong or something is wrong. When I tried what you wrote all I got was file or directory no found for each one. I think I messed up with the cd one, I didn't space after it, so it would have looked like
    cd/var/log instead of cd /var/log
    I'll try that one again.

    I would just go ahead and do it before I post, but I wanted to get your opinion. I managed changed the bios to ahci. The motherboard also has an option enable Linux DID support, which I did, but unfortunately it didn't change anything. The hard drives still were not visible and disconnecting the sata dvd burner did not change a thing. In fact during the process it ask me to put the install cd in the main drive.

    My thought was to go ahead format and repartition with gparted and then install windows vista then suse. I have to install vista first cause Microsoft put some crazy setup for in ahci mode. You have to hop into the registry and make some changes before you can boot into it from ahci mode.Error message when you start a Windows Vista-based computer after you change the SATA mode of the boot drive: "STOP 0x0000007B INACCESSABLE_BOOT_DEVICE"

    My question is, if I go ahead and do this, Is there any special commands or any thing I need to do before I try?
    I'll go ahead and give the cd a go before I do it though, I'm curious if not spacing was the cause.

  10. #10
    Join Date
    Jun 2008
    Location
    Atlanta, Georgia, USA
    Posts
    2,422

    Default Re: suse unable to recognise hard drive

    When you do Ctrl-Alt-F2 you should be switched to a console and see a # prompt, do this command:

    Code:
    ls
    And you should see some directories listed, including /var. That way you know you are in fact in a console. Then the commands should work.

    In your posts you have made reference to both an install CD and DVD. I presume it is the DVD. I haven't tested the above using the CD, only the DVD.

    What you found re the MS requirement and AHCI is not surprising, and is somewhat analagous to Linux. I'm surprised you have to reinstall Vista to make the change though; can't you use the Vista Recovery Environment command line shell to change the Registry?

    I looked at the thread at nvnews and I think it fair to conclude you are looking in the right area - bios setting vis-a-vis disk controller vis-a-v-is the kernel, specific to the 750a chipset - but given that that user had a RAID setup, we can't directly extrapolate to your situation. Once you set your bios to AHCI, and working off the theory that the linux kernel needs to use the ahci driver instead of sata_nv, then when you look at the kernel log check which driver the kernel is loading. If it is sata_nv and not ahci, you can try this: On the DVD menu below there is a place to type Boot Options, type this:

    Code:
    brokenmodules=sata_nv insmod=ahci
    That may force the kernel to use the ahci driver. If you are seeing a timeout error - the kernel will say it is trying to detect on a channel and getting slow response, eventually it gives up - then swap the SATA drive cables on the ports. There are known issues with some controllers having the quirk, with a given drive cabling setup, of being slow to respond and timing out. If you see this, you can also try installing from 11.1 RC1 with its newer kernel.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •