Results 1 to 7 of 7

Thread: Problems with NTLM proxy authentication

  1. #1
    Join Date
    Jun 2008
    Location
    Korneuburg, Austria
    Posts
    177

    Default Problems with NTLM proxy authentication

    I have a problem with the NTLM proxy we use in school. YAST proxy configuration won't work, it just says authentication error.
    We have to login with the user in DOMAIN\user style and a password, in Firefox it works.
    I'll post the error log tomorrow.

  2. #2
    Join Date
    Jun 2008
    Location
    Korneuburg, Austria
    Posts
    177

    Default Re: Problems with NTLM proxy authentication

    Here is the log:
    Code:
    * About to connect() to proxy 10.0.3.1 port 8080 (#0)
    *   Trying 10.0.3.1... connected
    * Connected to 10.0.3.1 (10.0.3.1) port 8080 (#0)
    > GET http:// --proxy-user bgstockerau\\user:password HTTP/1.1
    > User-Agent: curl/7.18.1 (i686-suse-linux-gnu) libcurl/7.18.1 OpenSSL/0.9.8g zlib/1.2.3 libidn/1.8
    > Host:  --proxy-user bgstockerau\\user:password
    > Pragma: no-cache
    > Accept: */*
    > Proxy-Connection: Keep-Alive
    > 
    < HTTP/1.1 400 Bad Request ( The data is invalid.  )
    < Via:1.1 PROXYSRV
    < Connection: close
    * HTTP/1.1 proxy connection set close!
    < Proxy-Connection: close
    < Pragma: no-cache
    < Cache-Control: no-cache
    < Content-Type: text/html
    < Content-Length: 2273  
    < 
    { [data not shown]
      % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                     Dload  Upload   Total   Spent    Left  Speed
    
     54  2273   54  1240    0     0   2792      0 --:--:-- --:--:-- --:--:--  2792
    100  2273  100  2273    0     0   5079      0 --:--:-- --:--:-- --:--:--  336k* Closing connection #0
    
    * About to connect() to proxy 10.0.3.1 port 8080 (#0)
    *   Trying 10.0.3.1... connected
    * Connected to 10.0.3.1 (10.0.3.1) port 8080 (#0)
    > GET http://www.novell.com HTTP/1.1
    > User-Agent: curl/7.18.1 (i686-suse-linux-gnu) libcurl/7.18.1 OpenSSL/0.9.8g zlib/1.2.3 libidn/1.8
    > Host: www.novell.com
    > Pragma: no-cache
    > Accept: */*
    > Proxy-Connection: Keep-Alive
    > 
    < HTTP/1.1 407 Proxy Authentication Required ( The ISA Server requires authorization to fulfill the request. Access to the Web Proxy service is denied.  )
    < Via:1.1 PROXYSRV
    < Proxy-Authenticate: NTLM
    < Proxy-Authenticate: Kerberos
    < Proxy-Authenticate: Negotiate
    < Pragma: no-cache
    < Cache-Control: no-cache
    < Content-Type: text/html
    < Content-Length: 2378  
    < 
    { [data not shown]
    
    100  2378  100  2378    0     0  30817      0 --:--:-- --:--:-- --:--:-- 30817* Connection #0 to host 10.0.3.1 left intact
    
    * Closing connection #0

  3. #3
    Join Date
    Jun 2008
    Location
    Korneuburg, Austria
    Posts
    177

    Default Re: Problems with NTLM proxy authentication

    Code:
    curl --proxy-ntlm --proxy-user DOMAIN\\user:password --url www.google.at --proxy http://10.0.3.1:8080/
    works fine, but how do I set up something like this for the whole system?

  4. #4

    Default Re: Problems with NTLM proxy authentication

    I have the same problem. Can anybody help me? How set Yast-Proxy to use NTLM authentication?

  5. #5
    Join Date
    Jun 2008
    Location
    Korneuburg, Austria
    Posts
    177

    Default Re: Problems with NTLM proxy authentication

    Can anybody help please?

  6. #6
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    2,839

    Default Re: Problems with NTLM proxy authentication

    If the curl command works (is important) and you're using either SuSE 11.x then go to YAST > Network Services > Proxy

    If curl doesn't work, I'm pretty sure you're SOL... In my network I had to turn off Windows Domain authentication at my MS ISA proxy to allow non-browser HTTP connections like Yast Online Update.

  7. #7

    Default Re: Problems with NTLM proxy authentication

    Try using NTLMAPS which acts as a go between.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •