Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: Beta 5, no sound

  1. #1

    Default Beta 5, no sound

    Hello,

    I've been trying the whole day long to get my soundcard operational, but no luck. Initially when I installed suse, every time I logged in, the phonon kept displaying an error message that my card is not working... I read somewhere that switching from the gstreamer to the alsa plugin will solve it (no error message now, but still no sound).

    The exact hardware details of my card can be found here: http://www.alsa-project.org/db/?f=80...3f8b662171be68

    Some more generic hardware information can be found here: Show Box

    PS: I couldn't get the sound to work on opensuse 11.0 either (amongst most of my hardware) so I used Vista since... I'd really like to switch back, but that requires a working distro...

    Thanks,
    Peter

  2. #2
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    25,814
    Blog Entries
    30

    Default Re: Beta 5, no sound

    Quote Originally Posted by Karalabe View Post
    I've been trying the whole day long to get my soundcard operational, but no luck. Initially when I installed suse, every time I logged in, the phonon kept displaying an error message that my card is not working... I read somewhere that switching from the gstreamer to the alsa plugin will solve it (no error message now, but still no sound).

    The exact hardware details of my card can be found here: http://www.alsa-project.org/db/?f=80...3f8b662171be68

    Some more generic hardware information can be found here: Show Box

    PS: I couldn't get the sound to work on opensuse 11.0 either (amongst most of my hardware) so I used Vista since... I'd really like to switch back, but that requires a working distro...
    Thanks for that information. Perhaps next time, you could install tsalsa from packman, and run that script (with root permissions). I know alsa-info comes with alsa (as of 1.0.17 of alsa) so it is easier to run, but I find tsalsa provides additional useful information. Yaloki was kind enough to package tsalsa as an rpm for openSUSE: PackMan :: Package details for tsalsa

    Still, I note from alsa-info script output, that your PC has a IDT 92HD71B7X hardware audio codec. I was trying to help a user with this chipset some time back, and I did not know the solution then. Not long after that I was looking at purchasing a laptop, and the HP dv5 series was one laptop I was considering. Now I am very conservative, and I did not like the idea of purchasing a laptop whose sound is not supported, so I read in some places that it uses a IDT 92HD71B7X. So I had to search (again) for a solution for this codec, so I could make an informed decision if I should purchase this laptop ...

    Researching, I discovered there was a bug report raised (on ubuntu) on this, and a work around solution found: https://bugs.launchpad.net/ubuntu/+bug/269586

    So please, open your /etc/modprobe.d/sound file, and add this line as the last line:
    options snd-hda-intel enable_msi=1
    Then restart your alsa sound driver by typing the following into a gnome-terminal or kde konsole: su -c 'rcalsasound restart' and enter root password when prompted for a password. Then test your sound. A good sound test is to copy and paste the following into a gnome-terminal or kde konsole:
    speaker-test -Dplug:front -c2 -l5 -twav
    You should hear a ladies voice saying "front left" "front right" five times. Check your mixer while that is playing.

    I can't be 100% certain that will work, as the alsa-info script does not provide the hardware information that the tsalsa script provides. And this fix worked on Ubuntu ... I don't know how it will fair on openSUSE.

  3. #3

    Default Re: Beta 5, no sound

    Quote Originally Posted by oldcpu View Post
    Thanks for that information. Perhaps next time, you could install tsalsa from packman, and run that script (with root permissions). I know alsa-info comes with alsa (as of 1.0.17 of alsa) so it is easier to run, but I find tsalsa provides additional useful information. Yaloki was kind enough to package tsalsa as an rpm for openSUSE: PackMan :: Package details for tsalsa

    Still, I note from alsa-info script output, that your PC has a IDT 92HD71B7X hardware audio codec. I was trying to help a user with this chipset some time back, and I did not know the solution then. Not long after that I was looking at purchasing a laptop, and the HP dv5 series was one laptop I was considering. Now I am very conservative, and I did not like the idea of purchasing a laptop whose sound is not supported, so I read in some places that it uses a IDT 92HD71B7X. So I had to search (again) for a solution for this codec, so I could make an informed decision if I should purchase this laptop ...

    Researching, I discovered there was a bug report raised (on ubuntu) on this, and a work around solution found: https://bugs.launchpad.net/ubuntu/+bug/269586

    So please, open your /etc/modprobe.d/sound file, and add this line as the last line:
    options snd-hda-intel enable_msi=1
    Then restart your alsa sound driver by typing the following into a gnome-terminal or kde konsole: su -c 'rcalsasound restart' and enter root password when prompted for a password. Then test your sound. A good sound test is to copy and paste the following into a gnome-terminal or kde konsole:
    speaker-test -Dplug:front -c2 -l5 -twav
    You should hear a ladies voice saying "front left" "front right" five times. Check your mixer while that is playing.

    I can't be 100% certain that will work, as the alsa-info script does not provide the hardware information that the tsalsa script provides. And this fix worked on Ubuntu ... I don't know how it will fair on openSUSE.
    Ok, I ran the tsalsa also: tsalsa.txt - nopaste.com (beta)

    I tried editing the file you suggested, but still nothing . Any other suggestions?

    Thanks for you time

  4. #4
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    25,814
    Blog Entries
    30

    Default Re: Beta 5, no sound

    Quote Originally Posted by Karalabe View Post
    Ok, I ran the tsalsa also: tsalsa.txt - nopaste.com (beta)

    I tried editing the file you suggested, but still nothing . Any other suggestions?
    According to that tsalsa output, you did not have those settings applied. How about running tsalsa WITH the settings applied.

    Did you get any error messages when you restarted alsa? Did you get any error messages when you ran the sound test? Don't forget I can not see the errors you get.

    Please provide me the output of copying and pasting the following, one line at a time, into a gnome-terminal or a konsole:
    rpm -qa | grep alsa
    rpm -qa | grep sound
    rpm -q libasound2
    uname -a
    cat /etc/modprobe.d/sound


    also, try switching OFF your digital sound (thats a wild guess on my part). ie try setting IEC958=OFF

    I also note you have analog loop back ON. Is that a mixer setting in your mixer?

  5. #5

    Default Re: Beta 5, no sound

    Quote Originally Posted by oldcpu View Post
    According to that tsalsa output, you did not have those settings applied. How about running tsalsa WITH the settings applied.

    Did you get any error messages when you restarted alsa? Did you get any error messages when you ran the sound test? Don't forget I can not see the errors you get.

    Please provide me the output of copying and pasting the following, one line at a time, into a gnome-terminal or a konsole:
    rpm -qa | grep alsa
    rpm -qa | grep sound
    rpm -q libasound2
    uname -a
    cat /etc/modprobe.d/sound


    also, try switching OFF your digital sound (thats a wild guess on my part). ie try setting IEC958=OFF

    I also note you have analog loop back ON. Is that a mixer setting in your mixer?
    Yes, indeed the last time I ran the tsalsa before doing the modifications. Here is the modified version: tsalsa.txt - nopaste.com (beta)

    No, I didn't get any error messages. I would have said it if anything odd happens.

    Here are the outputs you requested:
    rpm -qa | grep alsa
    alsa-firmware-1.0.17-1.36
    alsa-1.0.18-6.2
    tsalsa-20080914-0.pm.1
    alsa-oss-1.0.17-1.32
    alsa-utils-1.0.18-5.4
    alsa-plugins-pulse-1.0.18-5.4
    alsa-tools-1.0.18-1.2
    alsa-plugins-1.0.18-5.4
    alsa-oss-32bit-1.0.17-1.29

    rpm -qa | grep sound
    libasound2-1.0.18-6.2
    libasound2-32bit-1.0.18-6.3
    pulseaudio-esound-compat-0.9.12-6.6
    yast2-sound-2.17.10-1.1

    rpm -q libasound2
    libasound2-1.0.18-6.2

    uname -a
    Linux Karalabe-HP 2.6.27.5-2-default #1 SMP 2008-11-11 15:15:33 +0100 x86_64 x86_64 x86_64 GNU/Linux

    cat /etc/modprobe.d/sound
    alias snd-card-0 snd-hda-intel
    alias sound-slot-0 snd-hda-intel
    options snd-hda-intel enable_msi=1


    If by any chance these are of any use, here are the boot messages relating to sound:
    dmesg | grep "sound"
    ALSA sound/pci/hda/hda_codec.c:3047: autoconfig: line_outs=1 (0xd/0x0/0x0/0x0/0x0)
    ALSA sound/pci/hda/hda_codec.c:3051: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
    ALSA sound/pci/hda/hda_codec.c:3055: hp_outs=1 (0xa/0x0/0x0/0x0/0x0)
    ALSA sound/pci/hda/hda_codec.c:3056: mono: mono_out=0x0
    ALSA sound/pci/hda/hda_codec.c:3064: inputs: mic=0xb, fmic=0x0, line=0x0, fline=0x0, cd=0x0, aux=0x0
    ALSA sound/pci/hda/hda_generic.c:678: hda_generic: no proper input path found
    ALSA sound/pci/hda/hda_generic.c:426: hda_generic: no proper output path found
    ALSA sound/pci/hda/hda_generic.c:1021: hda_generic: no PCM found


    Where should I disable the digital sound? (I tried muting it from kmix, but nothing changed).

    About the analog loopback... I have no clue what that is... in my mixer there are a whole lot of things I don't really know what are. ( ImageShack - Hosting :: screenshotrs4.png <- these are all the modifiable things).

  6. #6
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    25,814
    Blog Entries
    30

    Default Re: Beta 5, no sound

    Quote Originally Posted by Karalabe View Post
    cat /etc/modprobe.d/sound
    alias snd-card-0 snd-hda-intel
    alias sound-slot-0 snd-hda-intel
    options snd-hda-intel enable_msi=1
    Maybe I messed up in my notes. I'm certain sound works with this laptop. I've read too many cases of users getting it to work.

    Working on the basis that I messed up in my notes (and my apologies for doing so), try this instead in your /etc/modprobe.d/sound (ie change the last line):
    alias snd-card-0 snd-hda-intel
    alias sound-slot-0 snd-hda-intel
    options snd-hda-intel single_cmd=1
    Then restart your sound as before, with su -c 'rcalsasound restart' . Test your sound. Check your mixer.

  7. #7

    Default Re: Beta 5, no sound

    Quote Originally Posted by oldcpu View Post
    Maybe I messed up in my notes. I'm certain sound works with this laptop. I've read too many cases of users getting it to work.

    Working on the basis that I messed up in my notes (and my apologies for doing so), try this instead in your /etc/modprobe.d/sound (ie change the last line):
    alias snd-card-0 snd-hda-intel
    alias sound-slot-0 snd-hda-intel
    options snd-hda-intel single_cmd=1
    Then restart your sound as before, with su -c 'rcalsasound restart' . Test your sound. Check your mixer.
    Nope, that didn't do the trick either. In my mimxer everything is on, almost at max.

    One more thing, my HP laptop has a few multimedia buttons above the keyboard, and the button used to toggle mute/unmute is signalling, that the sound is muted... (although maybe that needs a special driver too to work properly)...

  8. #8

    Default Re: Beta 5, no sound

    Hmm... ok, an update... maybe this will help:

    speaker-test -Dplug:front -c2 -l5 -twav
    speaker-test 1.0.18

    Playback device is plug:front
    Stream parameters are 48000Hz, S16_LE, 2 channels
    WAV file(s)
    Rate set to 48000Hz (requested 48000Hz)
    Buffer size range from 64 to 16384
    Period size range from 32 to 8192
    Using max buffer size 16384
    Periods = 4
    was set period_size = 4096
    was set buffer_size = 16384
    0 - Front Left
    <here output stops and program "waits">

    speaker-test -c2 -l5 -twav
    speaker-test 1.0.18

    Playback device is default
    Stream parameters are 48000Hz, S16_LE, 2 channels
    WAV file(s)
    Rate set to 48000Hz (requested 48000Hz)
    Buffer size range from 2048 to 8192
    Period size range from 1024 to 1024
    Using max buffer size 8192
    Periods = 4
    was set period_size = 1024
    was set buffer_size = 8192
    0 - Front Left
    1 - Front Right
    Time per period = 2.856688
    0 - Front Left
    1 - Front Right
    Time per period = 3.007898
    0 - Front Left
    1 - Front Right
    Time per period = 3.007866
    0 - Front Left
    1 - Front Right
    Time per period = 3.007718
    0 - Front Left
    1 - Front Right
    Time per period = 3.007884


    But no sound...

  9. #9
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    25,814
    Blog Entries
    30

    Default Re: Beta 5, no sound

    Quote Originally Posted by Karalabe View Post
    Nope, that didn't do the trick either. In my mimxer everything is on, almost at max.

    One more thing, my HP laptop has a few multimedia buttons above the keyboard, and the button used to toggle mute/unmute is signalling, that the sound is muted... (although maybe that needs a special driver too to work properly)...
    With this option:
    options snd-hda-intel single_cmd=1

    please run the tsalsa script again so I can see your mixer. Also, try rebooting with that setting.

  10. #10
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    25,814
    Blog Entries
    30

    Default Re: Beta 5, no sound

    Quote Originally Posted by Karalabe View Post
    (although maybe that needs a special driver too to work properly)...
    No. I don't think so. alsa is THE driver.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •