Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Can't Connect with Windows Remote Desktop

  1. #1
    Join Date
    Nov 2008
    Location
    West Plains, MO, USA
    Posts
    21

    Default Can't Connect with Windows Remote Desktop

    I installed xrdp and opened the rdp port in my firewall. When I try to connect with remote desktop, I get the window into the machine but a connection log dialog pops up with the following:
    Code:
    connecting to sesman ip 127.0.0.1 port 3350
    sesman connect ok
    sending login info to sesman
    login failed
    I checked the warn and message logs. Warn didn't have anything, but the message log had the following:
    Code:
    xrdp-sesman: pam_warn(gdm:auth): function=[pam_sm_authenticate] service=[gdm] terminal=[<unknown>] user=[<unknown>] ruser=[<unknown>] rhost=[<unknown>]
    What am I doing wrong?

  2. #2
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,306

    Default Re: Can't Connect with Windows Remote Desktop

    Hi & Welcome!

    sending login info to sesman
    I use tsclient which uses rdesktop. That works like a charm and also has an easy GUI.

    Is there a reason you are using port 3350 and not 3389?

    Other than that it could be your passing wrong credentials through a set config file or other?
    Have a lot of fun!

  3. #3
    Join Date
    Nov 2008
    Location
    West Plains, MO, USA
    Posts
    21

    Default Re: Can't Connect with Windows Remote Desktop

    Not that I know of. I opened 3389 in my firewall, I'm not sure where the 3350 came from. I just installed it about an hour ago and didn't change any settings.

  4. #4
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,306

    Default Re: Can't Connect with Windows Remote Desktop

    Well then I'd say give port 3389 a swing You don't need to open the port in the Linux firewall.. only on the Windows side if running one there.
    Have a lot of fun!

  5. #5
    Join Date
    Nov 2008
    Location
    West Plains, MO, USA
    Posts
    21

    Default Re: Can't Connect with Windows Remote Desktop

    Ok, I tried switching sesman to port 3389 in /etc/xrdp/sesman.ini, restarted xrdp and tried again. Remote desktop couldn't even open the window to my machine then. Tried adding 3350 to the firewall, still no luck.

    I changed the port back to 3350 in sesman.ini, now I'm back where I started. I can get a window into the machine but it's not authenticating. I've tried connecting from 2 different machines and I've tried connecting as a normal user and as root.

  6. #6
    Join Date
    Jan 2008
    Location
    U.K East Anglia
    Posts
    2,595

    Default Re: Can't Connect with Windows Remote Desktop

    Quote Originally Posted by beef623 View Post
    I installed xrdp and opened the rdp port in my firewall. When I try to connect with remote desktop, I get the window into the machine but a connection log dialog pops up with the following:
    Code:
    connecting to sesman ip 127.0.0.1 port 3350
    sesman connect ok
    sending login info to sesman
    login failed
    I checked the warn and message logs. Warn didn't have anything, but the message log had the following:
    Code:
    xrdp-sesman: pam_warn(gdm:auth): function=[pam_sm_authenticate] service=[gdm] terminal=[<unknown>] user=[<unknown>] ruser=[<unknown>] rhost=[<unknown>]
    What am I doing wrong?
    Moved to Networking

    Andy
    To be is to do = Immanuel Kant
    To do is to be = Descartes.
    Do be do be do = Frank Sinatra

    SuSE user since 7.0,Linux user since 1994

  7. #7
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,306

    Default Re: Can't Connect with Windows Remote Desktop

    Quote Originally Posted by beef623 View Post
    Ok, I tried switching sesman to port 3389 in /etc/xrdp/sesman.ini, restarted xrdp and tried again. Remote desktop couldn't even open the window to my machine then. Tried adding 3350 to the firewall, still no luck.
    I've just got the fact that you are using xrdp to be able to connect from Windows to your Linux system (Linux is the terminal service in this case, not Windows)...

    Nomad - openSUSE states that the default 3389 port is used. It also states it's quite a new service for openSUSE.
    As beta4 states it's been added to openSUSE 11.1 as main package. Could be an idea to see it that works better as the xrp does heavily depend on integrating with parts of X... that's what could be missing in your configuration now?
    Have a lot of fun!

  8. #8
    Join Date
    Nov 2008
    Location
    West Plains, MO, USA
    Posts
    21

    Default Re: Can't Connect with Windows Remote Desktop

    That's the page I was following along with to install xrdp. I'm running 11.1 b4.

    I use remote desktop on the windows side every day so I know it works fine. Are there any config files for xrdp other than the ones in /etc/xrdp? Or maybe some extra log files than an error might be hiding in?

  9. #9
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,306

    Default Re: Can't Connect with Windows Remote Desktop

    I think your best chance for this is to post your question in the factory mailing list. Again this is a new option in openSUSE so I don't think many will have answers on this just yet. The developers might be able to guide you better.

    Have a look here: Communicate - openSUSE

    You can subscribe directly using this address: opensuse-factory+subscribe@opensuse.org

    Cheers,
    Wj
    Have a lot of fun!

  10. #10
    shaunhey NNTP User

    Default Re: Can't Connect with Windows Remote Desktop

    @beef623

    I am also running b4 of 11.1. I am able to get this working, but only at 800x600 (even if I connect at a higher resolution, the desktop inside of the session is only 800x600). I found that I had to set my Windows client to connect at 24bit color. Any other setting produced errors. In addition, I found I had to reboot before the connection worked.

    On a side note, once connected, none of my windows have title bars!

    Being able to connect to my Linux box via RDP from work will be great! I can't wait until they get the kinks ironed out...

    Good luck!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •