Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: change resolution

  1. Default change resolution

    Hi,
    I'm using SUSE 11.1 in Sun xVM VirtualBox on a notebook and I want to change the resolution to 1280x800. So I opened Sax2. But there I can't find my resolution.

    I opened /etc/X11/xorg.conf and changed every 1024x768 to 1280x800 but it didn't help. Changing the resolution with Sax works. But I can just use the resolutions which are predefined in Sax.

    I hope someone can tell me the fault I did.

    Thanks

  2. #2
    Join Date
    Jun 2008
    Location
    Kansas City, MO
    Posts
    582

    Default Re: change resolution

    Quote Originally Posted by thexnecromancerx2 View Post
    I hope someone can tell me the fault I did.
    Thanks
    by installing beta OS
    try picking your monitor model or picking the vesa model with the refresh rate of your monitor since i don't use 11.1 not exactly sure but hope that might help

  3. #3
    Join Date
    Jun 2008
    Location
    PHX
    Posts
    488

    Default Re: change resolution

    Let's check and see if that reso is possible under the installed X:

    $ xrandr
    <>---><^>

  4. Default Re: change resolution

    What to do if the reso isn't possible? I used SUSE 10.3 in the same virtual system and I didn't have a problem.

    Modifiing xorg.conf don't take effect. I have tried 800x600 in xorg.conf and the resolution didn't change but when I changed in Sax2 after a reboot I had 800x600.

  5. Default Re: change resolution

    My fault, I installed SUSE 10.0. It's not beta.


    xrandr says:
    Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
    default connected 1024x768+0+0 0mm x 0mm
    1024 x 768 76.0*

    So, I changed the resolution in Sax2 to 1280x1024 and after reboot xrandr says:
    Screen 0: minimum 1280 x 1024, current 1280 x 1024, maximum 1280 x 1024
    default connected 1280x1024+0+0 0mm x 0mm
    1280 x 1024 77.0*

    As monitor model I picked --> LCD 1280X800@75HZ

  6. #6
    Join Date
    Jun 2008
    Location
    Atlanta, Georgia, USA
    Posts
    2,422

    Default Re: change resolution

    You need to look in the VBox manual. The vbox additions include its own video driver, with a wide range of possible resolutions. The manual explains everything. You are not using the same device driver as you would if you install openSUSE natively.

  7. Default Re: change resolution

    Again my fault. It's definetly SUSE 11.0.

    Is there a difference between SUSE 10.3 and 11.0? I didn't have any problems with SUSE 10.3 and the VBOX.

    I'll look in the manual.

    Thanks

  8. Default Re: change resolution

    After installing the guest addition I can't change the resolution even in Sax. Now many resolutions are listed in Sax but changing the resolution doesn't take effect.

    I think the only way is to downgrade to SUSE 10.3 until SUSE 11 gets better collaboration with VirtualBox.

    Nethertheless I'll try if someone posts a good idea.

  9. #9
    Join Date
    Jun 2008
    Location
    Atlanta, Georgia, USA
    Posts
    2,422

    Default Re: change resolution

    It's not about openSUSE compatibility with VBox - it's about how VBox wants its driver/resolution to be configured.

    From the manual (!!!):

    In Linux guests, VirtualBox video acceleration is available through the X Window System.
    Typically, in todays Linux distributions, this will be the X.Org server. During the
    installation process, X will be set up to use the VirtualBox video driver, using whatever
    graphics modes were set up before the installation. If these modes do not suit your
    requirements, you can change your setup by editing the configuration file of the X
    server, usually found in /etc/X11/xorg.conf.
    VirtualBox can use any default X graphics mode which fits into the virtual video
    memory allocated to the virtual machine, as described in chapter 3.7.1, General settings,
    page 41. You can also add your own modes to the X server configuration file. You
    simply need to add them to the Modes list in the Display subsection of the Screen
    section. For example, the section shown here has a custom 2048x800 resolution mode
    added:
    Section "Screen"
    Identifier "Default Screen"
    Device "VirtualBox graphics card"
    Monitor "Generic Monitor"
    DefaultDepth 24
    SubSection "Display"
    Depth 24
    Modes "2048x800" "800x600" "640x480"
    EndSubSection
    EndSection
    Edit the /etc/X11/xorg.conf file like above except use your desired resolution. Additionally, in the Advanced Topics chapter (yep, in the manual) it shows you how to create your own additional custom resolutions.

  10. Default Re: change resolution

    Sorry I thought installing guest addtion is enough.
    So I tried changing the xorg.conf like described and X didn't start.

    I had to change the entry to:
    Section "Screen"
    #Identifier "Default Screen"
    Device "VirtualBox graphics card"
    Monitor "Generic Monitor"
    DefaultDepth 24
    SubSection "Display"
    Depth 24
    Modes "1280x800" "800x600" "640x480"
    EndSubSection
    EndSection

    Now I have the resolution. That's great. Thanks

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •