Results 1 to 5 of 5

Thread: OpenSUSE 11.0 DMA DVD

  1. #1
    Gianfranco NNTP User

    Default OpenSUSE 11.0 DMA DVD

    I use openSUSE/SuSE from 10.0. Now I have openSUSE 10.3 working very
    well. Trying to install openSUSE 11.0 on another partition I have found
    the major problem with DVD playback. It is jerkily because :


    boot.msg
    .....
    <6>ata2.00: ATAPI: TSSTcorpCD/DVDW SH-W162C, TS12, max UDMA/33
    <4>ata2.00: WARNING: ATAPI DMA disabled for reliablity issues. It can
    be enabled
    <4>ata2.00: WARNING: via pata_ali.atapi_dma modparam or corresponding
    sysfs node.
    <6>ata2.01: ATAPI: TSSTcorpDVD-ROM SH-D162C, TS05, max UDMA/33
    <4>ata2.01: WARNING: ATAPI DMA disabled for reliablity issues. It can
    be enabled
    <4>ata2.01: WARNING: via pata_ali.atapi_dma modparam or corresponding
    sysfs node.
    <6>ata2.00: configured for UDMA/33
    <6>ata2.01: configured for UDMA/33
    ....


    I have IDE hardisk and IDE DVD/DVDW

    On the web I did not found a solution that I can understand and tried
    vary system to set DMA but don't knowning too much of Linux I failed.
    (I tried hdparm - sdparm - modprobe.conf)

    Before to give up and wait for a new release I insert "for fun" in boot
    loader option "pata_ali.atapi_dma=1".

    It works, now DVD playback is fine, but...

    boot.msg
    ......
    <5>Kernel command line:
    root=/dev/disk/by-id/scsi-SATA_SAMSUNG_SP2014NS088J1FYB09569-part8
    resume=/dev/sdb5 splash=verbose pata_ali.atapi_dma=1 vga=0x31a
    <6>bootsplash: verbose mode.
    <3>Unknown boot option `pata_ali.atapi_dma=1': ignoring
    .....

    Now I ask if someone can explain and/or teach me how do a better
    configuration.

    I hope my poor english is enough to expound my problem.

    --------------
    Greetings.

    Gianfranco


    Moterboard Asus P5RD1-V - Nvidia GeForce 7300 GS
    CPU0: Intel(R) Pentium(R) 4 CPU 3.00GHz



    Replace (at) with @ for right address

  2. #2
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,088

    Default Re: OpenSUSE 11.0 DMA DVD

    Typically, your CD/DVD drive should use DMA to speed data transfer, bypassing the CPU. If DMA is disabled, the drive defaults to PIO mode, that, besides being slower, consumes a lot of CPU cycles. This makes the video jerky and increases CPU usage.

    The problem is that if a CD/DVD drive detects any throttling in the transfer process, it starts do downgrade the transfer method; from UDMA to DMA to PIO, and IT DOES NOT GO BACK TO UDMA by itself. The OS may try to set it back to UDMA at the next reboot, or not.

    Now, opensuse 10.3 and previous had a IDE DMA Mode settings in Yast's hardware module where you could check/set the DMA mode of your IDE drives, but for some reason this was removed from 11.0. So you have to resort to the command line utility hdparm. Type "man hdparm" without quotes at a terminal prompt to learn how it works. It's not difficult.

    Keep in mind, however, that a drive that constantly drops out of DMA mode has a problem. It may be itself, or the other drive it's transferring data to, or a defective data cable, etc. Modern computers should have absolutely no difficulty in reading a standard DVD - in mine (Athlon X2) the CPU usage is less than 15% for DVD playback with postprocessing turned on.

    Good luck.

  3. #3
    Gianfranco NNTP User

    Default Re: OpenSUSE 11.0 DMA DVD

    brunomcl ha scritto:
    --

    > Typically, your CD/DVD drive should use DMA to speed data transfer,
    > bypassing the CPU. If DMA is disabled, the drive defaults to PIO mode,
    > that, besides being slower, consumes a lot of CPU cycles. This makes the
    > video jerky and increases CPU usage.
    >
    > The problem is that if a CD/DVD drive detects any throttling in the
    > transfer process, it starts do downgrade the transfer method; from UDMA
    > to DMA to PIO, and IT DOES NOT GO BACK TO UDMA by itself. The OS may try
    > to set it back to UDMA at the next reboot, or not.
    >
    > Now, opensuse 10.3 and previous had a IDE DMA Mode settings in Yast's
    > hardware module where you could check/set the DMA mode of your IDE
    > drives, but for some reason this was removed from 11.0. So you have to
    > resort to the command line utility hdparm. Type "man hdparm" without
    > quotes at a terminal prompt to learn how it works. It's not difficult.
    >
    > Keep in mind, however, that a drive that constantly drops out of DMA
    > mode has a problem. It may be itself, or the other drive it's
    > transferring data to, or a defective data cable, etc. Modern computers
    > should have absolutely no difficulty in reading a standard DVD - in mine
    > (Athlon X2) the CPU usage is less than 15% for DVD playback with
    > postprocessing turned on.
    >
    > Good luck.
    >
    >


    Thank for the answer.

    I used hdparm with "hdparm -d 1 /dev/sr0" but this don't was good for
    a error

    HDIO_SET_DMA failed: Inappropriate ioctl for device
    HDIO_GET_DMA failed: Inappropriate ioctl for device


    and I don't know what to do to set.

    I don't understand why "pata_ali.atapi_dma=1" in the boot options work.

    DVD playback on openSUSE 10.3 and Xp is fine.

    Thank again and Bye.

  4. #4

    Default Re: OpenSUSE 11.0 DMA DVD

    Quote Originally Posted by Gianfranco View Post
    brunomcl ha scritto:
    --

    > Typically, your CD/DVD drive should use DMA to speed data transfer,
    > bypassing the CPU. If DMA is disabled, the drive defaults to PIO mode,
    > that, besides being slower, consumes a lot of CPU cycles. This makes the
    > video jerky and increases CPU usage.
    >
    > The problem is that if a CD/DVD drive detects any throttling in the
    > transfer process, it starts do downgrade the transfer method; from UDMA
    > to DMA to PIO, and IT DOES NOT GO BACK TO UDMA by itself. The OS may try
    > to set it back to UDMA at the next reboot, or not.
    >
    > Now, opensuse 10.3 and previous had a IDE DMA Mode settings in Yast's
    > hardware module where you could check/set the DMA mode of your IDE
    > drives, but for some reason this was removed from 11.0. So you have to
    > resort to the command line utility hdparm. Type "man hdparm" without
    > quotes at a terminal prompt to learn how it works. It's not difficult.
    >
    > Keep in mind, however, that a drive that constantly drops out of DMA
    > mode has a problem. It may be itself, or the other drive it's
    > transferring data to, or a defective data cable, etc. Modern computers
    > should have absolutely no difficulty in reading a standard DVD - in mine
    > (Athlon X2) the CPU usage is less than 15% for DVD playback with
    > postprocessing turned on.
    >
    > Good luck.
    >
    >


    Thank for the answer.

    I used hdparm with "hdparm -d 1 /dev/sr0" but this don't was good for
    a error

    HDIO_SET_DMA failed: Inappropriate ioctl for device
    HDIO_GET_DMA failed: Inappropriate ioctl for device


    and I don't know what to do to set.

    I don't understand why "pata_ali.atapi_dma=1" in the boot options work.

    DVD playback on openSUSE 10.3 and Xp is fine.

    Thank again and Bye.
    Hello!

    I have this problem too! Did you find any result?
    I've already tried:

    #/dev/sr0 : on
    bash: /dev/sr0: Permission denied


    and


    #hdparm -d1 /dev/sr0

    /dev/sr0:
    setting using_dma to 1 (on)
    HDIO_SET_DMA failed: Inappropriate ioctl for device
    HDIO_GET_DMA failed: Inappropriate ioctl for device


    Please help me because I can't burn CD under 2 hours or extract files in normal time! :-(

    I use 11.2 64 bit

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    14,033
    Blog Entries
    12

    Default Re: OpenSUSE 11.0 DMA DVD

    Hi, welcome here. My advice: start a new thread. This one is old, it's about openSUSE 11.0, my bet is that not many will read this.
    Use a clear title, and in the post, be clear about openSUSE version, desktop used and the repos you configured.
    - Athlon X6 3.6 GHz, 16 GB DDR3, 30 GB SSD, 3 TB of disks, GT540, openSUSE 12.2 x86_64 + KDE 4.10 + GNOME 3
    - ASUS A73SD, Intel + GT610M Optimus, 6 GB, 120 GB SSD, openSUSE Tumbleweed

    Anything that can go wrong.... will teach us

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •