Results 1 to 5 of 5

Thread: TCP Port 21 open by default? (OpenSuse 11)

  1. #1
    waltertsai NNTP User

    Smile TCP Port 21 open by default? (OpenSuse 11)

    Hi,
    I installed OpenSuse 11 and configured one of server's NIC to external zone right after finish installation. And disconnected all the others NICs. Then I allow ssh to be public to external zone, save the settings and restart the Linux box.

    So theoretically, only port 22 is visible to outside world.
    However, when I use nmap to port scan the brand-new Suse11 box, the tcp port 21 was open. I ran the port scanning again and confirmed the port was opened. However, in iptables, the rule for accept "tcp 21" doesn't exist.

    Weird.

    Regards,
    Walter

  2. #2
    waltertsai NNTP User

    Cool Re: TCP Port 21 open by default? (OpenSuse 11)

    Guys, I just figured out what's happening.
    The root cause is my ISP has a dummy ftp in front of my server. - not yet sure it's for eavesdropping or mistakenly configured. Thanks for your time reading my question.

    Cheers,
    Walter

  3. #3
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,941
    Blog Entries
    4

    Default Re: TCP Port 21 open by default? (OpenSuse 11)

    Or to prevent people like you from trying to set up servers.

  4. #4

    Default Re: TCP Port 21 open by default? (OpenSuse 11)

    How to enable ftp port in Open Suse firewall?

    If your server install vsftpd, so after installation it will show in vsftpd server in the drop down menu of Allow Services.

    Let's follow: type command FTPServer:~# yast2 > Security and Users > Firewall > Allow Services > choose External Zone > and in the Service to Allow choose vsftpd Server (it lists at the bottom, you may not mention)> Click Add > after add select vsftpd Server in the field and then click on Advanced > modify TCP to port 20 or 21 > Ok > Ok
    FTPServer:~# rcSuSEfirewall2 start

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    22,861

    Default Re: TCP Port 21 open by default? (OpenSuse 11)

    On 2011-08-04 14:26, caryoo wrote:
    >
    > How to enable ftp port in Open Suse firewall?


    You are posting this in a thread that is three years old, and not related
    to the problem of the OP.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •