Results 1 to 8 of 8

Thread: User can't access samba shares

  1. #1

    Default User can't access samba shares

    Hallo!

    I'm using openSuse 11.0 and Samba 3.2. I'm trying to access the Samba shares from Windows-PCs.
    My problem is, that some users can't access the samba shares.
    I've created every user with the graphical user-manager in YaST an than added every user with "smbpasswd -a username" to the list of samba-users?

    Any glue whats the problem here?

  2. #2
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    10,946
    Blog Entries
    2

    Default Re: User can't access samba shares

    Hello wewa_chris. Welcome to the Forums.

    A bit more information please on how far they can go in their quests:

    Which shares can't be accessed, the individual users' home directories or a common share?
    Can they all see the computer thay seek in the windows network browser?
    Can they all see the shares they seek?
    Can they all see the shares they seek to access but can't get through the authentication process?

    i.e. just where is the problem?

  3. #3

    Default Re: User can't access samba shares

    Hy.

    I access the Linux-PC with Samba by executing "\\PC_Samba" on a Win-PC.
    Than appears the window where you are asked for your username and password. If you enter here the name of eg. user1 and his passwd you are forwarded to the shares and the password-prompt-window disappears.
    But if you enter the data of another user you are not forwarded to the shares an the password-prompt still appears. But I'm sure that both username and password are entered correctly.

  4. #4
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    10,946
    Blog Entries
    2

    Default Re: User can't access samba shares

    It doesn't make sense that the mechanism works, but only for some, so check the list of names/members in the Samba database with this command:
    sudo pdbedit -L
    Then if they are all there, re-enter the passwords of the members that fail with the command
    sudo smbpasswd -a username
    If a username is rejected by "smbpasswd" then check the Linux user database in Yast.

    any luck??

  5. #5

    Default Re: User can't access samba shares

    Thanks for your help. But the Problem was somewhere else. In YaST - Samba-Server - register-card Identity - Advanced Setup - Global Setup for experts.
    There I had to add some users manually to the list of valid users. (Not all were listed up, why aren't they added automatically?)

  6. #6
    Join Date
    Jun 2008
    Location
    Berlin, Germany
    Posts
    373

    Default Re: User can't access samba shares

    Hi,
    in our flat share that username & password stuff makes little sense. So I edited smb.conf for some shares that everyone in our network should be able to access.
    I added two lines to the [global] section:
    Code:
    [global]
    	map to guest = Bad User
    	usershare allow guests = Yes
    And edited some shares a little...
    This is a share with read access:
    Code:
    [music]
    	comment = music on my desktop
    	path = /home/me/music/
    	create mask = 0700
    	directory mask = 0700
    	guest ok = yes
    A share with write permissions:
    Code:
    [transfer]
    	comment = writeable
    	inherit acls = Yes
    	inherit permissions = Yes
    	path = /home/me/Transfer/
    	public = Yes
    	directory mask = 0777
    	create mask = 0666
    	browseable = Yes
    	guest ok = Yes
    	writeable = Yes
    	force user = me
    To make sure that files transferred to your writeable share via smb are yours, use the force user option. Otherwise files sent to that share will belong to user nobody.
    Well...that code does not look nice but it works - at least for me. And I'm still learning.

  7. #7

    Default Re: User can't access samba shares

    Ok, I'll try this too.

    But has anybody a clue (sorry for "glue" in my 1st post) why samba users are not added automatically to the list of valid users?

  8. #8
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    10,946
    Blog Entries
    2

    Default Re: User can't access samba shares

    Quote Originally Posted by wewa_chris View Post
    Thanks for your help. But the Problem was somewhere else. In YaST - Samba-Server - register-card Identity - Advanced Setup - Global Setup for experts.
    There I had to add some users manually to the list of valid users. (Not all were listed up, why aren't they added automatically?)
    It's confusing isn't it.

    Think about it: If every member of the Samba user database was automatically added to the list of allowed users, the parameter "valid users" would become illogical and unnecessary, because by default there could be no invalid users.

    Or here's another way: if you want everyone to be a valid user automatically, don't use the parameter at all. Delete the parameter and everyone can access the share. Now isn't that confusing!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •