Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Denemo compilation problem

  1. #1

    Default Denemo compilation problem

    Hi, I am trying to build Denemo - music notation software.
    However during configure I received and error:
    Code:
    configure: error: Package requirements (g-wrap-2.0-guile >= 1.9) were not met:
    But there is no such package in any repo...anyone help?

  2. #2
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    828

    Default Re: Denemo compilation problem

    On Sun, 24 Aug 2008 21:46:01 GMT
    Beyo <Beyo@no-mx.forums.opensuse.org> wrote:

    >
    > Hi, I am trying to build Denemo - music notation software.
    > However during configure I received and error:
    >
    > Code:
    > --------------------
    >
    > configure: error: Package requirements (g-wrap-2.0-guile >= 1.9) were not
    > met:
    > --------------------
    >
    > But there is no such package in any repo...anyone help?
    >
    >


    You'll need to install the 'g-wrap' package from the GNOME:/STABLE
    repository.

    Use the repo manager in Yast Software, then add the community repository
    "Gnome:/Stable".

    Then install 'g-wrap'.

    Loni

    --
    L R Nix
    lornix@lornix.com


  3. #3

    Default Re: Denemo compilation problem

    This is the same:
    Code:
    checking for GWRAP... configure: error: Package requirements (g-wrap-2.0-guile >= 1.9) were not met:
    
    Duplicate definition of variable 'datarootdir' in '/usr/lib/pkgconfig/g-wrap-2.0-guile.pc'
    
    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.
    
    Alternatively, you may set the environment variables GWRAP_CFLAGS
    and GWRAP_LIBS to avoid the need to call pkg-config.
    See the pkg-config man page for more details.
    but i have this file in /usr/lib/pkgconfig/ so why configure doesn't detect this?

  4. #4

    Default Re: Denemo compilation problem

    If you look into the file /usr/lib64/pkgconfig/g-wrap-2.0-guile.pc you'll see the error described in the error message:

    ----------
    prefix=/usr
    exec_prefix=/usr
    datarootdir=${prefix}/share
    ^^^^^^^^^^^^^^
    libdir=/usr/lib64
    includedir=/usr/include
    datarootdir=${prefix}/share
    ^^^^^^^^^^^^^^
    datadir=/usr/share
    module_directory=${prefix}/share/guile/site
    ----------

    datarootdir is defined twice.

    I've hit the same problem. I'm trying to buile guile-gnome-platform.

    Misc notes:
    platform: openSUSE_11.0 x86_64
    g-wrap: version 1.9.10-32.1

    Regards
    Werner

  5. #5

    Default Re: Denemo compilation problem


  6. #6

    Default Re: Denemo compilation problem

    I get a similar problem when I run ./configure for denemo 0.9.2 :

    checking pkg-config is at least version 0.9.0... yes
    checking for GTK2... yes
    checking for GUILE... no
    configure: error: Package requirements (guile-1.8 >= 1.8) were not met:

    No package 'guile-1.8' found

    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.

    Alternatively, you may set the environment variables GUILE_CFLAGS
    and GUILE_LIBS to avoid the need to call pkg-config.
    See the pkg-config man page for more details.
    guile IS installed (version 2.0).
    Anyone can help?
    Thanks,

    - pascal

  7. #7
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,661

    Default Re: Denemo compilation problem

    Am 21.02.2012 09:56, schrieb ppligdas:
    > guile IS installed (version 2.0).


    Is guile-devel installed, what is the output from
    Code:
    pkg-config --list-all | grep guile

    --
    PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
    4.6.0 | GeForce GT 420 | 16GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.8.0 |
    nVidia ION | 3GB Ram

  8. #8
    Join Date
    Feb 2012
    Location
    Greece
    Posts
    119

    Default Re: Denemo compilation problem

    Quote Originally Posted by martin_helm View Post
    Am 21.02.2012 09:56, schrieb ppligdas:
    > guile IS installed (version 2.0).


    Is guile-devel installed, what is the output from
    Code:
    pkg-config --list-all | grep guile
    It is :

    pascal@linux-7vld:~/Music-Editors/denemo-0.9.2> pkg-config --list-all | grep guile
    guile-2.0 GNU Guile - GNU's Ubiquitous Intelligent Language for Extension
    pascal@linux-7vld:~/Music-Editors/denemo-0.9.2>
    Thanks for helping

    - pascal

  9. #9
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,661

    Default Re: Denemo compilation problem

    Ok so it is not a problem of missing development packages but seems to
    be a problem that this configure looks explicitly for guile 1.8 and does
    not accept 2.0.
    There are two things you can try:
    Install guile1 and libguile1-devel in addition to guile
    http://software.opensuse.org
    it is in this repository
    http://download.opensuse.org/reposit.../openSUSE_12.1

    and try configure again, most probably it will fail without further
    configuration (but simply try it first) and you need to set GUILE_CFLAGS
    and GUILE_LIBS manually as the error message tells you to point to the
    right libraries and flags.

    --
    PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
    4.6.0 | GeForce GT 420 | 16GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.8.0 |
    nVidia ION | 3GB Ram

  10. #10
    Join Date
    Feb 2012
    Location
    Greece
    Posts
    119

    Default Re: Denemo compilation problem

    Quote Originally Posted by martin_helm View Post
    Ok so it is not a problem of missing development packages but seems to
    be a problem that this configure looks explicitly for guile 1.8 and does
    not accept 2.0.
    There are two things you can try:
    Install guile1 and libguile1-devel in addition to guile
    software.opensuse.org: Download openSUSE 12.1
    it is in this repository
    Index of /repositories/devel:/languages:/misc/openSUSE_12.1

    and try configure again, most probably it will fail without further
    configuration (but simply try it first) and you need to set GUILE_CFLAGS
    and GUILE_LIBS manually as the error message tells you to point to the
    right libraries and flags.
    I tried to install guile1 but I got too many conflicts and did not want to get into more trouble. I would like to play with the environment variables if I knew what their values are supposed to be. Instead, I copied the file guile-1.8.pc, I found in the denemo dir, to /usr/lib/pkgconfig/. Then I configured again and got

    Code:
    checking pkg-config is at least version 0.9.0... yes
    checking for GTK2... yes
    checking for GUILE... yes
    checking for XML2... yes
    checking for GTKSOURCEVIEW... yes
    checking for RSVG... no
    configure: error: Package requirements (librsvg-2.0 >= 2.0) were not met:
    
    No package 'librsvg-2.0' found
    Sure enough librsvg _IS_ installed and in fact it's a newer version (2.2.xx).

    Any ideas,

    - pascal

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •