Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: OpenSUSE 11 - No internet connection

  1. #1
    Join Date
    Aug 2008
    Location
    La Jolla, CA
    Posts
    73

    Unhappy OpenSUSE 11 - No internet connection

    Hi all,
    I just successfully completed a new dual-boot installation of OpenSUSE 11 along with Vista x64. The install went great and dual-booting works fine. But I cannot get a connection to the internet, no matter what I try. Granted, I'm a bit lost in this new environment, but I have managed to stumble onto various tools that would seem to address the issue. Unfortunately, no luck.
    I have cable modem service from Time Warner, but there is only DSL, ISDN, and Modem icons in the Yast "network devices" section. Also, I'm going through a Linksys WRT56G router. All other computers are connecting fine, and Vista connects fine when I boot to it on this machine.
    When I choose "Network Settings" in Yast, it shows my RTL8111/8168B PCI Express Gigabit Ethernet controller, but says (Not connected). I set it to use DHCP. Can anyone walk me through setting this up properly? I must be missing something. By the way, I installed the KDE 4 desktop.

    My system:
    Gigabyte GA-P45-DS3L BIOS F7
    E7200 Core2Duo 2.53Ghz 1066Mhz FSB 3MB L2
    SuperTalent 2x2G DDR2-800 PC6400 CL 5-5-5-15 (T800UX4GC5)
    Seagate 500GB SATA2 7200 32mb HD
    EVGA 8800GT 512MB Superclocked Edition
    Ultra X-connect X2 550-watt PSU
    Vista x64 SP1 and OpenSUSE 11.0

  2. #2
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,009
    Blog Entries
    2

    Default Re: OpenSUSE 11 - No internet connection

    Quote Originally Posted by mxcrowe View Post
    Hi all,
    I just successfully completed a new dual-boot installation of OpenSUSE 11 along with Vista x64. The install went great and dual-booting works fine. But I cannot get a connection to the internet, no matter what I try. Granted, I'm a bit lost in this new environment............
    Hello and welcome to the openSUSE Forums. Hope you get to like Suse -- plenty of help here!

    I suggest you check the configuration of the network card, which should have been automatic, but hey anything can happen in a "strange environment". There's a pictorial walk through on the net that should help:
    HowTo Configure a network card in Suse/openSUSE 10.x for LAN and Internet Access.
    I suggest this one: "For the default DHCP configuration use Pics 1 to 6 inclusive" and if you need to define the name servers (translate: if that doesn't work), maybe this one: "For DHCP on steroids use Pics 1, 2, 5, 6, 7 and 8"

    Luck

  3. #3
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,009
    Blog Entries
    2

    Default Re: OpenSUSE 11 - No internet connection

    Uh Oh .......... Something was tugging at my memory and I found this similar problem for the RTL8111/8168B: network is unreachable (trying to connect to LAN/Internet) - openSUSE Forums

    So this might be the same card, which is problematic in Linux until you install the realtek drivers. Have a read of the linked thread and see if that's for you, probably it is.

  4. #4
    Join Date
    Aug 2008
    Location
    La Jolla, CA
    Posts
    73

    Default Re: OpenSUSE 11 - No internet connection

    Thanks so much for the replies. I will work on it this evening. I really am looking forward to learning Linux, and SUSE seems so cool, so I hope this network issue is not a show-stopper. I'll report back with results asap.
    Thx!

  5. #5

    Default Re: OpenSUSE 11 - No internet connection

    I have the same problem with a rtl8111 but as a noob im unable to install the drivers from realtek's site followed the instructions but it doesn't work get errors during make command

  6. #6
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,009
    Blog Entries
    2

    Default Re: OpenSUSE 11 - No internet connection

    Quote Originally Posted by Osculim View Post
    I have the same problem with a rtl8111 but as a noob im unable to install the drivers from realtek's site followed the instructions but it doesn't work get errors during make command
    Do you want any assistance?

  7. #7

    Default Re: OpenSUSE 11 - No internet connection

    Quote Originally Posted by swerdna View Post
    Do you want any assistance?
    yes assistance would be most welcome I followed the commands in the readme file it doesnt work. the 2 one rmmod gives "command not found" and the make command just throws out errors then stops. Sorry if i sound totally stupid i got no idea whats goin on

  8. #8
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,009
    Blog Entries
    2

    Default Re: OpenSUSE 11 - No internet connection

    Quote Originally Posted by Osculim View Post
    yes assistance would be most welcome I followed the commands in the readme file it doesnt work. the 2 one rmmod gives "command not found" and the make command just throws out errors then stops. Sorry if i sound totally stupid i got no idea whats goin on
    Not stupid. there's no stupid question in newbie land in Linux. It's quite a hazy landscape.

    Try this: when you open the console/terminal window, enter su as the first thing and answer the password question. That gives you supernatural powers, the ability to tap the "force" available to the Jedi Masters. Then proceed with the instructions in the download document.

    If you want to learn more about su, then enter this command into a text console:
    info coreutils 'su invocation'

  9. #9

    Default Re: OpenSUSE 11 - No internet connection

    Quote Originally Posted by swerdna View Post
    Not stupid. there's no stupid question in newbie land in Linux. It's quite a hazy landscape.

    Try this: when you open the console/terminal window, enter su as the first thing and answer the password question. That gives you supernatural powers, the ability to tap the "force" available to the Jedi Masters. Then proceed with the instructions in the download document.

    If you want to learn more about su, then enter this command into a text console:
    last time i tried the su command it didnt wanna do it ill give it another bash. Just one question i see there is 2 drivers on the site i presume i must use the 2.6 kernel one is that correct ?

  10. #10
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,009
    Blog Entries
    2

    Default Re: OpenSUSE 11 - No internet connection

    Quote Originally Posted by Osculim View Post
    last time i tried the su command it didnt wanna do it ill give it another bash. Just one question i see there is 2 drivers on the site i presume i must use the 2.6 kernel one is that correct ?
    Yep, that's the one for openSUSE 11.0.

    Also, when you re-do the commands, if you run into trouble, use your mouse to copy and paste the dialogue on the console screen -- and post it back here so we can examine what happened. So to make that all clearer to us, maximise the console screen before you do the commands, so there aren't too many double lines (line/carriage returns).

    My the Force be with you.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •