Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: opensuse 11 - ifup eth0 fails on boot

  1. #1
    ganymede01 NNTP User

    Unhappy opensuse 11 - ifup eth0 fails on boot

    Hi all

    I use plain old ifup to manage my networks, I have no idea what my problem is, everytime my pc reboots the network does not start automatically i have to manually ifup eth0 from console - this is seriously ****. Such a basic function and it doesnt work.

    Here is my ifup config file:

    Ganymede@Apotheosis:/etc/sysconfig/network> cat ifcfg-eth0
    BOOTPROTO='static'
    BROADCAST=''
    ETHTOOL_OPTIONS=''
    IPADDR='196.211.113.10/29'
    MTU=''
    NAME='88E8056 PCI-E Gigabit Ethernet Controller'
    NETMASK=''
    NETWORK=''
    REMOTE_IPADDR=''
    STARTMODE='auto'
    USERCONTROL='yes'
    PREFIXLEN=''

    Here is the output from boot log on start:

    Setting up network interfaces:
    lo
    lo IP address: 127.0.0.1/8
    IP address: 127.0.0.2/8
    done eth0 device: Marvell Technology Group Ltd. 88E8056 PCI-E Gigabit Ethernet Controller (rev 12)
    eth0 IP address: 196.XXX.XXX.XX/29
    done eth1 device: Marvell Technology Group Ltd. 88E8001 Gigabit Ethernet Controller (rev 14)
    eth1 IP address: 196.XXX.XXX.XX/29
    done wlan0
    No configuration found for wlan0


    So in a single sentence... wtf is going on?

    Thanks

    Gany

  2. #2

    Default Re: opensuse 11 - ifup eth0 fails on boot

    Double check in Yast the cards configuration and make sure it is set to activate at boot time.

  3. #3
    ganymede01 NNTP User

    Default Re: opensuse 11 - ifup eth0 fails on boot

    Did that a million times...

    Surely yast just edits that file anyways...which has it already specified as 'auto'

  4. #4

    Default Re: opensuse 11 - ifup eth0 fails on boot

    I have the same problem. I upgraded 3 existing SUSE 10.x servers now, and each and everyone of them does NOT start networking automatically. It used to work, and broke on upgrade. I "just" have to manually enter "rcnetwork restart" and everything works.

    Then I wrote a startup script that runs automatically after the network script from SUSE, and does nothing else then
    ifdown eth0
    ifup eth0
    and after this it works. But that cannot be the solution. WTF do I do wrong, what is needed that openSUSE 11.0 can automatically startup the network with it's own scripts.

    Thanks, zmi

  5. #5

    Default Re: opensuse 11 - ifup eth0 fails on boot

    Nobody else got this problem?

  6. #6

    Default Re: opensuse 11 - ifup eth0 fails on boot

    My USERCONTROL parameter is set to NO if that makes a difference.

  7. #7

    Default Re: opensuse 11 - ifup eth0 fails on boot

    Example from my workstation:
    # cat /etc/sysconfig/network/ifcfg-eth0
    Code:
    BOOTPROTO='static'
    BROADCAST=''
    ETHTOOL_OPTIONS=''
    IPADDR='10.0.0.2/24'
    MTU=''
    NAME='88E8056 PCI-E Gigabit Ethernet Controller'
    NETWORK=''
    REMOTE_IPADDR=''
    STARTMODE='auto'
    USERCONTROL='no'
    I tried calling yast, deleted all network settings and re-assigned the IPs, still the network does NOT autostart. I'm very puzzled that nobody else gets this. Did nobody upgrade from an existing SUSE 10.x and have this problem?

    mfg zmi

  8. #8

    Default Re: opensuse 11 - ifup eth0 fails on boot

    Nobody? Where can I contact somebody from SUSE?

  9. #9

    Default Re: opensuse 11 - ifup eth0 fails on boot

    try changing STARTMODE to ifplugd.

  10. #10
    timoV1 NNTP User

    Default Re: opensuse 11 - ifup eth0 fails on boot

    I have the very same problem. After upgrading from 10.3 to 11.0 network setup during boot process returned error:
    Code:
      eth0  ifplugd is not running
      eth0  is down
      etho  interface could not be set up until now
    (network card: Marvell 88E8001 Gigabit)

    STARTMODE="ifplugd" (instead of "auto") did not help

    As mentioned before the only work around was to add an init script which runs after network script and calls ifdown eth0 and ifup eth0.

    For error tracing: running "rcnetwork restart" in the init script will fail as well, but after login running "rcnetwork restart" in terminal works.

    Timo

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •