Results 1 to 5 of 5

Thread: NFS Server HOWTO?

  1. #1

    Default NFS Server HOWTO?

    I went through yast to set up a NFS share on my desktop running openSuSE 11 that I used as a file server with roughly a terrabyte in RAID5. I've formatted the raidset and I'd like to set up that as a fileshare. For linux I see the NFS server and appears to have decent security. How do I easily set up a folder to be shared over the lan from my laptop? I tried the obvious of right-click in dolphin and use the share options and it just has an error that I can't read all of. I then went to yast and tried to set up the NFS server but the error I get says to make sure the perl script *fileshare* set root to uid or uuid, something to that effect and I don't quite understand all the permissions in linux much less SuSE 11. I hope I described my issue well enough. I'm off to bed. Thanks in advance.

  2. #2
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    2,029

    Default Re: NFS Server HOWTO?

    NFS - openSUSE

    At the bottom there's "NFS HOWTO" that's pretty generic for all Linux distributions.

  3. #3

    Default Re: NFS Server HOWTO?

    Hi,

    Its pretty simple. All you need to edit your /etc/export and add the lines and bounce nfs
    here is a sample one
    /data/mp3/ 10.30.50.0/255.255.255.0(rw,no_root_squash,no_all_squash,sync)
    meaning all systems in the 10.30.50 network can access this share.
    now details of other options
    rw,no_root_squash,sync

    RW Attribute
    Mount the file system with Read/Write ( rw) access.

    No Root Squash
    Disable root squashing for the superuser with the No Root Squash ( no_root_squash) option. This allows root users on client computers to have root access on the server. With the No Root Squash option, mount requests for root are not mounted to the anonymous user ( nobody).


    Sync
    Specify the Sync ( sync) option, which requires all file system writes to be committed to disk before the request can be completed.


    Read this Cool Solutions: How to Setup an NFS Export on your Linux Desktop

    HTH,

    VinuKaimal.

  4. #4

    Default Re: NFS Server HOWTO?

    I've followed this guide on how to set up an NFS server (openSUSE11), and when I try to connect to it from another openSUSE 11 machine with the mount command, I get

    RPCBind failed, with an internal error.

    Any ideas?

    --Kp

  5. #5
    nabendu NNTP User

    Question Re: NFS Server HOWTO?

    same thing happening here, some RPC bind problem in client..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •