Results 1 to 8 of 8

Thread: Problem with Realtek RTL-8110SC/8169SC

  1. #1

    Default Problem with Realtek RTL-8110SC/8169SC

    Hi all,

    I have a problem with my ethernet card Realtek RTL-8110SC/8169SC on my Asus P5K Premium Board.

    I use openSuSE 10.3... the module used is "r8169".
    I use a static IP... no DHCP.

    I don't think that the configuration is incorrect, because mostly the network works fine.

    Sometimes - unfortunately not reproduceable - the ethernet connection fails with "link down"... more often it fails with "lower speed" (10MBit or 100MBit instead of 1000MBit).

    If the network fails I have to restart the computer until the network has been initialised correctly (sometimes more than one restart). "rcnetwork restart" doesn't help

    I tried to change the switch and the cable but the problem is still the same.

    With Windows - on the same machine - there seem to be no problems with the network card

    Yes I tried the Windows setting "Wake-on-lan after shutdown"... but that makes no difference. The problem also exists between two Linux boots.

    I already asked for help within a thread in the german forum Linux-Club, but no one could help me to solve the problem

    Thanks for your help

    Alf

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    317

    Default Re: Problem with Realtek RTL-8110SC/8169SC

    Did you use PPPE ?
    Are you sure that it not should be IP dynamic ?
    Before I run DHCP I use a Belkin ethernet card It chip was Realtek and it only
    works properly with PPPE IP dynamic
    dobby9
    Last edited by dobby9; 29-Jul-2008 at 05:59. Reason: ADD info

  3. #3

    Default Re: Problem with Realtek RTL-8110SC/8169SC

    Hi dobby,

    I'm not sure, but as far as I know I only need PPPoE for e.g. DSL connections

    My problem is the ethernet connection between the computer (network card) and the network switch.

    Please correct me if I am wrong.

    Alf

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    317

    Default Re: Problem with Realtek RTL-8110SC/8169SC

    Well first a misread you,re thread ,sorry fore that.
    But when I was still working , every time I longin on our network I get I new IP adres ,when I have shutdown my computer
    They only a sign fixed IP to the servers and
    network printers
    So I do not know how you,res is set up

    dobby9
    Last edited by dobby9; 29-Jul-2008 at 07:16. Reason: add information

  5. #5

    Default Re: Problem with Realtek RTL-8110SC/8169SC

    Now the connection problem appears again while booting

    /var/log/messages:
    Code:
    Jul 29 18:00:31 computer ifup:     eth0      device: Realtek Semiconductor Co., Ltd. RTL-8110SC/8169SC Gigabit Ethernet (rev 10)
    Jul 29 18:00:31 computer kernel: r8169: eth0: link down
    Jul 29 18:00:31 computer ifup:     eth0
    Jul 29 18:00:31 computer ifup: IP address: 192.168.0.24/24
    Jul 29 18:00:31 computer ifup:
    Jul 29 18:00:32 computer kernel: NET: Registered protocol family 10
    Jul 29 18:00:32 computer kernel: lo: Disabled Privacy Extensions
    Jul 29 18:00:32 computer kernel: ADDRCONF(NETDEV_UP): eth0: link is not ready
    Jul 29 18:00:32 computer kernel: Mobile IPv6
    Jul 29 18:00:32 computer kernel: ip6_tables: (C) 2000-2006 Netfilter Core Team
    ... and some seconds later ...
    Code:
    Jul 29 18:00:38 computer kernel: r8169: eth0: link up
    Jul 29 18:00:39 computer kernel: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
    The connection speed is only 100MBit:
    Code:
    Settings for eth0:
            Supported ports: [ TP ]
            Supported link modes:   10baseT/Half 10baseT/Full
                                    100baseT/Half 100baseT/Full
                                    1000baseT/Full
            Supports auto-negotiation: Yes
            Advertised link modes:  10baseT/Half 10baseT/Full
                                    100baseT/Half 100baseT/Full
                                    1000baseT/Full
            Advertised auto-negotiation: Yes
            Speed: 100Mb/s
            Duplex: Full
            Port: Twisted Pair
            PHYAD: 0
            Transceiver: internal
            Auto-negotiation: on
            Supports Wake-on: pumbg
            Wake-on: g
            Current message level: 0x00000033 (51)
            Link detected: yes
    The command "ethtool -s eth0 speed 1000" disables the connection completly
    Log output:
    Code:
    Jul 29 18:16:01 computer kernel: r8169: eth0: link down

    Someone an idea

  6. #6

    Default Re: Problem with Realtek RTL-8110SC/8169SC

    After reboot the speed was only 10MBit...
    Code:
    Settings for eth0:
            Supported ports: [ TP ]
            Supported link modes:   10baseT/Half 10baseT/Full
                                    100baseT/Half 100baseT/Full
                                    1000baseT/Full
            Supports auto-negotiation: Yes
            Advertised link modes:  10baseT/Half 10baseT/Full
                                    100baseT/Half 100baseT/Full
                                    1000baseT/Full
            Advertised auto-negotiation: Yes
            Speed: 10Mb/s
            Duplex: Half
            Port: Twisted Pair
            PHYAD: 0
            Transceiver: internal
            Auto-negotiation: on
            Supports Wake-on: pumbg
            Wake-on: g
            Current message level: 0x00000033 (51)
            Link detected: yes
    And after the third reboot everything is ok...
    Code:
    Settings for eth0:
            Supported ports: [ TP ]
            Supported link modes:   10baseT/Half 10baseT/Full
                                    100baseT/Half 100baseT/Full
                                    1000baseT/Full
            Supports auto-negotiation: Yes
            Advertised link modes:  10baseT/Half 10baseT/Full
                                    100baseT/Half 100baseT/Full
                                    1000baseT/Full
            Advertised auto-negotiation: Yes
            Speed: 1000Mb/s
            Duplex: Full
            Port: Twisted Pair
            PHYAD: 0
            Transceiver: internal
            Auto-negotiation: on
            Supports Wake-on: pumbg
            Wake-on: g
            Current message level: 0x00000033 (51)
            Link detected: yes
    I'm confused

  7. #7

    Default Re: Problem with Realtek RTL-8110SC/8169SC

    Hi,

    for the sake of completeness...

    After 2 Mainboard changes it seems that the Realtek ethernet card on the Asus board is buggy (same problem on all 3 boards!)

    The board has another ethernet card (Marvell) and everything works fine with it

    So I will use the Marvell card

  8. #8

    Default Re: Problem with Realtek RTL-8110SC/8169SC

    I have a giga-byte ga-945gcm motherboard with a realtek 8111C ethernet chip, Suse installs the r8169 module but Realtek specify the r8168 module.After much reading and many failed attempts to install the r8168 module using tar balls, I found this link to a rpm source,
    Index of /repositories/home:/bitshuffler/openSUSE_10.3_update/x86_64
    Select the default kernel and left clicked on this file and saved to my download directory.
    Then left clicked and installed with YAST.
    As root, in a terminal
    insmod lib/modules/2.6.22.18-0.2-default/updates/r8168.ko
    to install the r8168 driver
    and to stop running r8169 driver, edit /etc/modprobe.d/blacklist
    by adding blacklist r8169
    To check what modules are loaded
    lspci | grep thernet to check what driver is detected
    lsmod | grep r* to check what module is loaded
    Hope this helps

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •