Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: No sound nVidia Corporation MCP51 High Definition Audio

  1. #1
    Join Date
    Jun 2008
    Location
    Omaha, NE
    Posts
    546

    Default No sound nVidia Corporation MCP51 High Definition Audio

    lspci -v shows me:

    nVidia Corporation MCP51 High Definition Audio (rev a2)

    dmesg shows me:

    ALSA /usr/src/realtek-linux-audiopack-5.05/alsa-driver-rt20080704-5.05/pci/hda/../../alsa-kernel/pci/hda/hda_intel.c:2142: hda-intel: no codecs found!

    I'm running the latest alsa packages, and I even downloaded the alsa driver and tried compiling it myself. I also tried the package from realtek's website.

    I fought with this all day yesterday. This is a friend's computer. I twisted his arm to leave Windows behind and try Linux, and now I feel like a schmuck that the sound isn't working.

  2. #2
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    25,932
    Blog Entries
    30

    Default Re: No sound nVidia Corporation MCP51 High Definition Audio

    Quote Originally Posted by enderandrew View Post
    dmesg shows me:

    ALSA /usr/src/realtek-linux-audiopack-5.05/alsa-driver-rt20080704-5.05/pci/hda/../../alsa-kernel/pci/hda/hda_intel.c:2142: hda-intel: no codecs found!
    This suggests to me you should focus your efforts on
    - his PC's BIOS or
    - on a newer alsa version or
    - on power management (ACPI) / special boot code for his motherboard.

    In the case of the BIOS, look for:
    a. sound being turned ON in this motherboard's BIOS, or
    b. something else being switched OFF (or ON) in the BIOS causing problem (maybe switch OFF plug an play if ON (or visa versa)),
    c. a newer BIOS version.

    I assume, sound worked under MS-Windows. Note though, that Linux is more sensitive to BIOS settings than Windows (Windows will on occasion ignore the BIOS settings).

    Quote Originally Posted by enderandrew View Post
    I'm running the latest alsa packages, and I even downloaded the alsa driver and tried compiling it myself. I also tried the package from realtek's website.
    Ok, ... so you tried the "alsa" route! ... I personally avoid the realtek drivers like a plague. From what I have read they are undocumented edits to the alsa drivers ... and one is typically better off with the alsa drivers.

    Try booting with safe settings (fail safe) and check sound with that. Does it work? In terms of a sound test, I recommend this test from the audio troubleshooting guide: SDB:AudioTroubleshooting - openSUSE
    Code:
    speaker-test -Dplug:front -c2 -l5 -twav
    However that dmesg warning needs to be addressed, and no optimized sound test will help until it is addressed.

    Can you provide specific information on his motherboard? For example, some laptops (the Toshiba P100/105 series for example) required special boot codes to get sound codec recognized: How To Have Sound On A Toshiba P105/100 Series (oss 10.3) - openSUSE Forums
    In the case of the Toshiba's, one had to put in the boot code:
    Code:
    acpi_osi=!Linux
    Also, try downloading an burning a "sidux" live cd, and/or a Kanotix "live cd", and then booting with those. Does sound work? They have possibly the best hardware detection in Linux, and if sound works under any Linux, IMHO its most likely to work with those Live CDs.

    If worst comes to worst, and a BIOS update, and safe setting boot fails, can you please write a bug report? I know, that's an unsatisfactory solution from your and your friend's viewpoint, but at least the community will benefit from your hard work, as by writing a bug report, this will be brought to the attention of the developers.

    opensuse bug reposts: Submitting Bug Reports - openSUSE
    alsa bug reports: https://bugtrack.alsa-project.org/alsa-bug/

  3. #3
    Join Date
    Jun 2008
    Location
    Omaha, NE
    Posts
    546

    Default Re: No sound nVidia Corporation MCP51 High Definition Audio

    Thanks. I already tried the latest .17 alsa driver, and even the daily snapshot, and the realtek version.

    I did check BIOS, and changed onboard sound from auto to on. I didn't see any other relevant sound or PCI options.

    I wonder if I can just use acpi=off, because this isn't a laptop, and power management isn't crucial.

    I didn't verify sound worked in Windows before I whipped out fdisk, but I'm assuming it did. I'm also downloading sidux right now.

  4. #4
    Join Date
    Nov 2008
    Location
    France
    Posts
    17

    Default Re: No sound nVidia Corporation MCP51 High Definition Audio

    I have the same problem, sound doesn't work, although it works under Linux Fedora Core 6 with ALSA driver.

  5. #5
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    25,932
    Blog Entries
    30

    Default Re: No sound nVidia Corporation MCP51 High Definition Audio

    Quote Originally Posted by chocho63 View Post
    I have the same problem, sound doesn't work, although it works under Linux Fedora Core 6 with ALSA driver.
    Welcome to our forum and welcome to openSUSE Linux.

    Do you have same motherboard: nVidia Corporation MCP51 High Definition Audio (rev a2) ? Do you have same dmesg output?

    Does sound work when you boot with acpi=off ?

    Does sound work when you boot with acpi_osi=!Linux ?

    There are many suggestions in this thread and it is not clear to me which, if any, you tried.

  6. #6
    Join Date
    Nov 2008
    Location
    France
    Posts
    17

    Default Re: No sound nVidia Corporation MCP51 High Definition Audio

    My motherboard : Gigabyte GA-M55plus-S3G (rev. 1.0)
    Opensuse 11.0 for x86_64 (AMD Athlon)

    I can't remember the dmesg output.

    My sound works today :

    - desactivated my Sound Board in the BIOS
    - removed the MCP51 Sound Board from YAST
    - downloaded drivers from NVIDIA : Linux nForce Drivers
    - installed this drivers
    - reboot my computer
    - configured the MCP51 Sound Board in YAST
    - the sound is OK, but is not very well amplified. I've had to increase the volume of my speakers.

    BIOS version F6 upgraded to F15A for my motherboard

  7. #7
    Join Date
    Nov 2008
    Location
    France
    Posts
    17

    Default Re: No sound nVidia Corporation MCP51 High Definition Audio

    My motherboard : Gigabyte GA-M55plus-S3G (rev. 1.0)
    Southbridge: NVIDIA nForce 430
    OnBoard Realtek ALC883 Audio Codec

    Opensuse 11.0 for x86_64 (AMD Athlon)

    I can't remember the dmesg output.

    My sound works today :

    - desactivated my Sound Board in the BIOS
    - removed the MCP51 Sound Board from YAST
    - downloaded drivers from NVIDIA : Linux nForce Drivers
    - installed this drivers
    - reboot my computer
    - reactivated my Sound Board in the BIOS
    - configured the MCP51 Sound Board in YAST
    - the sound is OK, but is not very well amplified. I've had to increase the volume of my speakers.

    BIOS version F6 upgraded to F15A for my motherboard

  8. #8
    Join Date
    Nov 2008
    Location
    France
    Posts
    17

    Default Re: No sound nVidia Corporation MCP51 High Definition Audio

    My motherboard : Gigabyte GA-M55plus-S3G (rev. 1.0)
    Southbridge: NVIDIA nForce 430
    OnBoard Realtek ALC883 Audio Codec

    lcpci : 00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)

    Opensuse 11.0 for x86_64 (AMD Athlon)

    I can't remember the dmesg output.

    My sound works today :

    - desactivated my Sound Board in the BIOS
    - removed the MCP51 Sound Board from YAST
    - downloaded drivers from NVIDIA : Linux nForce Drivers
    - installed this drivers
    - reboot my computer
    - reactivated my Sound Board in the BIOS
    - configured the MCP51 Sound Board in YAST
    - the sound is OK, but is not very well amplified. I've had to increase the volume of my speakers.

    BIOS version F6 upgraded to F15A for my motherboard

  9. #9

    Default Re: No sound nVidia Corporation MCP51 High Definition Audio

    Hey fella,

    sometimes there are very minor problems that conclude to this.
    have you tried:
    alsa-init
    alsaconfig
    or even /etc/alsasound restart
    and then alsamixer to raise the volume.

    give this a try with root permissions.

    Regards.

  10. #10
    Join Date
    Nov 2008
    Location
    France
    Posts
    17

    Default Re: No sound nVidia Corporation MCP51 High Definition Audio

    With these commands, the issue was resolved for the active session.

    I found on error message in /var/log/messages "pulseaudio[3719]: core-util.c: setpriority(): Permission non accorde" that I resolved with #281 (Applications are sluggish because of disabled network access to local sound devices) - PulseAudio - Trac.
    No it seems to work after I've rebooted my computer.

    The sound is OK with alsamixer.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •