Page 1 of 5 123 ... LastLast
Results 1 to 10 of 42

Thread: nspluginwrapper for firefox 3, 64bit -- no flash

  1. #1
    Join Date
    Jun 2008
    Location
    Madrid
    Posts
    81

    Default nspluginwrapper for firefox 3, 64bit -- no flash

    I've read through the other threads of folks running openSuSE-11.0 with 64bit firefox3, and resolving flash issues with nspluginwrapper.

    I re-installed the flash-plugin from macromedia and the two nspluginwrapper rpms from nspluginwrapper [Web > Gwenole Beauchesne]

    flash-plugin-9.0.124.0-release
    nspluginwrapper-1.0.0-1

    and whereas previously a box would appear empty where flash content was to be found, I now receive messages like, Hello, you either have JavaScript turned off or an old version of Adobe's Flash Player. Get the latest Flash player.

    I tried the suggestion here to use the NoScript plugin to allow scripts from sites I choose, but the flash player is still undetected. Any ideas?
    SuSE-12.3, Lenovo G780, 3.7.10-1.16-desktop

  2. #2

    Default Re: nspluginwrapper for firefox 3, 64bit -- no flash

    I am assuming you have downloaded the flash player rpm from the Adobe website. If so please try this:
    1.open a terminal and login as root (this is for system-wide installation, if you want to install for your account only then this is not necessary).
    2.Enter the following command
    nspluginwrapper -i /usr/lib/flash-plugin/libflashplayer.so

    However flash player is supposed to work on firefox3 for a default 64 bit installation from the openSUSE 11.0 dvd (as far as I know both nspluginwrapper and flash player are installed by default and there is nothing more to do). Therefore you could also try uninstalling the nspluginwrapper and flash player packages using yast and reinstalling them from the dvd. In that case the above command from the terminal will not be necessary.
    Hope that helps.

  3. #3
    Join Date
    Jun 2008
    Location
    Madrid
    Posts
    81

    Default Re: nspluginwrapper for firefox 3, 64bit -- no flash

    Yes, I downloaded the flash player rpm from the Adobe website.
    As root, I entered,
    Code:
    nspluginwrapper -i /usr/lib/flash-plugin/libflashplayer.so
    and received,

    Code:
    nspluginwrapper -i /usr/lib/flash-plugin/libflashplayer.so
    /usr/lib/nspluginwrapper/i386/linux/npviewer.bin: error while loading shared libraries: libgobject-2.0.so.0: wrong ELF class: ELFCLASS64
    nspluginwrapper: no appropriate viewer found for /usr/lib/flash-plugin/libflashplayer.so
    Is this error telling at all?

    I also believe both nspluginwrapper and flash player were installed by default on the openSuSE-11.0 dvd. I tried uninstalling them with Yast and then reinstalling them, but this did nothing.

    Any other ideas?
    SuSE-12.3, Lenovo G780, 3.7.10-1.16-desktop

  4. #4
    Join Date
    Jan 2008
    Location
    Kenton, TN USA
    Posts
    1,048

    Default Re: nspluginwrapper for firefox 3, 64bit -- no flash

    Thread moved to Multimedia
    opensuse.org.help.applications.multimedia
    Last edited by kastorff; 20-Jul-2008 at 18:19.
    Keith Kastorff

  5. #5
    Join Date
    Jun 2008
    Location
    Madrid
    Posts
    81

    Default Re: nspluginwrapper for firefox 3, 64bit -- no flash

    Some other suggestions I tried to implement:

    from here
    Code:
    rpm -qa | grep flash
    flash-player-9.0.124.0-10.1
    flash-plugin-9.0.124.0-release
    libflashsupport-000-67.1
    I removed flash-plugin and libflashsupport

    From this thread in general
    I installed Mplayer and mplayerplug-in
    removed pulseaudio
    installed w32codec-all

    When visiting a site with flash I still receive the message, "Hello, you either have JavaScript turned off or an old version of Adobe's Flash Player. Get the latest Flash player." Is it indeed enabled in my browser though.

    Before I tried to "fix" any of the missing video, there would at least be a gray rectangular area, no sound or image.
    SuSE-12.3, Lenovo G780, 3.7.10-1.16-desktop

  6. #6

    Default Re: nspluginwrapper for firefox 3, 64bit -- no flash

    I'm running opensuse x86_64 11.0 installed from just the cd though. I used zypper to install nspluginwrapper and then ran
    nspluginwrapper -i /usr/lib/flash-plugin/libflashplayer.so
    and now flash is working!!

    I could have lived without it but it is annoying to get those blank screen at some sites. I like zypper better than yast I must admit but not really sure why it worked for me. I'm grateful for the info in this thread though and Yay opensuse!

  7. #7
    Join Date
    Jun 2008
    Location
    Madrid
    Posts
    81

    Default Re: nspluginwrapper for firefox 3, 64bit -- no flash

    I'm glad other folks are getting it working.
    I tried removing flash-player again, re-installing, and running
    Code:
    su
    nspluginwrapper -i /usr/lib/flash-plugin/libflashplayer.so
    This time I get a different error message:
    Code:
    nspluginwrapper: /usr/lib/browser-plugins/libflashplayer.so is not a valid NPAPI plugin
    Perhaps I'm approaching the truth of flash.
    But I'm not quite sure what else to try, or where to go from here. Any ideas or directions to look into?
    SuSE-12.3, Lenovo G780, 3.7.10-1.16-desktop

  8. #8

    Default Re: nspluginwrapper for firefox 3, 64bit -- no flash

    I get this same error, does anyone no a fix?

  9. #9
    Join Date
    Jun 2008
    Location
    Madrid
    Posts
    81

    Default Re: nspluginwrapper for firefox 3, 64bit -- no flash

    doroshjt, have you found a solution?

    I've tried uninstalling firefox, flash-player and nspluginwrapper, reinstalling and trying:

    Code:
    nspluginwrapper -i /usr/lib/firefox/plugins/libflash
    player.so
    nspluginwrapper: /usr/lib/firefox/plugins/libflashplayer.so is not a valid NPAPI
     plugin
    and
    Code:
    nspluginwrapper -i /usr/lib/browser-plugins/libflash
    player.so
    nspluginwrapper: no appropriate viewer found for /usr/lib/browser-plugins/libfla
    shplayer.so
    as I've seen these two varieties floating around. Any idea what these errors indicate? how to overcome them?

    Code:
    about:plugins
    gives me
    Code:
    DivX Browser Plug-In
        File name: mplayerplug-in-dvx.so
        mplayerplug-in 3.55
    
    Google VLC multimedia plugin 1.0
        File name: mplayerplug-in-gmp.so
        mplayerplug-in 3.55
    
    QuickTime Plug-in 7.4.5
        File name: mplayerplug-in-qt.so
        mplayerplug-in 3.55
    
    RealPlayer 9
        File name: mplayerplug-in-rm.so
        mplayerplug-in 3.55
    
    Windows Media Player Plug-in
        File name: mplayerplug-in-wmp.so
        mplayerplug-in 3.55
    
    mplayerplug-in 3.55
        File name: mplayerplug-in.so
        mplayerplug-in 3.55
    
    NPAPI Plugins Wrapper 0.9.91.6-Pre (20071225)
    
    iTunes Application Detector
        File name: librhythmbox-itms-detection-plugin.so
    
    OpenSC Signer plugin
        File name: opensc-signer.so
    mplayer is the only one enabled to view flv.

    and
    Code:
    rpm -q flash-player
    flash-player-9.0.124.0-10.1
    I still have the same problem, and receive the message, "Hello, you either have JavaScript turned off or an old version of Adobe's Flash Player. Get the latest Flash player."

    anyone have any suggestions or have this same problem?
    SuSE-12.3, Lenovo G780, 3.7.10-1.16-desktop

  10. #10
    linux-juzer NNTP User

    Default Re: nspluginwrapper for firefox 3, 64bit -- no flash

    I only use nspluginwrapper and flash-plugin from official openSUSE repositories and I never had to type any command in console. Flash works here in Firefox just like that, without any CLI magic. Try to remove Flash from Adobe and nspluginwrapper from nspluginwrapper site and install packages from official openSUSE repositories.

Page 1 of 5 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •