Results 1 to 7 of 7

Thread: Yast & Updater problems

  1. #1

    Default Yast & Updater problems

    I am not sure when this started to happen but I am suddenly unable to open Yast. I think in the last week an update went bad somehow on my PC.

    When I try to run Yast, I get the KDE su prompt but after entering root's password Yast does not show up. I do however see it in the process list.

    When I run yast from a command line, I get an error reading:

    Qt GUI wanted but not found, falling back to ncurses.

    Yast opens up in character mode but I cannot open any of the modules and the following appears on the command line (visible after I have quit yast):

    Qt GUI wanted but not found, falling back to ncurses.
    Error while creating client module bootloader
    Error while creating client module disk
    Error while creating client module x11
    Error while creating client module sw_single



    Updater shows up in the system tray with the yellow triangle warning sign. When I click on it, the following error is displayed:

    Can't launch zypp-checkpatches-wrapper helper program. Make sure zypper package is installed and working.

    I am not sure where to start troubleshooting these problems. Please help! All I really wanted to do was to resize my disk partitions so that I could set up test partitions for openSUSE 11.0.

  2. #2
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,306

    Default Re: Yast & Updater problems

    Running zypper from a console can you successfully run a refresh with ' zypper ref ' (as root)?

    If that still works you might try to apply (and also check) which updates are pending with ' zypper up ' & ' zypper dup '.


    Did you resize (shrink) your root partition? Or have you not touched that yet?

    Cheers,
    Wj
    Have a lot of fun!

  3. #3

    Default Re: Yast & Updater problems

    Hello,

    I have the same problem. I think there's something wrong with the last update. It instals newer libzyyp and remove zypper completly and some yast parts. After that update my system looked like a garbage. My kde pannel was almmost empty (just white line and few icons) I couldn't work normaly. I spent whole day to somehow get back my system as it was befor the update. Even after reinstaling some packages to old versions I got "Error while creating client module sw_single" when I used yast. I finaly managed with this (used zypper, yum and rpm manualy) and system looks simillar like it was before the update. Unfortunately not all works as it was. I have no autoupdater because it just won't start anymore it says that somekind of module is not working etc. The most anoying thing is that when I klick on the KDE pannel and write in search box, a program for example yast it'll find it but after that whole panel is crashing or it freezes whole system. Is there any 1click "pill" for this to be fixed?

    I forgot to mention that when your system is after update already and you want to do zypper up ' & ' zypper dup it won't work because there is no zypper in the system. It has deleted it self. But when you fix the system like me and then try to do the zypper up and dup the story will repeat it self. It'll delete packages including zypper it self.

  4. #4

    Default Re: Yast & Updater problems

    Quote Originally Posted by Magic31 View Post
    Running zypper from a console can you successfully run a refresh with ' zypper ref ' (as root)?

    If that still works you might try to apply (and also check) which updates are pending with ' zypper up ' & ' zypper dup '.


    Did you resize (shrink) your root partition? Or have you not touched that yet?

    Cheers,
    Wj
    This is what I get from zypper up (followed by solution suggestions to not install):

    Downloading repository 'KDE:KDE4:STABLE:Community' metadata [done]
    Building repository 'KDE:KDE4:STABLE:Community' cache [done]
    Downloading repository 'KDE:KDE4:STABLEesktop' metadata [done]
    Building repository 'KDE:KDE4:STABLEesktop' cache [done]
    Downloading repository 'Packman Repository' metadata [done]
    Building repository 'Packman Repository' cache [done]
    Downloading repository 'openSUSE:10.3:Update' metadata [done]
    Building repository 'openSUSE:10.3:Update' cache [done]
    Reading installed packages...
    172 Problems:
    Problem: nothing provides atom:SDL_image-32bit = 1.2.6-25.3 needed by patch:SDL_image-4956-0.noarch
    Problem: nothing provides atom:libasound2-32bit = 1.0.14-31.2 needed by patch:alsa-4737-0.noarch
    Problem: nothing provides atom:capi4linux-32bit = 2007.10.9-1.1 needed by patch:ant-phone-4534-0.noarch
    Problem: nothing provides atom:audit-libs-32bit = 1.5.5-13.2 needed by patch:audit-4685-0.noarch
    Problem: nothing provides atom:audit-libs-32bit = 1.5.5-13.4 needed by patch:audit-5212-0.noarch
    Problem: nothing provides atom:bind-devel-64bit = 9.4.1.P1-12.2 needed by patch:bind-4931-0.noarch
    Problem: nothing provides atom:bind-devel-64bit = 9.4.1.P1-12.4 needed by patch:bind-5269-0.noarch
    Problem: nothing provides atom:bind-devel-64bit = 9.4.1.P1-12.5 needed by patch:bind-5410-0.noarch
    Problem: nothing provides atom:boost-64bit = 1.33.1-108.5 needed by patch:boost-4946-0.noarch
    (...)
    Problem: cannot install both patch:wireshark-5145-0.noarch and patch:wireshark-4843-0.noarch
    Problem: cannot install both patch:xorg-x11-server-4595-0.noarch and patch:xorg-x11-server-4557-0.noarch
    Problem: cannot install both patch:xpdf-5245-0.noarch and patch:xpdf-4643-0.noarch
    Problem: cannot install both patch:yast2-add-on-creator-4612-0.noarch and patch:yast2-add-on-creator-4463-0.noarch
    Problem: cannot install both patch:yast2-product-creator-4610-0.noarch and patch:yast2-product-creator-4524-0.noarch
    Problem: patch:xorg-x11-Xvnc-5317-0.noarch requires atom:xorg-x11-server = 7.2-143.13, but this requirement cannot be provided
    Problem: patch:yast2-trans-de-4889-0.noarch requires atom:yast2-trans-de = 2.15.30-0.1, but this requirement cannot be provided
    Problem: atom:xen-tools-domU-3.1.0_15042-51.3.i586 requires xen-tools-domU >= 3.1.0_15042-51.3, but this requirement cannot be provided


    and from zypper dup:

    Reading installed packages...
    3 Problems:
    Problem: nothing provides yast2 >= 2.17.6 needed by yast2-firewall-2.17.0-1.1.noarch
    Problem: nothing provides limal-ca-mgm-perl >= 1.4.0 needed by yast2-ca-management-2.17.1-1.2.noarch
    Problem: yast2-online-update-2.16.15-1.13.noarch requires yast2-pkg-bindings >= 2.16.23, but this requirement cannot be provided

    Problem: nothing provides yast2 >= 2.17.6 needed by yast2-firewall-2.17.0-1.1.noarch
    Solution 1: do not install yast2-firewall-2.17.0-1.1.noarch

    Choose the above solution using '1' or skip, retry or cancel [1/s/r/C]:


    The repository refresh seems to work fine:

    Repository '10.3-non-oss' is up to date.
    Repository '10.3-oss' is up to date.
    Repository 'Banshee' is up to date.
    Repository 'KDE:Community' is up to date.
    Repository 'KDE:KDE4:STABLE:Community' is up to date.
    Repository 'KDE:KDE4:STABLEesktop' is up to date.
    Repository 'KDE:KDE4:STABLE:Extra-Apps' is up to date.
    Repository 'Packman Repository' is up to date.
    Repository 'VideoLan Repository' is up to date.
    Repository 'YaST:SVN' is up to date.
    Repository 'nVidia Drivers' is up to date.
    Repository 'openSUSE:10.3' is up to date.
    Repository 'openSUSE:10.3:Update' is up to date.
    Repository 'zypp:svn' is up to date.
    All repositories have been refreshed.



    Any ideas?

  5. #5

    Default Re: Yast & Updater problems

    Quote Originally Posted by Magic31 View Post

    Did you resize (shrink) your root partition? Or have you not touched that yet?
    I forgot to add that I have not yet touched my partitions.

    -DA

  6. #6

    Default Re: Yast & Updater problems

    Which version of libzyyp and zypper is instaled in your system?
    Or can you show what will you get after this command?

    rpm -qa | egrep "yast2|zypp"

    I suggest to instal yum and try to update with it (at least yast and zypp packages) if you want to get yast to work again at least for now.

  7. #7

    Default Re: Yast & Updater problems

    Quote Originally Posted by xyzyx View Post
    Which version of libzyyp and zypper is instaled in your system?
    Or can you show what will you get after this command?

    rpm -qa | egrep "yast2|zypp"

    I suggest to instal yum and try to update with it (at least yast and zypp packages) if you want to get yast to work again at least for now.
    Here's the grep putput:

    yast2-slp-2.15.0-31
    yast2-2.15.58-12
    yast2-pam-2.14.0-128
    yast2-apparmor-2.1-26
    yast2-kerberos-client-2.15.7-32
    autoyast2-installation-2.15.17-17
    yast2-sudo-2.15.3-86
    yast2-online-update-2.15.24-0.1
    yast2-mail-2.15.23-2.1
    yast2-backup-2.15.6-0.1
    yast2-perl-bindings-2.16.7-7.1
    yast2-ldap-2.15.1-83
    yast2-sysconfig-2.15.3-58
    yast2-packager-2.15.81-4
    yast2-iscsi-client-2.15.2-39
    yast2-ldap-client-2.15.12-37
    yast2-users-2.15.38-7
    yast2-nfs-server-2.15.5-2.1
    zypper-0.12.0-4.2
    libzypp-devel-5.0.0-5.2
    yast2-schema-2.15.0-123
    yast2-trans-en_US-2.15.5-6
    yast2-transfer-2.14.0-107
    yast2-bluetooth-2.15.4-17
    yast2-country-2.15.20-7
    yast2-irda-2.15.1-94
    yast2-nfs-client-2.15.0-25
    yast2-firewall-2.15.8-8
    yast2-tv-2.15.7-23
    yast2-nis-client-2.15.3-21
    yast2-network-2.15.81-2
    yast2-registration-2.15.3-15
    yast2-storage-2.15.27-4
    yast2-inetd-2.15.1-41
    yast2-installation-2.15.54-4
    autoyast2-2.15.17-17
    yast2-ncurses-2.17.1-2.1
    libzypp-5.0.0-5.2
    yast2-ldap-server-2.15.5-76
    yast2-profile-manager-2.15.1-0.1
    yast2-trans-stats-2.15.0-32
    yast2-theme-openSUSE-2.15.14-4
    yast2-storage-lib-2.15.27-4
    yast2-hardware-detection-2.15.8-36
    yast2-sound-2.15.11-18
    yast2-printer-2.15.6-4
    yast2-control-center-2.15.4-12
    yast2-mouse-2.15.1-81
    yast2-fingerprint-reader-2.15.2-27
    yast2-control-center-qt-2.15.4-12
    yast2-restore-2.15.4-22
    yast2-add-on-2.15.17-4
    yast2-core-2.17.1-1.1
    yast2-support-2.15.3-14
    yast2-runlevel-2.15.3-19
    yast2-ntp-client-2.15.12-7
    yast2-update-2.15.23-21
    yast2-bootloader-2.15.29-2
    yast2-tune-2.15.7-20
    yast2-ca-management-2.15.3-0.1
    yast2-libyui-2.17.2-1.1
    yast2-pkg-bindings-2.17.0-1.4
    yast2-xml-2.15.0-55
    yast2-scanner-2.15.5-42
    yast2-x11-2.15.11-22
    yast2-security-2.15.1-23
    yast2-samba-client-2.15.11-33
    yast2-samba-server-2.15.7-57
    yast2-metapackage-handler-0.7.1-9
    yast2-online-update-frontend-2.15.24-0.1
    yast2-repair-2.15.8-0.1
    yast2-control-center-gnome-2.13.2-91
    yast2-ycp-ui-bindings-2.17.1-1.1


    I would prefer sorting this out rather than n installing yum if possible.

    -DA

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •