Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: permission denied on .gvfs

  1. #1
    lodlock NNTP User

    Default permission denied on .gvfs

    When attempting to use the update system I receive a unable to stat and permission denied on /home/whatever/.gvfs

    When looking at it with an ls -l it looks like

    ????????????? ? ? ? ? ? .gvfs

    I can not chown, touch, edit, remove, or do anything as the user of the home dir or as root. Both receive a permission denied.

    Any suggestions?

    *Edit*
    Also, I am running OpenSuSE 11.0. I found similar issues in the beta / rc sections of the forum but I am running the actual release for 11.
    */Edit*

    -Lodlock

  2. #2

    Default Re: permission denied on .gvfs

    lodlock <lodlock@no-mx.forums.opensuse.org> wrote:
    >
    > When attempting to use the update system I receive a unable to stat and
    > permission denied on /home/whatever/.gvfs
    >
    > When looking at it with an ls -l it looks like
    >
    > ????????????? ? ? ? ? ? .gvfs
    >
    > I can not chown, touch, edit, remove, or do anything as the user of the
    > home dir or as root. Both receive a permission denied.


    This is also causing problems with rsync backups of /home.

    --
    Stephen Chadfield

  3. #3
    LordOllie NNTP User

    Default Re: permission denied on .gvfs

    ollie@linux-e1c6:~> stat .gvfs
    File: `.gvfs'
    Size: 0 Blocks: 0 IO Block: 4096 directory
    Device: 13h/19d Inode: 1 Links: 2
    Access: (0500/dr-x------) Uid: ( 1000/ ollie) Gid: ( 100/ users)
    Access: 2008-07-04 09:13:20.000000000 -0400
    Modify: 2008-07-04 09:13:20.000000000 -0400
    Change: 2008-07-04 09:13:20.000000000 -0400

    I am also having to same issue, but it seems to carry over if I wish to use the gnome right click option of "Install Software" I receive an error of cannot stat .gvfs

  4. #4

    Default Re: permission denied on .gvfs

    Bumping this thread due to the following:

    * I installed OS11 Gnome fresh on my system
    * I did some configuring and want to put back my backed up files
    * I can access my network drive
    * I can not copy files over it says "permission denied"
    * User is owner of directory and has sufficient rights
    * Even using su doesn't resolve this
    * On console it states "can not access .gvfs. Permission denied".
    * I'm not able to delete the .gvfs directory (says it is in use)
    * I am able to create new directories in the home folder of the user

    I've been looking on the Internet and haven't found solutions and the given tips in IRC didn't work out. Does anybody here have ideas on how to fix this issue, besides doing a total re-install?
    Main: openSUSE 12.3 x64 | KDE | AMD 64 X2 4200+ | 4GB | ATI Radeon HD 2600 XT | Xonar Essence STX
    Laptop: openSUSE Tumbleweed x64 | GNOME | Mobile AMD 3400+ | 1GB | ATI RV350 | Broadcom wireless

  5. #5

    Default Re: permission denied on .gvfs

    Same problem here. Shiny new installations OpenSuse on a T61 (64Bit) and a Mac Mini (32 Bit). Both throw that error when installing IBM RPMs

  6. #6

    Default Re: permission denied on .gvfs

    FUSE directories are only accessible by the UID that mounted them (unless other options were using during mount). I find this gvfs stuff highly annoying anyway, why is it suddenly needed in 11.0?

  7. #7
    MaraST78 NNTP User

    Default Re: permission denied on .gvfs

    There is also one critical bug regarding fuse/gvfs. Makes me pretty nervous, though I don't experience any data corruption (yet?).

    https://bugzilla.novell.com/show_bug.cgi?id=404758

  8. #8

    Default Re: permission denied on .gvfs

    Did anyone ever figure this out? I am having the same issue also. This /home/$USER/.gvfs file is impossible to take ownership of or change permissions on. I actually wanted to take ownership of my home folder to test a program that won't run, and this untouchable .gvfs folder is in the way. Funny...

  9. #9
    Camalen NNTP User

    Default Re: permission denied on .gvfs

    buckeyered80 wrote:

    > Did anyone ever figure this out? I am having the same issue also. This
    > /home/$USER/.gvfs file is impossible to take ownership of or change
    > permissions on. I actually wanted to take ownership of my home folder
    > to test a program that won't run, and this untouchable .gvfs folder is
    > in the way. Funny...


    I think this is a "well-know" bug, reported several times. So, maybe still
    not fixed:

    ***
    Bug 467862 - By opening firefox a file ".gvfs" are created in the home
    direcotry with no access rights
    https://bugzilla.novell.com/show_bug.cgi?id=467862

    Bug 368628 - gvfs: Random crashes
    https://bugzilla.novell.com/show_bug.cgi?id=368628
    ***

    Greetings,

    --
    Camalen

  10. #10

    Default Re: permission denied on .gvfs

    A solution to remove .gvfs , odd directory:

    #umount /home/useraccount/.gvfs
    #find . -inum 554009 -exec rm{} \;

    After that,

    #rm -rf .gvfs

    Cheers!

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •