Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Desktop Effects crashed KDE 4

  1. #1
    Join Date
    Jun 2008
    Location
    Dublin, Ireland
    Posts
    298

    Red face Desktop Effects crashed KDE 4

    Hi,

    HELP !! I enabled desktop effects in OpenSuse 11 and the screen had gone black... How do I turn desktop effects off from the command line? How do I get to a command line? I tried rescue system and it booted to a prompt. Then I tried sax2 and gnome-xgl-switch commands but it didn't recognise either of them.

    I also got rid of the task bar and have no idea how to get it back

    I have an ATI card and I imagine that's the reason it crashed in the first place. I can sort that out later if I could just get the desktop back..

    /jlar

  2. #2
    Join Date
    Jun 2008
    Location
    Dublin, Ireland
    Posts
    298

    Default Re: Desktop Effects crashed KDE 4

    I tried reinstalling and it didn't make any differance... I am really screwed now. I managed to disable xgl but it made no differance.. Any help would be great

    /j

  3. #3
    Join Date
    Jun 2008
    Location
    Amsterdam
    Posts
    56

    Default Re: Desktop Effects crashed KDE 4

    I'd like to follow up on this question, because it seems to me like a usefull thing to be able to do.

    First of all, what I do when the KDE4 Desktop Effects crash my Window Manager is restart the X-server (CTRL+ALT+BACKSPACE x2, in a short period of time). This bring you back to the login window. Then I change my session type to something else (failsafe for instance, everything but KDE4 will do). Then I login (and open up a terminal/konsole) and move my .kde4 directory in my home folder to .kde4-backup. Unfortunately this removes all my kde4 user settings so another solution would be appriciated.

    For instance doing an ALT+F1 and then running a command. Any ideas?

  4. #4

    Default Re: Desktop Effects crashed KDE 4

    I'm no expert but I've been using Linux for awhile and I have found there is almost always a solution.

    I would suggest that you reboot your system and at the green grub prompt, type init 3. This should boot to a command prompt without X running.

    From there login as user and try running sax2 -r and turn off desktop effects in the setup screen. Then reboot. (if there is no apparent way to turn off "effects" reboot anyway because regenerating the xorg.conf file might fix the problem)

    If that doesn't help, boot again into init 3 and use an editor to open your /etc/X11/xorg.conf file. (I use nano - if you don't have a text editor installed you can install one using the zypper command from the prompt.)

    Anyway, if the last line of xorg.conf indicates compositing is running try changing it ... can't remember if it's "no" or "false" but you could just "rem" out that line in xorg.conf. You may also have to "rem" the line that loads aiglx.

    That should get your gui running.

  5. #5

    Default Re: Desktop Effects crashed KDE 4

    You can also press Ctrl-Alt-1 to get into one of the virtual consoles, login as root and type init 3 in command line. Then change directory to your home directory and type "rm -R .kde4" This removes all KDE 4 settings and sets it to factory default. I hope this helps.

  6. #6
    Join Date
    Jun 2008
    Location
    Amsterdam
    Posts
    56

    Post Re: [Solved] Desktop Effects crashed KDE 4

    Here's a little less rigorous approach to get your Desktop Back once enabling "Desktop Effects" had crashed your window manager and wouldn't get back to normal. Credits (also) to: kjjjjshab from kubuntuforums

    Ok, first your situation, you enabled Desktop Effects in KDE4 and now you're stuck with a black / grey / white screen with just / not even your mouse visible. Restarting the X server via CTRL+ALT+BACKSPACE doesn't work. Also you don't want to delete your whole .kde4 folder because you just got everything just right, here's what you do:
    Please note I'm using the command line text editor "nano" in this example, but you might not have it installed, then try a different editor like "pico", "vi", "vim" (in order of preference, vi and vim work slighty differently).


    • Press CTRL+ALT+F1 (switches to command line - terminal)
    • Enter *your* login + password, NOT root.


    • Type (line after line):
      Code:
      cd ~/.kde4/share/config
      nano kwinrc


    • Now in the 4th and 5th line you see this:
      [Compositing]
      Enabled=true
      ... now navigate to the 5th line by means of the arrow keys and change "true" to "false"
    • Press CTRL+O to "WriteOut" or in other words save the file. It will ask for a name which is by default the original file name "kwinrc", so just press ENTER to overwrite the file with this new change.
    • Press CTRL+X, to exit the nano editor. Now you are back at the command line.
    • Press CTRL+ALT+F7 to switch back to graphical mode (yes the screen is still white / dark / grey, because we still need to restart KDE4)
    • Press CTRL+ALT+BACKSPACE (twice, fast) to restart the X Graphics Server and end up at the login window.
    • Login and see your KDE4 desktop as it was before you enabled Desktop Effects



    • Optional: file a bug report (because KDE4 should have disabled Desktop Effects automatically after the 10 seconds you didn't do anything because your Desktop wasn't working anymore.
    Last edited by jsnel; 24-Jul-2008 at 14:02. Reason: fixed a typo: kjjjjsjab -> kjjjjshab

  7. #7
    Join Date
    Jun 2008
    Location
    Amsterdam
    Posts
    56

    Post Disable KDE 4 Desktop Effects from the command line [script]

    Here's a slightly more convenient solution, which should work in the file in question remains properly formatted (but this may change in subsequent KDE releases). I've tested it with KDE 4.1.

    Note: if you are in "black / white / messed up screen mode" remember you need to press CTRL+ALT+F1 to get a terminal and login with your normal user account (not as root).


    • Type the following inside a terminal / konsole to disable Desktop Effects:


    Code:
    cp -i ~/.kde4/share/config/kwinrc ~/.kde4/share/config/kwinrc_backup 
    sed -i '/[Compositing]/{n; s/true/false/;}' ~/.kde4/share/config/kwinrc


    [Explanation]

    First this make a copy (kwinrc_backup) of the configuration file we are about to mess with (kwinrc) using [b]cp[/B. Verify this backup was made using "less ~/.kde4/share/config/kwinrc_backup".
    Next using the unix/linux tool sed we find the line that matches the string "[Compositing]", then replace the string "true" with the string "false" on the next line. If "true" is not found (Desktop Effects was already disabled, nothing happens). The "-i" options makes that we replace the string in the same file, rather than spit out the output to the command line, so this is a search and replace command.
    Note: if you don't have the "sed" program then run the following as root to install it:
    Code:
    zypper in sed
    If something goes wrong you can restore the backup by executing the following line from the terminal, but make sure you're not in super user (root) mode:
    Code:
    mv -i ~/.kde4/share/config/kwinrc_backup ~/.kde4/share/config/kwinrc
    What might be also useful if you experiment with Desktop Effects a lot is the following:


    • Create a new text file called "Disable_DesktopEffects" in the folder "bin" in your home directory, i.e. ~/bin/. And put the following lines of code in it:


    Code:
    #!/bin/sh
    echo ---------------------------------------------------------
    echo Making backup of configuration file: ~/.kde4/share/config/kwinrc
    echo if backup file already exists you will be promted to overwrite \(y/n\).
    echo ---------------------------------------------------------
    cp -i ~/.kde4/share/config/kwinrc ~/.kde4/share/config/kwinrc_backup
    sed -i '/[Compositing]/{n; s/true/false/;}' ~/.kde4/share/config/kwinrc
    echo Desktop Effects disabled, now restart the X-server using CTRL+ALT+ESCAPE
    echo alternatively you can also login as root, type
    echo \"init 3\" which tops the kde desktop manager and then type
    echo \"init 5\" to restart it and bring you back to the login screen.

    • Now make sure to make it executable by typing:


    Code:
    chmod +x ~/bin/Disable_DesktopEffects
    Have fun!

  8. #8
    Join Date
    Mar 2008
    Location
    Toronto, Canada
    Posts
    310

    Default Re: Desktop Effects crashed KDE 4

    To clarify from the OP, it's not clear whether you're talking about compiz-style "desktop effects", or KDE4 style desktop effects.

    Novell refers to compiz integration as "desktop effects", KDE refers to compositing in KDE4 as "desktop effects".

    From your post, it's not really clear which environment you're running with, or what the actual issue is.

    KDE4 should recover if compositing fails, otherwise jsnel's advice should help.

    If the issue is with compiz, then you can search this forum for support, or remove compiz if all else fails.

    Hope this helps...

    Cheers,
    KV

  9. #9
    Join Date
    Jun 2008
    Location
    Amsterdam
    Posts
    56

    Default Re: Desktop Effects crashed KDE 4

    I thought it would be clear from my post's title "Disable KDE 4 Desktop Effects from the command line [script]" but if it wasn't, yes I'm talking about the Desktop Effects built into KDE4. KDE doesn't recover from this on some (Ati graphics card's based) machines. I will try to file a bug report if I find the time.

  10. #10

    Default Re: Desktop Effects crashed KDE 4

    Thankyou so much for this simple and straight forward solution jsnel!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •