Results 1 to 8 of 8

Thread: Banshee-1 dependency probs with OpenSuSE 10.3

  1. #1
    Join Date
    Jun 2008
    Location
    Mount Airy, MD
    Posts
    25

    Default Banshee-1 dependency probs with OpenSuSE 10.3

    For my relatively vanilla OpenSuSE 10.3 load with Banshee 0.13.2, Mono 1.2.5 and Gnome Media 2.20.1 installed, YaST reports the following errors for the one-click installer at Banshee Download:

    Cannot install banshee-1, because it is conflicting with banshee
    pattern:gnome_multimedia has missing dependencies
    banshee-engine-gst has missing dependencies
    banshee-plugins-extra has missing dependencies
    banshee-plugins-default has missing dependencies
    banshee-plugins-DAAP has missing dependencies
    A post on the Banshee list suggests instructing YaST to uninstall Banshee 0.13.2 and ignore the other dependencies, but according to Banshee Banshee 1.0 Final this should not be necessary:
    No Conflicts

    This new release is not backwards compatible with previous Banshee releases, however, it will not conflict or cause any problems with any previous release you may have installed.

    These changes mean you can have installed and use both older Banshee releases (0.13.2 and older) and new Banshee releases (0.98.1 and newer) without worrying about packaging or installation problems or user data conflicts.
    I don't mind removing 0.13.2 but would like to avoid ending up with neither! Has anyone else encountered this? TIA for any suggestions to help get Banshee 1.0 up and running.

  2. #2
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    25,701
    Blog Entries
    29

    Default Re: Banshee-1 dependency probs with OpenSuSE 10.3

    I hate to see a post go unanswered, especially in "multimedia". ... But I don't use Banshee. So let me pass you some diagnostic commands that might help.

    Typically if I get a dependency error, I like the find the specific rpms that conflict.

    Here are some commands that can be useful for finding libraries/conficts. I am using an installed amarok as an example, but for banshee, lets say the rpm is banshee-0.13.2.nightly20071018-20.1.i586.rpm

    Then to find the dependencies use:
    rpm -qpR banshee-0.13.2.nightly20071018-20.1.i586.rpm

    Here is an example finding installed dependencies on my PC, using an installed rpm packaged amarok as an example.
    rpm -qR amarok #that will give a list of amarok dependencies of which libqt-mt.so.3 is of example interest
    rpm -qa --filesbypkg | grep libqt-mt.so.3 #this will give the location of this library as "/usr/lib/qt3/lib/"
    rpm -qf /usr/lib/qt3/lib/libqt-mt.so.3 #which tells one this lib comes with rpm qt3-3.3.8-76.2

    Note in the above, the rpm command to find dependencies is different between an installed rpm, and an rpm that is a downloaded file (but not yet installed).

    ... also, philosophically, sometimes dependency problems can arise because:
    * a repository server is down, or
    * one is missing an important repository in their package manager, or
    * one has too many repositories in their package manager, which can cause conflicting packages, or
    * the rpm packager made a mistake.

    In your case, you are referring to Banshee 0.13.2, ... is that correct?
    From what I can see, that is packaged by user "aaronbockover".
    Index of /repositories/home:/aaronbockover/openSUSE_10.3
    Packages in such user repositories (with nightly builds), tend to be more cutting edge, and one has to be careful when trying to install.

    If you don't want to fight with the dependency errors, you could try Banshee 0.13.1. I suspect you will have more success that way.

  3. #3
    Join Date
    Jun 2008
    Location
    Mount Airy, MD
    Posts
    25

    Default Re: Banshee-1 dependency probs with OpenSuSE 10.3

    Thanks so much for the reply! Version 0.13.2 is already installed (Aaron Bockover is "the creator and lead developer of Banshee," so his repo is presumably okay) and I would like to upgrade to version 1.0. Here is how the dependencies match up using the commands you provided:

    Code:
    > rpm -qR banshee				> rpm -qpR banshee-1-1.0.0-3.1.i586.rpm 
    filesystem  					filesystem  
    gconf2  					gconf2  
    mono-core  					mono-core  
    						mono-addins >= 0.3
    						taglib-sharp >= 2.0
    						ndesk-dbus >= 0.5
    						ndesk-dbus-glib >= 0.3
    						banshee-1-lang = 1.0.0
    						banshee-1-backend-engine-gstreamer = 1.0.0
    						banshee-1-backend-platform-unix = 1.0.0
    podsleuth >= 0.6.1
    libmusicbrainz  
    gstreamer010  
    gstreamer010-plugins-base  
    gstreamer010-plugins-good  			gstreamer010-plugins-good  
    gstreamer010-plugins-base-oil  
    banshee-engine = 0.13.2
    dbus-1-glib >= 0.60-26
    dbus-1-x11 >= 0.60-26
    /usr/bin/gconftool-2  
    coreutils  
    						/bin/bash  
    /bin/sh  					/bin/sh  
    /bin/sh  
    /bin/sh  
    /bin/sh  
    rpmlib(PayloadFilesHavePrefix) <= 4.0-1		rpmlib(PayloadFilesHavePrefix) <= 4.0-1
    rpmlib(CompressedFileNames) <= 3.0.4-1		rpmlib(CompressedFileNames) <= 3.0.4-1
    rpmlib(VersionedDependencies) <= 3.0.3-1	rpmlib(VersionedDependencies) <= 3.0.3-1
    /bin/bash  
    libORBit-2.so.0  
    libatk-1.0.so.0  
    libc.so.6  					libc.so.6  
    libc.so.6(GLIBC_2.0)  				libc.so.6(GLIBC_2.0)  
    libc.so.6(GLIBC_2.1.3)  			libc.so.6(GLIBC_2.1.3)  
    libcairo.so.2  					libcairo.so.2  
    libdbus-1.so.3  
    libdbus-glib-1.so.2  
    libdl.so.2  					libdl.so.2  
    libgconf-2.so.4  
    libgdk-x11-2.0.so.0  				libgdk-x11-2.0.so.0  
    libgdk_pixbuf-2.0.so.0  			libgdk_pixbuf-2.0.so.0  
    libglib-2.0.so.0  				libglib-2.0.so.0  
    libgmodule-2.0.so.0  				libgmodule-2.0.so.0  
    libgnomevfs-2.so.0  
    libgobject-2.0.so.0  				libgobject-2.0.so.0  
    libgstbase-0.10.so.0  				libgstbase-0.10.so.0  
    						libgstcdda-0.10.so.0  
    libgstcontroller-0.10.so.0  			libgstcontroller-0.10.so.0  
    libgstdataprotocol-0.10.so.0  			libgstdataprotocol-0.10.so.0  
    						libgstinterfaces-0.10.so.0  
    libgstpbutils-0.10.so.0  			libgstpbutils-0.10.so.0 
    libgstreamer-0.10.so.0  			libgstreamer-0.10.so.0  
    						libgstvideo-0.10.so.0  
    libgthread-2.0.so.0  				libgthread-2.0.so.0  
    libgtk-x11-2.0.so.0  
    libhal.so.1  
    libmusicbrainz.so.4  
    libnautilus-burn.so.4  
    libpango-1.0.so.0  				libpango-1.0.so.0  
    libpangocairo-1.0.so.0  			libpangocairo-1.0.so.0  
    libpthread.so.0  				libpthread.so.0  
    librt.so.1  					librt.so.1  
    libxml2.so.2  					libxml2.so.2  
    						mono(ICSharpCode.SharpZipLib) = 2.84.0.0
    						mono(Mono.Addins) = 0.3.0.0
    						mono(Mono.Addins.Gui) = 0.3.0.0
    						mono(Mono.Addins.Setup) = 0.3.0.0
    mono(Mono.Cairo) = 2.0.0.0			mono(Mono.Cairo) = 2.0.0.0
    mono(Mono.Data.SqliteClient) = 2.0.0.0		mono(Mono.Data.SqliteClient) = 2.0.0.0
    mono(Mono.Posix) = 2.0.0.0			mono(Mono.Posix) = 2.0.0.0
    mono(NDesk.DBus) = 1.0.0.0			mono(NDesk.DBus) = 1.0.0.0
    mono(NDesk.DBus.GLib) = 1.0.0.0			mono(NDesk.DBus.GLib) = 1.0.0.0
    mono(System) = 1.0.5000.0
    mono(System) = 2.0.0.0				mono(System) = 2.0.0.0
    mono(System.Data) = 2.0.0.0			mono(System.Data) = 2.0.0.0
    						mono(System.Web) = 2.0.0.0
    mono(System.Xml) = 1.0.5000.0
    mono(System.Xml) = 2.0.0.0			mono(System.Xml) = 2.0.0.0
    mono(gconf-sharp) = 2.16.0.0
    mono(gdk-sharp) = 2.10.0.0			mono(gdk-sharp) = 2.10.0.0
    mono(glade-sharp) = 2.10.0.0			mono(glade-sharp) = 2.10.0.0
    mono(glib-sharp) = 2.10.0.0			mono(glib-sharp) = 2.10.0.0
    mono(gnome-sharp) = 2.16.0.0
    mono(gnome-vfs-sharp) = 2.16.0.0
    mono(gtk-sharp) = 2.10.0.0			mono(gtk-sharp) = 2.10.0.0
    mono(mscorlib) = 1.0.5000.0
    mono(mscorlib) = 2.0.0.0			mono(mscorlib) = 2.0.0.0
    mono(pango-sharp) = 2.10.0.0			mono(pango-sharp) = 2.10.0.0
    						mono(taglib-sharp) = 2.0.3.0
    rpmlib(PayloadIsBzip2) <= 3.0.5-1		rpmlib(PayloadIsBzip2) <= 3.0.5-1
    Jim Matthews
    desktop: OpenSuSE 11.4-64 Gnome 3.0 GHz Athlon II X4 640 8 GB M4A88TD-V
    laptop: OpenSuSE 12.3-64 Gnome 1.9 GHz Tur64 X2 2 GB nVIDIA GeForce 7000M
    netbook: OpenSuSE 11.4-64 Gnome 1.66 GHz Atom N450 2 GB GMA 3150

  4. #4
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    25,701
    Blog Entries
    29

    Default Re: Banshee-1 dependency probs with OpenSuSE 10.3

    Quote Originally Posted by bjmsam View Post
    For my relatively vanilla OpenSuSE 10.3 load with Banshee 0.13.2, Mono 1.2.5 and Gnome Media 2.20.1 installed, YaST reports the following errors for the one-click installer at Banshee Download:
    OK, reading this again, you are trying to install Banshee from the Banshee Download site.

    I think you should try sort those dependency errors, one by one. Which means locate the missing dependencies from:
    pattern:gnome_multimedia has missing dependencies
    banshee-engine-gst has missing dependencies
    banshee-plugins-extra has missing dependencies
    banshee-plugins-default has missing dependencies
    banshee-plugins-DAAP has missing dependencies


    Note: gst = gstreamer .. hence the "banshee-engine-gst has missing dependencies" suggests to me the "one-click" tried to install banshee-1-backend-engine-gstreamer-1.0.0-3.3.i586.rpm, but it could not, because it in turn had dependency problems.

    ... the other errors are likely conceptually similar.

    Have you checked your repos? What does:
    zypper lr
    give for repose?

  5. #5
    Join Date
    Jun 2008
    Location
    Mount Airy, MD
    Posts
    25

    Default Re: Banshee-1 dependency probs with OpenSuSE 10.3

    Code:
    > zypper lr
    #  | Enabled | Refresh | Type   | Alias                                                             | Name                        
    ---+---------+---------+--------+-------------------------------------------------------------------+-----------------------------
    1  | Yes     | Yes     | rpm-md | openSUSE-10.3-Updates                                             | openSUSE-10.3-Updates       
    2  | Yes     | Yes     | rpm-md | Packman Repository                                                | Packman Repository          
    3  | Yes     | Yes     | yast2  | http://download.opensuse.org/repositories/openSUSE:10.3/standard/ | Main Repository (OSS)       
    4  | Yes     | Yes     | rpm-md | Banshee                                                           | Banshee                     
    5  | Yes     | No      | yast2  | Repository                                                        | Repository                  
    6  | Yes     | Yes     | rpm-md | ATI Repository                                                    | ATI Repository              
    7  | Yes     | No      | yast2  | openSUSE-10.3-OSS-Gnome 10.3                                      | openSUSE-10.3-OSS-Gnome 10.3
    8  | Yes     | Yes     | NONE   | VideoLan Repository                                               | VideoLan Repository         
    9  | Yes     | Yes     | yast2  | http://download.opensuse.org/distribution/10.3/repo/non-oss/      | Main Repository (NON-OSS)   
    10 | Yes     | Yes     | rpm-md | Mozilla_beta                                                      | Mozilla beta                
    11 | Yes     | Yes     | rpm-md | Mozilla                                                           | Mozilla
    Jim Matthews
    desktop: OpenSuSE 11.4-64 Gnome 3.0 GHz Athlon II X4 640 8 GB M4A88TD-V
    laptop: OpenSuSE 12.3-64 Gnome 1.9 GHz Tur64 X2 2 GB nVIDIA GeForce 7000M
    netbook: OpenSuSE 11.4-64 Gnome 1.66 GHz Atom N450 2 GB GMA 3150

  6. #6
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    25,701
    Blog Entries
    29

    Default Re: Banshee-1 dependency probs with OpenSuSE 10.3

    As I noted above, I am not a Gnome user. But looking at your zypper repos list, I think you should check the URL of your openSUSE-10.3-OSS-Gnome-10.3 repos, and ensure it is valid. Sometimes Refresh=NO can indicate a problem.

    Also, sometimes Packman can conflict with VideoLan. I recommend you set VideoLan repos to disabled, and then try again to install banshee. Do you get the same errors? If not, record the difference.

    If disabling VideoLan did not help, then do the opposite. Re-enable VideoLan and disable Packman, and then try again to install banshee. Do you get the same errors? If not, record the difference.

  7. #7
    Join Date
    Jun 2008
    Location
    Mount Airy, MD
    Posts
    25

    Default Re: Banshee-1 dependency probs with OpenSuSE 10.3

    The repos with Refresh=No are CDROM sources. YaST produces identical dependency messages when VideoLan and Packman are individually disabled.

    Perhaps openSuSE 11.0 will be less frustrating.

    Quote Originally Posted by Novell
    If you'd like to switch from Windows to Linux, but have absolutely no interest in chmoding or chowning anything, check out openSUSE 11.0 from Novell. This is a friendly sort of Linux you can put on your home computers without having a geek at your house. Get all the advantages of Linux without all the ack and sed. Your family will love it, and you won't have to grok anything you don't want to.
    Jim Matthews
    desktop: OpenSuSE 11.4-64 Gnome 3.0 GHz Athlon II X4 640 8 GB M4A88TD-V
    laptop: OpenSuSE 12.3-64 Gnome 1.9 GHz Tur64 X2 2 GB nVIDIA GeForce 7000M
    netbook: OpenSuSE 11.4-64 Gnome 1.66 GHz Atom N450 2 GB GMA 3150

  8. #8
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    25,701
    Blog Entries
    29

    Default Re: Banshee-1 dependency probs with OpenSuSE 10.3

    Quote Originally Posted by bjmsam View Post
    The repos with Refresh=No are CDROM sources. YaST produces identical dependency messages when VideoLan and Packman are individually disabled. Perhaps openSuSE 11.0 will be less frustrating.
    Again, typically when one gets such dependency problems, it is because:
    * a repository server is down, or
    * one is missing an important repository in their package manager, or
    * one has too many repositories in their package manager, which can cause conflicting packages, or
    * the rpm packager made a mistake.
    I suspect this is tied into your openSUSE needing applications, and needing specific versions of applications, that are not currently in your repositories that are in your zypper/yast.

    What you are experiencing is not unusual, when trying to go for the newest most cutting edge version of an application. If you wait some time (weeks to months) I'm pretty confident this will be sorted. .... Its just you are trying hard to install the latest cutting edge version. This simply comes with the territory.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •